]> git.pld-linux.org Git - packages/php-pecl-imagick.git/blame - php-pecl-imagick.spec
BR update
[packages/php-pecl-imagick.git] / php-pecl-imagick.spec
CommitLineData
a70f8547
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
77bd0b10
ER
5%define php_name php%{?php_suffix}
6%define modname imagick
c3cb436b
ER
7%define status stable
8Summary: %{modname} - PHP wrapper to the Image Magick Library
9Summary(pl.UTF-8): %{modname} - PHP-owy wrapper do biblioteki Image Magick
77bd0b10 10Name: %{php_name}-pecl-%{modname}
a0d47040 11Version: 3.4.2
b65e8485 12Release: 3
80c4878b 13License: PHP 3.01
7ef11872 14Group: Development/Languages/PHP
c3cb436b 15Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
a0d47040 16# Source0-md5: 3f80e35c2434636cdb5df01b221b3ffa
4baa9e02 17Patch0: skip_version_check.patch
b46c9cbe 18URL: http://pecl.php.net/package/imagick/
4c078d1b 19BuildRequires: %{php_name}-devel >= 4:5.3
30d818b5 20BuildRequires: ImageMagick-devel >= 1:6.2.4.0
58592d83
ER
21BuildRequires: pkgconfig
22BuildRequires: re2c
696a2b4e 23BuildRequires: rpmbuild(macros) >= 1.650
a70f8547
ER
24%if %{with tests}
25BuildRequires: %{php_name}-cli
501a42f6 26BuildRequires: %{php_name}-pcre
a70f8547 27BuildRequires: %{php_name}-spl
4dc1d668
ER
28BuildRequires: ImageMagick-coder-jpeg
29BuildRequires: ImageMagick-coder-png
30BuildRequires: ImageMagick-coder-tiff
a70f8547 31%endif
dbfce4b3 32%{?requires_php_extension}
ac93969d 33Requires(triggerpostun): sed >= 4.0
b65e8485 34Requires: %{php_name}-spl
6e32b6ae
ER
35Suggests: ImageMagick-coder-jpeg
36Suggests: ImageMagick-coder-png
37Suggests: ImageMagick-coder-tiff
ee3b6a5c 38Provides: php(imagick) = %{version}
c056a9a3 39Obsoletes: php-pecl-imagick < 3.1.2-2
7ef11872 40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
7ef11872 42%description
43ImageMagick is a robust collection of tools and libraries to read,
44write, and manipulate an image in many image formats (over 68 major
45formats) including popular formats like TIFF, JPEG, PNG, PDF, PhotoCD,
46and GIF. With ImageMagick you can create images dynamically, making it
47suitable for Web applications. You can also resize, rotate, sharpen,
48color reduce, or add special effects to an image and save your
49completed work in the same or differing image format.
50
c3cb436b 51In PECL status of this package is: %{status}.
3fd56945 52
98a194af
JR
53%description -l pl.UTF-8
54ImageMagick to duży zestaw narzędzi i bibliotek do odczytu, zapisu i
55modyfikowania obrazków w wielu formatach (ponad 68 głównych), w tym
56popularnych, takich jak TIFF, JPEG, PNG, PDF, PhotoCD i GIF. Za pomocą
57ImageMagick można dynamicznie tworzyć obrazki, co jest przydatne w
58aplikacjach WWW. Można je także przeskalowywać, obracać, wyostrzać,
59zmniejszać ilość kolorów - w tym samym lub innym formacie.
7ef11872 60
c3cb436b 61To rozszerzenie ma w PECL status: %{status}.
3fd56945 62
7ef11872 63%prep
4baa9e02 64%setup -qc
c3cb436b 65mv %{modname}-%{version}/* .
4baa9e02 66%patch0 -p1
7ef11872 67
f5c1a0f1
ER
68# skip failing tests
69Test() {
70 nf=$(eval echo \$$#)
71 t=$nf; t=${t#\[}; t=${t%\]}
72 mv $t $t.skip
73}
74Test Imagick, annotateImage [tests/034_Imagick_annotateImage_basic.phpt]
75Test ImagickDraw, composite [tests/177_ImagickDraw_composite_basic.phpt]
76Test ImagickDraw, setFontSize [tests/206_ImagickDraw_setFontSize_basic.phpt]
77Test ImagickDraw, setFontFamily [tests/207_ImagickDraw_setFontFamily_basic.phpt]
78Test ImagickDraw, setFontStretch [tests/208_ImagickDraw_setFontStretch_basic.phpt]
79Test ImagickDraw, setFontWeight [tests/209_ImagickDraw_setFontWeight_basic.phpt]
80Test ImagickDraw, setFontStyle [tests/210_ImagickDraw_setFontStyle_basic.phpt]
81Test ImagickDraw, setGravity [tests/212_ImagickDraw_setGravity_basic.phpt]
82Test ImagickDraw, setTextAlignment [tests/222_ImagickDraw_setTextAlignment_basic.phpt]
83Test ImagickDraw, setTextAntialias [tests/223_ImagickDraw_setTextAntialias_basic.phpt]
84Test ImagickDraw, setTextUnderColor [tests/224_ImagickDraw_setTextUnderColor_basic.phpt]
85Test ImagickDraw, setTextDecoration [tests/225_ImagickDraw_setTextDecoration_basic.phpt]
86Test Tutorial, psychedelicFont [tests/241_Tutorial_psychedelicFont_basic.phpt]
87Test Tutorial, svgExample [tests/243_Tutorial_svgExample_basic.phpt]
88Test Tutorial, psychedelicFontGif [tests/244_Tutorial_psychedelicFontGif_basic.phpt]
89
7ef11872 90%build
7ef11872 91phpize
4f203515
JR
92%configure \
93 php_cv_cc_dashr=false
7ef11872 94
bc18093b 95%{__make} \
bc18093b 96 CFLAGS_CLEAN="%{rpmcflags}"
7ef11872 97
a70f8547
ER
98%if %{with tests}
99%{__php} -n -q \
100 -d extension_dir=modules \
501a42f6 101 -d extension=%{php_extensiondir}/pcre.so \
a70f8547
ER
102 -d extension=%{php_extensiondir}/spl.so \
103 -d extension=%{modname}.so \
104 -m > modules.log
105grep %{modname} modules.log
106
107export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
108%{__make} test \
109 PHP_EXECUTABLE=%{__php} \
501a42f6 110 PHP_TEST_SHARED_SYSTEM_EXTENSIONS="pcre spl" \
a70f8547
ER
111%endif
112
7ef11872 113%install
114rm -rf $RPM_BUILD_ROOT
be7cd71f 115install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
c3cb436b
ER
116install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
117cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
118; Enable %{modname} extension module
119extension=%{modname}.so
dbfce4b3 120EOF
be7cd71f 121cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
7ef11872 122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post
f7ead91e 127%php_webserver_restart
7ef11872 128
dbfce4b3
ER
129%postun
130if [ "$1" = 0 ]; then
f7ead91e 131 %php_webserver_restart
7ef11872 132fi
133
dbfce4b3 134%triggerpostun -- %{name} < 0.9.11-2.1
c3cb436b 135%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*%{modname}\.so/d' %{php_sysconfdir}/php.ini
dbfce4b3 136
7ef11872 137%files
138%defattr(644,root,root,755)
1fe13cac 139%doc CREDITS
c3cb436b
ER
140%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
141%attr(755,root,root) %{php_extensiondir}/%{modname}.so
be7cd71f 142%{_examplesdir}/%{name}-%{version}
This page took 0.049166 seconds and 4 git commands to generate.