]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
ensure new openssl version
[packages/openssh.git] / openssh.spec
CommitLineData
2ebfbf87 1#
2ca913e8 2# Conditional build:
f6c7fa07 3%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
cd53fc87 4%bcond_without gtk # without GTK+ (2.x)
b32891d6 5%bcond_without ldap # with ldap support
f6c7fa07 6%bcond_without libedit # without libedit (editline/history support in sftp client)
9cfed0b2 7%bcond_without kerberos5 # without kerberos5 support
70329622 8%bcond_without selinux # build without SELinux support
5c609334 9%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
516496e1 10
cef904f1
JB
11# gtk2-based gnome-askpass means no gnome1-based
12%{?with_gtk:%undefine with_gnome}
cc788d8e 13
2ebfbf87
ER
14%if "%{pld_release}" == "ac"
15%define pam_ver 0.79.0
16%else
17%define pam_ver 0.99.7.1
18%endif
19
52000378 20Summary: OpenSSH free Secure Shell (SSH) implementation
25e16946
ER
21Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
22Summary(es.UTF-8): Implementación libre de SSH
23Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
24Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
25Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
26Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27Summary(pt_BR.UTF-8): Implementação livre do SSH
28Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
29Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
52000378 30Name: openssh
49801d06 31Version: 5.8p1
f734da5b 32Release: 9
f5fc6a92 33Epoch: 2
5d1c7089 34License: BSD
35Group: Applications/Networking
6481986b 36Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
49801d06 37# Source0-md5: 86f5e1c23b4c4845f23b9b7b493fb53d
486d736c
JR
38Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39# Source1-md5: 66943d481cc422512b537bcc2c7400d1
40Source2: %{name}d.init
41Source3: %{name}d.pamd
42Source4: %{name}.sysconfig
43Source5: ssh-agent.sh
44Source6: ssh-agent.conf
b32891d6 45Source7: %{name}-lpk.schema
c0f446a0 46Source8: %{name}d.upstart
2ebfbf87 47Patch100: %{name}-heimdal.patch
89eac7b5 48Patch0: %{name}-no_libnsl.patch
8d59ede4
JB
49Patch2: %{name}-pam_misc.patch
50Patch3: %{name}-sigpipe.patch
b32891d6
JR
51# http://code.google.com/p/openssh-lpk/
52Patch4: %{name}-lpk.patch
8d59ede4 53Patch5: %{name}-config.patch
0a069c2e 54# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
0d5b2bd4
ER
55# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56Patch9: %{name}-5.2p1-hpn13v6.diff
8d59ede4 57Patch10: %{name}-include.patch
100234b3 58Patch11: %{name}-chroot.patch
342ae3ba 59# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
cc788d8e 60Patch12: %{name}-blacklist.diff
92dc7c43 61Patch13: %{name}-kuserok.patch
c5eb8e82 62URL: http://www.openssh.com/portable.html
0a069c2e 63BuildRequires: %{__perl}
92d612e6 64BuildRequires: autoconf
8f12ae30 65BuildRequires: automake
9cfed0b2 66%{?with_gnome:BuildRequires: gnome-libs-devel}
67%{?with_gtk:BuildRequires: gtk+2-devel}
044fff96 68%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
f6c7fa07 69%{?with_libedit:BuildRequires: libedit-devel}
70329622 70%{?with_selinux:BuildRequires: libselinux-devel}
a14c109c 71BuildRequires: libwrap-devel
044fff96 72%{?with_ldap:BuildRequires: openldap-devel}
f734da5b 73BuildRequires: openssl-devel >= 1.0.2
92d612e6 74BuildRequires: pam-devel
9cfed0b2 75%{?with_gtk:BuildRequires: pkgconfig}
2ebfbf87 76BuildRequires: rpm >= 4.4.9-56
9be30b5d 77BuildRequires: rpmbuild(macros) >= 1.318
a42c5034 78BuildRequires: sed >= 4.0
a14c109c 79BuildRequires: zlib-devel
2ebfbf87
ER
80%if "%{pld_release}" == "ac"
81Requires: filesystem >= 2.0-1
82Requires: pam >= 0.79.0
83%else
680fc8d4 84Requires: filesystem >= 3.0-11
2ebfbf87 85Requires: pam >= %{pam_ver}
35844bbb 86Suggests: openssh-blacklist
a9abed26 87Suggests: xorg-app-xauth
2ebfbf87 88%endif
f937b661 89Obsoletes: ssh
05fbd2e9 90BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52000378 91
b7b47957 92%define _sysconfdir /etc/ssh
1dd7cf18 93%define _libexecdir %{_libdir}/%{name}
a14c109c 94%define _privsepdir /usr/share/empty
b32891d6 95%define schemadir /usr/share/openldap/schema
6fe24471 96
c0f446a0
JK
97## to be moved to rpm-build-macros
98## TODO: handle RPM_SKIP_AUTO_RESTART
99
100# migrate from init script to upstart job
101%define upstart_post() \
102 if [ -f /var/lock/subsys/"%1" ] ; then \
103 /sbin/service --no-upstart "%1" stop \
104 /sbin/service "%1" start \
105 else \
106 /sbin/service "%1" try-restart \
107 fi
108
109# restart the job after upgrade or migrate to init script on removal
110%define upstart_postun() \
111 if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
112 /sbin/initctl stop "%1" 2>/dev/null \
113 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
114 fi
115
116
6fe24471
AF
117%description
118Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 119executing commands in a remote machine. It is intended to replace
120rlogin and rsh, and provide secure encrypted communications between
121two untrusted hosts over an insecure network. X11 connections and
122arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 123
11530f15 124OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
125it up to date in terms of security and features, as well as removing
126all patented algorithms to seperate libraries (OpenSSL).
6fe24471 127
11530f15 128This package includes the core files necessary for both the OpenSSH
129client and server. To make this package useful, you should also
130install openssh-clients, openssh-server, or both.
a42c5034 131
0d5b2bd4 132%if %{with hpn}
0a069c2e 133This release includes High Performance SSH/SCP patches from
a42c5034
ER
134http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
135increase throughput on fast connections with high RTT (20-150 msec).
088aab43 136See the website for '-w' values for your connection and /proc/sys TCP
137values. BTW. in a LAN you have got generally RTT < 1 msec.
138%endif
6fe24471 139
84ae85a3 140%description -l de.UTF-8
aebfac88
JB
141OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
142ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
84ae85a3
JR
143verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
144über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
145andere TCP/IP Ports können ebenso über den sicheren Channel
aebfac88
JB
146weitergeleitet werden.
147
84ae85a3
JR
148%description -l es.UTF-8
149SSH es un programa para accesar y ejecutar órdenes en computadores
150remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
6c34819e 151seguro entre dos servidores en una red insegura. Conexiones X11 y
84ae85a3 152puertas TCP/IP arbitrárias también pueden ser usadas por el canal
6c34819e 153seguro.
154
155OpenSSH es el resultado del trabajo del equipo de OpenBSD para
84ae85a3
JR
156continuar la última versión gratuita de SSH, actualizándolo en
157términos de seguridad y recursos,así también eliminando todos los
158algoritmos patentados y colocándolos en bibliotecas separadas
6c34819e 159(OpenSSL).
160
161Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
84ae85a3 162también el paquete openssh-clients u openssh-server o ambos.
6c34819e 163
84ae85a3
JR
164%description -l fr.UTF-8
165OpenSSH (Secure Shell) fournit un accès à un système distant. Il
aebfac88 166remplace telnet, rlogin, rexec et rsh, tout en assurant des
84ae85a3
JR
167communications cryptées securisées entre deux hôtes non fiabilisés sur
168un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
169arbitraires peuvent également être transmis sur le canal sécurisé.
aebfac88 170
84ae85a3 171%description -l it.UTF-8
aebfac88
JB
172OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
173Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
174sicure e crittate tra due host non fidati su una rete non sicura. Le
175connessioni X11 ad una porta TCP/IP arbitraria possono essere
176inoltrate attraverso un canale sicuro.
177
84ae85a3
JR
178%description -l pl.UTF-8
179Ssh (Secure Shell) to program służący do logowania się na zdalną
180maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
181zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
182pomiędzy dwoma hostami.
93e2d77c 183
84ae85a3
JR
184Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
185klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
186co najmniej jeden z pakietów: openssh-clients lub openssh-server.
a42c5034 187
0d5b2bd4 188%if %{with hpn}
84ae85a3
JR
189Ta wersja zawiera łaty z projektu High Performance SSH/SCP
190http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
a42c5034
ER
191zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
192RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
193danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
194TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
088aab43 195%endif
aebfac88 196
84ae85a3 197%description -l pt.UTF-8
aebfac88 198OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
84ae85a3
JR
199telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
200cifradas entre duas máquinas sem confiança mútua sobre uma rede
201insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
aebfac88
JB
202reenviados pelo canal seguro.
203
84ae85a3
JR
204%description -l pt_BR.UTF-8
205SSH é um programa para acessar e executar comandos em máquinas
206remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
207seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
208TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
6c34819e 209
84ae85a3
JR
210OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
211última versão gratuita do SSH, atualizando-o em termos de segurança e
6c34819e 212recursos, assim como removendo todos os algoritmos patenteados e
213colocando-os em bibliotecas separadas (OpenSSL).
214
84ae85a3
JR
215Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
216também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
217
218%description -l ru.UTF-8
219Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
220машину и для выполнения команд на удаленной машине. Она предназначена
221для замены rlogin и rsh и обеспечивает безопасную шифрованную
222коммуникацию между двумя хостами в сети, являющейся небезопасной.
223Соединения X11 и любые порты TCP/IP могут также быть проведены через
224безопасный канал.
225
226OpenSSH - это переделка командой разработчиков OpenBSD последней
227свободной версии SSH, доведенная до современного состояния в терминах
228уровня безопасности и поддерживаемых возможностей. Все патентованные
229алгоритмы вынесены в отдельные библиотеки (OpenSSL).
230
231Этот пакет содержит файлы, необходимые как для клиента, так и для
232сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
233openssh-server, или оба пакета.
234
235%description -l uk.UTF-8
236Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
237машини та для виконання команд на віддаленій машині. Вона призначена
238для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
239між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
240довільні порти TCP/IP можуть також бути проведені через безпечний
241канал.
242
243OpenSSH - це переробка командою розробників OpenBSD останньої вільної
244версії SSH, доведена до сучасного стану в термінах рівня безпеки та
245підтримуваних можливостей. Всі патентовані алгоритми винесені до
246окремих бібліотек (OpenSSL).
247
248Цей пакет містить файли, необхідні як для клієнта, так і для сервера
249OpenSSH. Вам потрібно буде ще встановити openssh-clients,
250openssh-server, чи обидва пакети.
cb086001 251
52000378
AF
252%package clients
253Summary: OpenSSH Secure Shell protocol clients
25e16946
ER
254Summary(es.UTF-8): Clientes de OpenSSH
255Summary(pl.UTF-8): Klienci protokołu Secure Shell
256Summary(pt_BR.UTF-8): Clientes do OpenSSH
257Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
258Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
52000378 259Group: Applications/Networking
f1608a0c 260Requires: %{name}
516496e1 261Provides: ssh-clients
a14c109c 262Obsoletes: ssh-clients
6fe24471 263
52000378
AF
264%description clients
265Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 266executing commands in a remote machine. It is intended to replace
267rlogin and rsh, and provide secure encrypted communications between
268two untrusted hosts over an insecure network. X11 connections and
269arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 270
11530f15 271OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
272it up to date in terms of security and features, as well as removing
273all patented algorithms to seperate libraries (OpenSSL).
52000378 274
11530f15 275This package includes the clients necessary to make encrypted
276connections to SSH servers.
52000378 277
84ae85a3 278%description clients -l es.UTF-8
6c34819e 279Este paquete incluye los clientes que se necesitan para hacer
280conexiones codificadas con servidores SSH.
281
84ae85a3
JR
282%description clients -l pl.UTF-8
283Ssh (Secure Shell) to program służący do logowania się na zdalną
284maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
285zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
286pomiędzy dwoma hostami.
93e2d77c 287
84ae85a3 288Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
93e2d77c 289
84ae85a3
JR
290%description clients -l pt_BR.UTF-8
291Esse pacote inclui os clientes necessários para fazer conexões
6c34819e 292encriptadas com servidores SSH.
293
84ae85a3
JR
294%description clients -l ru.UTF-8
295Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
296машину и для выполнения команд на удаленной машине.
cb086001 297
84ae85a3
JR
298Этот пакет содержит программы-клиенты, необходимые для установления
299зашифрованных соединений с серверами SSH.
cb086001 300
84ae85a3
JR
301%description clients -l uk.UTF-8
302Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
303машини та для виконання команд на віддаленій машині.
cb086001 304
84ae85a3
JR
305Цей пакет містить програми-клієнти, необхідні для встановлення
306зашифрованих з'єднань з серверами SSH.
cb086001 307
8a7ba6eb
AM
308%package clients-agent-profile_d
309Summary: OpenSSH Secure Shell agent init script
4944be5f 310Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
8a7ba6eb
AM
311Group: Applications/Networking
312Requires: %{name}-clients = %{epoch}:%{version}-%{release}
313
314%description clients-agent-profile_d
315profile.d scripts for starting SSH agent.
316
4944be5f
JB
317%description clients-agent-profile_d -l pl.UTF-8
318Skrypty profile.d do uruchamiania agenta SSH.
319
8a7ba6eb
AM
320%package clients-agent-xinitrc
321Summary: OpenSSH Secure Shell agent init script
322Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
323Group: Applications/Networking
324Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
325Requires: xinitrc
326
327%description clients-agent-xinitrc
328xinitrc scripts for starting SSH agent.
329
4944be5f
JB
330%description clients-agent-xinitrc -l pl.UTF-8
331Skrypty xinitrc do uruchamiania agenta SSH.
8a7ba6eb 332
52000378
AF
333%package server
334Summary: OpenSSH Secure Shell protocol server (sshd)
25e16946
ER
335Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
336Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
337Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
338Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
339Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
340Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
341Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
342Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
343Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
52000378 344Group: Networking/Daemons
2ebfbf87 345Requires(post): /sbin/chkconfig
40cb2e83 346Requires(post): grep
0a069c2e 347Requires(post,preun): /sbin/chkconfig
9b604401 348Requires(postun): /usr/sbin/userdel
0a069c2e
ER
349Requires(pre): /bin/id
350Requires(pre): /usr/sbin/useradd
351Requires: %{name} = %{epoch}:%{version}-%{release}
f734da5b 352Requires: openssl >= 1.0.2
2ebfbf87 353Requires: pam >= %{pam_ver}
c0f446a0 354Requires: rc-scripts >= 0.4.3.0
0a069c2e 355Requires: util-linux
0d5b2bd4 356Suggests: /bin/login
516496e1
ER
357Provides: ssh-server
358Provides: user(sshd)
52000378
AF
359
360%description server
361Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 362executing commands in a remote machine. It is intended to replace
363rlogin and rsh, and provide secure encrypted communications between
364two untrusted hosts over an insecure network. X11 connections and
365arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 366
11530f15 367OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
368it up to date in terms of security and features, as well as removing
369all patented algorithms to seperate libraries (OpenSSL).
52000378 370
11530f15 371This package contains the secure shell daemon. The sshd is the server
372part of the secure shell protocol and allows ssh clients to connect to
373your host.
6fe24471 374
84ae85a3 375%description server -l de.UTF-8
aebfac88
JB
376Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
377
84ae85a3 378%description server -l es.UTF-8
6c34819e 379Este paquete contiene el servidor SSH. sshd es la parte servidor del
380protocolo secure shell y permite que clientes ssh se conecten a su
381servidor.
382
84ae85a3 383%description server -l fr.UTF-8
aebfac88
JB
384Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
385
84ae85a3 386%description server -l it.UTF-8
aebfac88
JB
387Questo pacchetto installa sshd, il server di OpenSSH.
388
84ae85a3
JR
389%description server -l pl.UTF-8
390Ssh (Secure Shell) to program służący do logowania się na zdalną
391maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
392zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
393pomiędzy dwoma hostami.
93e2d77c 394
84ae85a3 395Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
11530f15 396ssh).
93e2d77c 397
84ae85a3 398%description server -l pt.UTF-8
aebfac88
JB
399Este pacote intala o sshd, o servidor do OpenSSH.
400
84ae85a3
JR
401%description server -l pt_BR.UTF-8
402Esse pacote contém o servidor SSH. O sshd é a parte servidor do
6c34819e 403protocolo secure shell e permite que clientes ssh se conectem ao seu
404host.
405
84ae85a3
JR
406%description server -l ru.UTF-8
407Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
408машину и для выполнения команд на удаленной машине.
cb086001 409
84ae85a3
JR
410Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
411часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
412вашим хостом.
cb086001 413
84ae85a3
JR
414%description server -l uk.UTF-8
415Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
416машини та для виконання команд на віддаленій машині.
cb086001 417
84ae85a3
JR
418Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
419частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
420з вашим хостом.
cb086001 421
c0f446a0
JK
422%package server-upstart
423Summary: Upstart job description for OpenSSH server
424Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
425Group: Daemons
426Requires: %{name}-server = %{epoch}:%{version}-%{release}
427Requires: upstart >= 0.6
428
429%description server-upstart
430Upstart job description for OpenSSH.
431
432%description server-upstart -l pl.UTF-8
433Opis zadania Upstart dla OpenSSH.
434
6e70f4f7 435%package gnome-askpass
52000378 436Summary: OpenSSH GNOME passphrase dialog
25e16946
ER
437Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
438Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
439Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
440Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
441Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
442Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
443Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
444Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
445Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
52000378 446Group: Applications/Networking
96f686c2 447Requires: %{name} = %{epoch}:%{version}-%{release}
f937b661 448Obsoletes: openssh-askpass
0a069c2e
ER
449Obsoletes: ssh-askpass
450Obsoletes: ssh-extras
52000378 451
6e70f4f7 452%description gnome-askpass
52000378 453Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 454executing commands in a remote machine. It is intended to replace
455rlogin and rsh, and provide secure encrypted communications between
456two untrusted hosts over an insecure network. X11 connections and
457arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 458
11530f15 459OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
460it up to date in terms of security and features, as well as removing
461all patented algorithms to seperate libraries (OpenSSL).
52000378
AF
462
463This package contains the GNOME passphrase dialog.
464
84ae85a3
JR
465%description gnome-askpass -l es.UTF-8
466Este paquete contiene un programa que abre una caja de diálogo para
6c34819e 467entrada de passphrase en GNOME.
468
84ae85a3
JR
469%description gnome-askpass -l pl.UTF-8
470Ssh (Secure Shell) to program służący do logowania się na zdalną
471maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
472zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
473pomiędzy dwoma hostami.
93e2d77c 474
84ae85a3 475Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
93e2d77c 476
84ae85a3
JR
477%description gnome-askpass -l pt_BR.UTF-8
478Esse pacote contém um programa que abre uma caixa de diálogo para
6c34819e 479entrada de passphrase no GNOME.
480
84ae85a3
JR
481%description gnome-askpass -l ru.UTF-8
482Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
483машину и для выполнения команд на удаленной машине.
cb086001 484
84ae85a3 485Этот пакет содержит диалог ввода ключевой фразы для использования под
cb086001 486GNOME.
487
84ae85a3
JR
488%description gnome-askpass -l uk.UTF-8
489Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
490машини та для виконання команд на віддаленій машині.
cb086001 491
84ae85a3 492Цей пакет містить діалог вводу ключової фрази для використання під
cb086001 493GNOME.
494
b32891d6
JR
495%package -n openldap-schema-openssh-lpk
496Summary: OpenSSH LDAP Public Key schema
497Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
498Group: Networking/Daemons
499Requires(post,postun): sed >= 4.0
500Requires: openldap-servers
501
502%description -n openldap-schema-openssh-lpk
503This package contains OpenSSH LDAP Public Key schema for openldap.
504
505%description -n openldap-schema-openssh-lpk -l pl.UTF-8
0d5b2bd4
ER
506Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
507openldap-a.
b32891d6 508
52000378 509%prep
ecf377a3 510%setup -q
2ebfbf87 511%{?with_kerberos5:%patch100 -p1}
4946f6e5 512%patch0 -p1
1aca01a4 513%patch2 -p1
200ba837 514%patch3 -p1
8d59ede4
JB
515%{?with_ldap:%patch4 -p1}
516%patch5 -p1
516496e1 517%{?with_hpn:%patch9 -p1}
8d59ede4 518%patch10 -p1
100234b3 519%patch11 -p1
35844bbb 520%patch12 -p1
92dc7c43 521%patch13 -p1
52000378 522
57f5c94e 523cp -p %{SOURCE3} sshd.pam
95191792 524install -p %{SOURCE2} sshd.init
55c2af60 525
a42c5034
ER
526%if "%{pld_release}" == "ac"
527# fix for missing x11.pc
528%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
55c2af60 529# not present in ac, no point searching it
57f5c94e 530%{__sed} -i -e '/pam_keyinit.so/d' sshd.pam
a42c5034
ER
531%endif
532
73b6bc9f
ER
533# OSSH_PATH_ENTROPY_PROG gets undefined if aclocal gets overwritten
534mv aclocal.m4 acinclude.m4
535
52000378 536%build
64f1c35c 537cp /usr/share/automake/config.sub .
0b24ec17 538%{__aclocal}
5c76eb87 539%{__autoconf}
37aa5700 540CPPFLAGS="-DCHROOT"
52000378 541%configure \
c59fae24 542 PERL=%{__perl} \
41897191
AM
543 --with-pam \
544 --with-mantype=man \
f9bf943b 545 --with-md5-passwords \
4946f6e5 546 --with-ipaddr-display \
f6c7fa07 547 %{?with_libedit:--with-libedit} \
93e2d77c 548 --with-4in6 \
06b95d40 549 --with-tcp-wrappers \
9cfed0b2 550 %{?with_ldap:--with-libs="-lldap -llber"} \
551 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
4a5c0c7d 552 %{?with_kerberos5:--with-kerberos5=/usr} \
a14c109c 553 --with-privsep-path=%{_privsepdir} \
05fbd2e9 554 --with-pid-dir=%{_localstatedir}/run \
2ebfbf87
ER
555%if "%{pld_release}" == "ac"
556 --with-xauth=/usr/X11R6/bin/xauth \
557%else
f1344723 558 --with-xauth=%{_bindir}/xauth \
2ebfbf87 559%endif
c7963a12
JR
560 --enable-utmpx \
561 --enable-wtmpx
82f989ae 562
b8002dec 563echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
f9bf943b 564
100832a0 565%{__make}
475ef6df 566
40cb2e83 567cd contrib
9cfed0b2 568%if %{with gnome}
40cb2e83
JB
569%{__make} gnome-ssh-askpass1 \
570 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
571%endif
9cfed0b2 572%if %{with gtk}
40cb2e83
JB
573%{__make} gnome-ssh-askpass2 \
574 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
575%endif
6fe24471
AF
576
577%install
578rm -rf $RPM_BUILD_ROOT
c0f446a0 579install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
b32891d6 580 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
8a7ba6eb 581install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
52000378 582
9a2a459a
PG
583%{__make} install \
584 DESTDIR=$RPM_BUILD_ROOT
0d32b20f 585
486d736c 586bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
40cb2e83 587
95191792 588install -p sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
55c2af60
ER
589cp -p sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
590cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
591cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
486d736c 592ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
55c2af60
ER
593cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
594cp -p %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
595cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
c0f446a0 596
9cfed0b2 597%if %{with gnome}
55c2af60 598install -p contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
40cb2e83 599%endif
9cfed0b2 600%if %{with gtk}
55c2af60 601install -p contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
1d1e6997
PG
602%endif
603%if %{with gnome} || %{with gtk}
6157007b 604cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
1d1e6997
PG
605#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
606EOF
6157007b 607cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
1d1e6997
PG
608#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
609EOF
4ae0bc0d 610ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
40cb2e83 611%endif
6e70f4f7 612
55c2af60
ER
613install -p contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
614cp -p contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
0906c8d0 615
8e700b6b 616rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
5f72fe6f 617echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
41897191 618
ffbc041f 619touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
643dc12f 620
b8002dec 621cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
1d1e6997
PG
622#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
623EOF
624
92815192
ER
625rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
626rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
627
6fe24471
AF
628%clean
629rm -rf $RPM_BUILD_ROOT
630
b259ae2c
ER
631%post clients
632%env_update
633
634%postun clients
635%env_update
636
637%post gnome-askpass
638%env_update
639
640%postun gnome-askpass
641%env_update
642
8a304ceb 643%pre server
0225d3b8 644%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
4c8ae2f8 645
52000378 646%post server
d7fde396 647/sbin/chkconfig --add sshd
2c99507e 648%service sshd reload "openssh daemon"
40cb2e83
JB
649if ! grep -qs ssh /etc/security/passwd.conf ; then
650 umask 022
ec00afd0
JR
651 echo "ssh" >> /etc/security/passwd.conf
652fi
6fe24471 653
52000378 654%preun server
d7fde396 655if [ "$1" = "0" ]; then
b054de44 656 %service sshd stop
d7fde396 657 /sbin/chkconfig --del sshd
658fi
6fe24471 659
9b604401
JB
660%postun server
661if [ "$1" = "0" ]; then
5f4ffc90 662 %userremove sshd
9b604401
JB
663fi
664
c0f446a0
JK
665%post server-upstart
666%upstart_post sshd
667
668%postun server-upstart
669%upstart_postun sshd
670
7073aeeb
JR
671%post -n openldap-schema-openssh-lpk
672%openldap_schema_register %{schemadir}/openssh-lpk.schema
673%service -q ldap restart
674
675%postun -n openldap-schema-openssh-lpk
676if [ "$1" = "0" ]; then
677 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
678 %service -q ldap restart
679fi
680
6fe24471 681%files
52000378 682%defattr(644,root,root,755)
7cc45b9b 683%doc *.RNG TODO README OVERVIEW CREDITS Change*
a6eef44c 684%attr(755,root,root) %{_bindir}/ssh-key*
35844bbb 685%attr(755,root,root) %{_bindir}/ssh-vulnkey*
a6eef44c 686%{_mandir}/man1/ssh-key*.1*
35844bbb 687%{_mandir}/man1/ssh-vulnkey*.1*
52000378 688%dir %{_sysconfdir}
9df62d0f 689%dir %{_libexecdir}
52000378
AF
690
691%files clients
692%defattr(644,root,root,755)
96f686c2
JB
693%attr(755,root,root) %{_bindir}/ssh
694%attr(755,root,root) %{_bindir}/slogin
695%attr(755,root,root) %{_bindir}/sftp
696%attr(755,root,root) %{_bindir}/ssh-agent
697%attr(755,root,root) %{_bindir}/ssh-add
0906c8d0 698%attr(755,root,root) %{_bindir}/ssh-copy-id
96f686c2 699%attr(755,root,root) %{_bindir}/scp
794e0987
JB
700%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
701%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
52000378
AF
702%{_mandir}/man1/scp.1*
703%{_mandir}/man1/ssh.1*
41897191 704%{_mandir}/man1/slogin.1*
a6eef44c 705%{_mandir}/man1/sftp.1*
52000378
AF
706%{_mandir}/man1/ssh-agent.1*
707%{_mandir}/man1/ssh-add.1*
0906c8d0 708%{_mandir}/man1/ssh-copy-id.1*
902cef13 709%{_mandir}/man5/ssh_config.5*
2b7669a6 710%lang(it) %{_mandir}/it/man1/ssh.1*
711%lang(it) %{_mandir}/it/man5/ssh_config.5*
712%lang(pl) %{_mandir}/pl/man1/scp.1*
713%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
ec82f607
JB
714
715# for host-based auth (suid required for accessing private host key)
716#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
717#%{_mandir}/man8/ssh-keysign.8*
52000378 718
8a7ba6eb
AM
719%files clients-agent-profile_d
720%defattr(644,root,root,755)
721%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
722%attr(755,root,root) /etc/profile.d/ssh-agent.sh
723
724%files clients-agent-xinitrc
725%defattr(644,root,root,755)
726%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
727
52000378
AF
728%files server
729%defattr(644,root,root,755)
730%attr(755,root,root) %{_sbindir}/sshd
a6eef44c 731%attr(755,root,root) %{_libexecdir}/sftp-server
ad852e00 732%attr(755,root,root) %{_libexecdir}/ssh-keysign
50835229 733%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
52000378 734%{_mandir}/man8/sshd.8*
a6eef44c 735%{_mandir}/man8/sftp-server.8*
ad852e00 736%{_mandir}/man8/ssh-keysign.8*
50835229 737%{_mandir}/man8/ssh-pkcs11-helper.8*
902cef13 738%{_mandir}/man5/sshd_config.5*
78aa4c3c 739%{_mandir}/man5/moduli.5*
794e0987
JB
740%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
741%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
634d69b4 742%attr(640,root,root) %{_sysconfdir}/moduli
52000378 743%attr(754,root,root) /etc/rc.d/init.d/sshd
794e0987
JB
744%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
745%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
52000378 746
0d32b20f 747%if %{with gnome} || %{with gtk}
40cb2e83
JB
748%files gnome-askpass
749%defattr(644,root,root,755)
794e0987 750%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
40cb2e83
JB
751%dir %{_libexecdir}/ssh
752%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
4ae0bc0d 753%attr(755,root,root) %{_libexecdir}/ssh-askpass
40cb2e83 754%endif
b32891d6
JR
755
756%if %{with ldap}
757%files -n openldap-schema-openssh-lpk
758%defattr(644,root,root,755)
759%{schemadir}/openssh-lpk.schema
760%endif
c0f446a0 761
4ec733f6 762%if "%{pld_release}" != "ti"
c0f446a0
JK
763%files server-upstart
764%defattr(644,root,root,755)
765%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
4ec733f6 766%endif
This page took 3.416419 seconds and 4 git commands to generate.