]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
- misc files for OpenSSH
[packages/openssh.git] / openssh.spec
CommitLineData
52000378
AF
1Summary: OpenSSH free Secure Shell (SSH) implementation
2Name: openssh
3Version: 1.2pre15
4Release: 2
5Source0: openssh-%{version}.tar.gz
6Source1: opensshd.conf
7Source2: openssh.conf
8Source3: opensshd.init
9Source4: opensshd.pamd
10Source5: openssh.sysconfig
11Patch0: openssh-ssl.patch
12Patch1: openssh-DESTDIR.patch
13License: BSD
14Group: Applications/Networking
15Group(pl): Aplikacje/Sieciowe
16BuildRequires: openssl-devel
17BuildRequires: zlib-devel
18BuildRequires: pam-devel
19BuildRequires: XFree86-devel
20BuildRequires: gnome-libs-devel
21BuildRoot: /tmp/%{name}-%{version}-root
22Obsoletes: ssh
23
24%define _syscondir /etc/ssh
6fe24471
AF
25
26%description
27Ssh (Secure Shell) a program for logging into a remote machine and for
28executing commands in a remote machine. It is intended to replace
29rlogin and rsh, and provide secure encrypted communications between
30two untrusted hosts over an insecure network. X11 connections and
31arbitrary TCP/IP ports can also be forwarded over the secure channel.
32
33OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
34up to date in terms of security and features, as well as removing all
35patented algorithms to seperate libraries (OpenSSL).
36
52000378
AF
37This package includes the core files necessary for both the OpenSSH
38client and server. To make this package useful, you should also
39install openssh-clients, openssh-server, or both.
6fe24471 40
52000378
AF
41%package clients
42Summary: OpenSSH Secure Shell protocol clients
43Requires: openssh
44Group: Applications/Networking
45Group(pl): Aplikacje/Sieciowe
46Obsoletes: ssh-clients
47Requires: %{name} = %{version}
6fe24471 48
52000378
AF
49%description clients
50Ssh (Secure Shell) a program for logging into a remote machine and for
51executing commands in a remote machine. It is intended to replace
52rlogin and rsh, and provide secure encrypted communications between
53two untrusted hosts over an insecure network. X11 connections and
54arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 55
52000378
AF
56OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
57up to date in terms of security and features, as well as removing all
58patented algorithms to seperate libraries (OpenSSL).
59
60This package includes the clients necessary to make encrypted connections
61to SSH servers.
62
63%package server
64Summary: OpenSSH Secure Shell protocol server (sshd)
65Requires: openssh chkconfig >= 0.9
66Group: Networking/Daemons
67Group(pl): Sieciowe/Serwery
68Obsoletes: ssh-server
69Requires: rc-scripts
70Prereq: %{name} = %{version}
71
72%description server
73Ssh (Secure Shell) a program for logging into a remote machine and for
74executing commands in a remote machine. It is intended to replace
75rlogin and rsh, and provide secure encrypted communications between
76two untrusted hosts over an insecure network. X11 connections and
77arbitrary TCP/IP ports can also be forwarded over the secure channel.
78
79OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
80up to date in terms of security and features, as well as removing all
81patented algorithms to seperate libraries (OpenSSL).
82
83This package contains the secure shell daemon. The sshd is the server
84part of the secure shell protocol and allows ssh clients to connect to
85your host.
6fe24471 86
52000378
AF
87%package askpass
88Summary: OpenSSH GNOME passphrase dialog
89Group: Applications/Networking
90Group(pl): Aplikacje/Sieciowe
91Requires: %{name} = %{version}
92Obsoletes: ssh-extras
93Obsoletes: ssh-askpass
94
95%description askpass
96Ssh (Secure Shell) a program for logging into a remote machine and for
97executing commands in a remote machine. It is intended to replace
98rlogin and rsh, and provide secure encrypted communications between
99two untrusted hosts over an insecure network. X11 connections and
100arbitrary TCP/IP ports can also be forwarded over the secure channel.
101
102OpenSSH is OpenBSD's rework of the last free version of SSH, bringing it
103up to date in terms of security and features, as well as removing all
104patented algorithms to seperate libraries (OpenSSL).
105
106This package contains the GNOME passphrase dialog.
107
108
109%prep
110%setup -q
111%patch0 -p1
112%patch1 -p1
113
114%build
115autoconf
116%configure \
117 --with-gnome-askpass
118make
6fe24471
AF
119
120%install
121rm -rf $RPM_BUILD_ROOT
6fe24471 122
52000378
AF
123install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{pam.d,rc.d/init.d,sysconfig}}
124
125make install \
126 DESTDIR="$RPM_BUILD_ROOT"
127
128install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/sshd
129install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/sshd
130install -m755 %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
131install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/ssh_config
132install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/sshd_config
133
134gzip -9fn ChangeLog OVERVIEW COPYING.Ylonen README README.Ylonen UPGRADING \
135 $RPM_BUILD_ROOT/%{_mandir}/man*/*
136
6fe24471
AF
137%clean
138rm -rf $RPM_BUILD_ROOT
139
52000378
AF
140%post server
141/sbin/chkconfig --add sshd
142if [ ! -f /etc/ssh/ssh_host_key -o ! -s /etc/ssh/ssh_host_key ]; then
143 /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N '' >&2
6fe24471 144fi
52000378 145if test -r /var/run/sshd.pid
6fe24471 146then
52000378 147 /etc/rc.d/init.d/sshd restart >&2
6fe24471
AF
148fi
149
52000378 150%preun server
6fe24471
AF
151if [ "$1" = 0 ]
152then
52000378
AF
153 /etc/rc.d/init.d/sshd stop >&2
154 /sbin/chkconfig --del sshd
6fe24471
AF
155fi
156
157%files
52000378
AF
158%defattr(644,root,root,755)
159%doc {ChangeLog,OVERVIEW,COPYING.Ylonen,README,README.Ylonen,UPGRADING}.gz
160%attr(755,root,root) %{_bindir}/ssh-keygen
161%{_mandir}/man1/ssh-keygen.1*
162%dir %{_sysconfdir}
163
164%files clients
165%defattr(644,root,root,755)
166# suid root ?
167#%attr(4755,root,root) %{_bindir}/ssh
168%attr(0755,root,root) %{_bindir}/ssh
169%attr(0755,root,root) %{_bindir}/ssh-agent
170%attr(0755,root,root) %{_bindir}/ssh-add
171#%attr(0755,root,root) %{_bindir}/slogin
172%attr(755,root,root) %{_bindir}/scp
173%{_mandir}/man1/scp.1*
174%{_mandir}/man1/ssh.1*
175%{_mandir}/man1/ssh-agent.1*
176%{_mandir}/man1/ssh-add.1*
177#%{_mandir}/man1/slogin.1
178%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ssh_config
179
180%files server
181%defattr(644,root,root,755)
182%attr(755,root,root) %{_sbindir}/sshd
183%{_mandir}/man8/sshd.8*
184%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/sshd_config
185%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/sshd
186%attr(754,root,root) /etc/rc.d/init.d/sshd
187%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/sshd
188
189%files askpass
190%defattr(644,root,root,755)
191%dir %{_libexecdir}/ssh
192%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
This page took 0.066959 seconds and 4 git commands to generate.