]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
- revert; ssh-copy-id -i idfile hostname still works (mislooked something i suppose)
[packages/openssh.git] / openssh.spec
CommitLineData
2ebfbf87 1#
2ca913e8 2# Conditional build:
f6c7fa07 3%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
cd53fc87 4%bcond_without gtk # without GTK+ (2.x)
b32891d6 5%bcond_without ldap # with ldap support
f6c7fa07 6%bcond_without libedit # without libedit (editline/history support in sftp client)
9cfed0b2 7%bcond_without kerberos5 # without kerberos5 support
70329622 8%bcond_without selinux # build without SELinux support
5c609334 9%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
516496e1 10
cef904f1
JB
11# gtk2-based gnome-askpass means no gnome1-based
12%{?with_gtk:%undefine with_gnome}
cc788d8e 13
2ebfbf87
ER
14%if "%{pld_release}" == "ac"
15%define pam_ver 0.79.0
16%else
17%define pam_ver 0.99.7.1
18%endif
19
52000378 20Summary: OpenSSH free Secure Shell (SSH) implementation
25e16946
ER
21Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
22Summary(es.UTF-8): Implementación libre de SSH
23Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
24Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
25Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
26Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
27Summary(pt_BR.UTF-8): Implementação livre do SSH
28Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
29Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
52000378 30Name: openssh
f1344723 31Version: 5.7p1
b90f4397 32Release: 4
f5fc6a92 33Epoch: 2
5d1c7089 34License: BSD
35Group: Applications/Networking
6481986b 36Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
f1344723 37# Source0-md5: 50231fa257219791fa41b84a16c9df04
486d736c
JR
38Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
39# Source1-md5: 66943d481cc422512b537bcc2c7400d1
40Source2: %{name}d.init
41Source3: %{name}d.pamd
42Source4: %{name}.sysconfig
43Source5: ssh-agent.sh
44Source6: ssh-agent.conf
b32891d6 45Source7: %{name}-lpk.schema
c0f446a0 46Source8: %{name}d.upstart
2ebfbf87 47Patch100: %{name}-heimdal.patch
89eac7b5 48Patch0: %{name}-no_libnsl.patch
8d59ede4
JB
49Patch2: %{name}-pam_misc.patch
50Patch3: %{name}-sigpipe.patch
b32891d6
JR
51# http://code.google.com/p/openssh-lpk/
52Patch4: %{name}-lpk.patch
8d59ede4 53Patch5: %{name}-config.patch
0a069c2e 54# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
0d5b2bd4
ER
55# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
56Patch9: %{name}-5.2p1-hpn13v6.diff
8d59ede4 57Patch10: %{name}-include.patch
100234b3 58Patch11: %{name}-chroot.patch
342ae3ba 59# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
cc788d8e 60Patch12: %{name}-blacklist.diff
e9cfdffe 61URL: http://www.openssh.com/
0a069c2e 62BuildRequires: %{__perl}
92d612e6 63BuildRequires: autoconf
8f12ae30 64BuildRequires: automake
9cfed0b2 65%{?with_gnome:BuildRequires: gnome-libs-devel}
66%{?with_gtk:BuildRequires: gtk+2-devel}
044fff96 67%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
f6c7fa07 68%{?with_libedit:BuildRequires: libedit-devel}
70329622 69%{?with_selinux:BuildRequires: libselinux-devel}
a14c109c 70BuildRequires: libwrap-devel
044fff96 71%{?with_ldap:BuildRequires: openldap-devel}
b12dd014 72BuildRequires: openssl-devel >= 0.9.7d
92d612e6 73BuildRequires: pam-devel
9cfed0b2 74%{?with_gtk:BuildRequires: pkgconfig}
2ebfbf87 75BuildRequires: rpm >= 4.4.9-56
9be30b5d 76BuildRequires: rpmbuild(macros) >= 1.318
a42c5034 77BuildRequires: sed >= 4.0
a14c109c 78BuildRequires: zlib-devel
2ebfbf87
ER
79%if "%{pld_release}" == "ac"
80Requires: filesystem >= 2.0-1
81Requires: pam >= 0.79.0
82%else
680fc8d4 83Requires: filesystem >= 3.0-11
2ebfbf87 84Requires: pam >= %{pam_ver}
35844bbb 85Suggests: openssh-blacklist
a9abed26 86Suggests: xorg-app-xauth
2ebfbf87 87%endif
f937b661 88Obsoletes: ssh
05fbd2e9 89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52000378 90
b7b47957 91%define _sysconfdir /etc/ssh
1dd7cf18 92%define _libexecdir %{_libdir}/%{name}
a14c109c 93%define _privsepdir /usr/share/empty
b32891d6 94%define schemadir /usr/share/openldap/schema
6fe24471 95
c0f446a0
JK
96## to be moved to rpm-build-macros
97## TODO: handle RPM_SKIP_AUTO_RESTART
98
99# migrate from init script to upstart job
100%define upstart_post() \
101 if [ -f /var/lock/subsys/"%1" ] ; then \
102 /sbin/service --no-upstart "%1" stop \
103 /sbin/service "%1" start \
104 else \
105 /sbin/service "%1" try-restart \
106 fi
107
108# restart the job after upgrade or migrate to init script on removal
109%define upstart_postun() \
110 if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
111 /sbin/initctl stop "%1" 2>/dev/null \
112 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
113 fi
114
115
6fe24471
AF
116%description
117Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 118executing commands in a remote machine. It is intended to replace
119rlogin and rsh, and provide secure encrypted communications between
120two untrusted hosts over an insecure network. X11 connections and
121arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 122
11530f15 123OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
124it up to date in terms of security and features, as well as removing
125all patented algorithms to seperate libraries (OpenSSL).
6fe24471 126
11530f15 127This package includes the core files necessary for both the OpenSSH
128client and server. To make this package useful, you should also
129install openssh-clients, openssh-server, or both.
a42c5034 130
0d5b2bd4 131%if %{with hpn}
0a069c2e 132This release includes High Performance SSH/SCP patches from
a42c5034
ER
133http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
134increase throughput on fast connections with high RTT (20-150 msec).
088aab43 135See the website for '-w' values for your connection and /proc/sys TCP
136values. BTW. in a LAN you have got generally RTT < 1 msec.
137%endif
6fe24471 138
84ae85a3 139%description -l de.UTF-8
aebfac88
JB
140OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
141ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
84ae85a3
JR
142verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
143über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
144andere TCP/IP Ports können ebenso über den sicheren Channel
aebfac88
JB
145weitergeleitet werden.
146
84ae85a3
JR
147%description -l es.UTF-8
148SSH es un programa para accesar y ejecutar órdenes en computadores
149remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
6c34819e 150seguro entre dos servidores en una red insegura. Conexiones X11 y
84ae85a3 151puertas TCP/IP arbitrárias también pueden ser usadas por el canal
6c34819e 152seguro.
153
154OpenSSH es el resultado del trabajo del equipo de OpenBSD para
84ae85a3
JR
155continuar la última versión gratuita de SSH, actualizándolo en
156términos de seguridad y recursos,así también eliminando todos los
157algoritmos patentados y colocándolos en bibliotecas separadas
6c34819e 158(OpenSSL).
159
160Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
84ae85a3 161también el paquete openssh-clients u openssh-server o ambos.
6c34819e 162
84ae85a3
JR
163%description -l fr.UTF-8
164OpenSSH (Secure Shell) fournit un accès à un système distant. Il
aebfac88 165remplace telnet, rlogin, rexec et rsh, tout en assurant des
84ae85a3
JR
166communications cryptées securisées entre deux hôtes non fiabilisés sur
167un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
168arbitraires peuvent également être transmis sur le canal sécurisé.
aebfac88 169
84ae85a3 170%description -l it.UTF-8
aebfac88
JB
171OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
172Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
173sicure e crittate tra due host non fidati su una rete non sicura. Le
174connessioni X11 ad una porta TCP/IP arbitraria possono essere
175inoltrate attraverso un canale sicuro.
176
84ae85a3
JR
177%description -l pl.UTF-8
178Ssh (Secure Shell) to program służący do logowania się na zdalną
179maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
180zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
181pomiędzy dwoma hostami.
93e2d77c 182
84ae85a3
JR
183Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
184klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
185co najmniej jeden z pakietów: openssh-clients lub openssh-server.
a42c5034 186
0d5b2bd4 187%if %{with hpn}
84ae85a3
JR
188Ta wersja zawiera łaty z projektu High Performance SSH/SCP
189http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
a42c5034
ER
190zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
191RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
192danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
193TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
088aab43 194%endif
aebfac88 195
84ae85a3 196%description -l pt.UTF-8
aebfac88 197OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
84ae85a3
JR
198telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
199cifradas entre duas máquinas sem confiança mútua sobre uma rede
200insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
aebfac88
JB
201reenviados pelo canal seguro.
202
84ae85a3
JR
203%description -l pt_BR.UTF-8
204SSH é um programa para acessar e executar comandos em máquinas
205remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
206seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
207TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
6c34819e 208
84ae85a3
JR
209OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
210última versão gratuita do SSH, atualizando-o em termos de segurança e
6c34819e 211recursos, assim como removendo todos os algoritmos patenteados e
212colocando-os em bibliotecas separadas (OpenSSL).
213
84ae85a3
JR
214Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
215também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
216
217%description -l ru.UTF-8
218Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
219машину и для выполнения команд на удаленной машине. Она предназначена
220для замены rlogin и rsh и обеспечивает безопасную шифрованную
221коммуникацию между двумя хостами в сети, являющейся небезопасной.
222Соединения X11 и любые порты TCP/IP могут также быть проведены через
223безопасный канал.
224
225OpenSSH - это переделка командой разработчиков OpenBSD последней
226свободной версии SSH, доведенная до современного состояния в терминах
227уровня безопасности и поддерживаемых возможностей. Все патентованные
228алгоритмы вынесены в отдельные библиотеки (OpenSSL).
229
230Этот пакет содержит файлы, необходимые как для клиента, так и для
231сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
232openssh-server, или оба пакета.
233
234%description -l uk.UTF-8
235Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
236машини та для виконання команд на віддаленій машині. Вона призначена
237для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
238між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
239довільні порти TCP/IP можуть також бути проведені через безпечний
240канал.
241
242OpenSSH - це переробка командою розробників OpenBSD останньої вільної
243версії SSH, доведена до сучасного стану в термінах рівня безпеки та
244підтримуваних можливостей. Всі патентовані алгоритми винесені до
245окремих бібліотек (OpenSSL).
246
247Цей пакет містить файли, необхідні як для клієнта, так і для сервера
248OpenSSH. Вам потрібно буде ще встановити openssh-clients,
249openssh-server, чи обидва пакети.
cb086001 250
52000378
AF
251%package clients
252Summary: OpenSSH Secure Shell protocol clients
25e16946
ER
253Summary(es.UTF-8): Clientes de OpenSSH
254Summary(pl.UTF-8): Klienci protokołu Secure Shell
255Summary(pt_BR.UTF-8): Clientes do OpenSSH
256Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
257Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
52000378 258Group: Applications/Networking
f1608a0c 259Requires: %{name}
516496e1 260Provides: ssh-clients
a14c109c 261Obsoletes: ssh-clients
6fe24471 262
52000378
AF
263%description clients
264Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 265executing commands in a remote machine. It is intended to replace
266rlogin and rsh, and provide secure encrypted communications between
267two untrusted hosts over an insecure network. X11 connections and
268arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 269
11530f15 270OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
271it up to date in terms of security and features, as well as removing
272all patented algorithms to seperate libraries (OpenSSL).
52000378 273
11530f15 274This package includes the clients necessary to make encrypted
275connections to SSH servers.
52000378 276
84ae85a3 277%description clients -l es.UTF-8
6c34819e 278Este paquete incluye los clientes que se necesitan para hacer
279conexiones codificadas con servidores SSH.
280
84ae85a3
JR
281%description clients -l pl.UTF-8
282Ssh (Secure Shell) to program służący do logowania się na zdalną
283maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
284zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
285pomiędzy dwoma hostami.
93e2d77c 286
84ae85a3 287Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
93e2d77c 288
84ae85a3
JR
289%description clients -l pt_BR.UTF-8
290Esse pacote inclui os clientes necessários para fazer conexões
6c34819e 291encriptadas com servidores SSH.
292
84ae85a3
JR
293%description clients -l ru.UTF-8
294Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
295машину и для выполнения команд на удаленной машине.
cb086001 296
84ae85a3
JR
297Этот пакет содержит программы-клиенты, необходимые для установления
298зашифрованных соединений с серверами SSH.
cb086001 299
84ae85a3
JR
300%description clients -l uk.UTF-8
301Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
302машини та для виконання команд на віддаленій машині.
cb086001 303
84ae85a3
JR
304Цей пакет містить програми-клієнти, необхідні для встановлення
305зашифрованих з'єднань з серверами SSH.
cb086001 306
8a7ba6eb
AM
307%package clients-agent-profile_d
308Summary: OpenSSH Secure Shell agent init script
4944be5f 309Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
8a7ba6eb
AM
310Group: Applications/Networking
311Requires: %{name}-clients = %{epoch}:%{version}-%{release}
312
313%description clients-agent-profile_d
314profile.d scripts for starting SSH agent.
315
4944be5f
JB
316%description clients-agent-profile_d -l pl.UTF-8
317Skrypty profile.d do uruchamiania agenta SSH.
318
8a7ba6eb
AM
319%package clients-agent-xinitrc
320Summary: OpenSSH Secure Shell agent init script
321Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
322Group: Applications/Networking
323Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
324Requires: xinitrc
325
326%description clients-agent-xinitrc
327xinitrc scripts for starting SSH agent.
328
4944be5f
JB
329%description clients-agent-xinitrc -l pl.UTF-8
330Skrypty xinitrc do uruchamiania agenta SSH.
8a7ba6eb 331
52000378
AF
332%package server
333Summary: OpenSSH Secure Shell protocol server (sshd)
25e16946
ER
334Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
335Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
336Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
337Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
338Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
339Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
340Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
341Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
342Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
52000378 343Group: Networking/Daemons
2ebfbf87 344Requires(post): /sbin/chkconfig
40cb2e83 345Requires(post): grep
0a069c2e 346Requires(post,preun): /sbin/chkconfig
9b604401 347Requires(postun): /usr/sbin/userdel
0a069c2e
ER
348Requires(pre): /bin/id
349Requires(pre): /usr/sbin/useradd
350Requires: %{name} = %{epoch}:%{version}-%{release}
2ebfbf87 351Requires: pam >= %{pam_ver}
c0f446a0 352Requires: rc-scripts >= 0.4.3.0
0a069c2e 353Requires: util-linux
0d5b2bd4 354Suggests: /bin/login
516496e1
ER
355Provides: ssh-server
356Provides: user(sshd)
52000378
AF
357
358%description server
359Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 360executing commands in a remote machine. It is intended to replace
361rlogin and rsh, and provide secure encrypted communications between
362two untrusted hosts over an insecure network. X11 connections and
363arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 364
11530f15 365OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
366it up to date in terms of security and features, as well as removing
367all patented algorithms to seperate libraries (OpenSSL).
52000378 368
11530f15 369This package contains the secure shell daemon. The sshd is the server
370part of the secure shell protocol and allows ssh clients to connect to
371your host.
6fe24471 372
84ae85a3 373%description server -l de.UTF-8
aebfac88
JB
374Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
375
84ae85a3 376%description server -l es.UTF-8
6c34819e 377Este paquete contiene el servidor SSH. sshd es la parte servidor del
378protocolo secure shell y permite que clientes ssh se conecten a su
379servidor.
380
84ae85a3 381%description server -l fr.UTF-8
aebfac88
JB
382Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
383
84ae85a3 384%description server -l it.UTF-8
aebfac88
JB
385Questo pacchetto installa sshd, il server di OpenSSH.
386
84ae85a3
JR
387%description server -l pl.UTF-8
388Ssh (Secure Shell) to program służący do logowania się na zdalną
389maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
390zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
391pomiędzy dwoma hostami.
93e2d77c 392
84ae85a3 393Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
11530f15 394ssh).
93e2d77c 395
84ae85a3 396%description server -l pt.UTF-8
aebfac88
JB
397Este pacote intala o sshd, o servidor do OpenSSH.
398
84ae85a3
JR
399%description server -l pt_BR.UTF-8
400Esse pacote contém o servidor SSH. O sshd é a parte servidor do
6c34819e 401protocolo secure shell e permite que clientes ssh se conectem ao seu
402host.
403
84ae85a3
JR
404%description server -l ru.UTF-8
405Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
406машину и для выполнения команд на удаленной машине.
cb086001 407
84ae85a3
JR
408Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
409часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
410вашим хостом.
cb086001 411
84ae85a3
JR
412%description server -l uk.UTF-8
413Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
414машини та для виконання команд на віддаленій машині.
cb086001 415
84ae85a3
JR
416Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
417частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
418з вашим хостом.
cb086001 419
c0f446a0
JK
420%package server-upstart
421Summary: Upstart job description for OpenSSH server
422Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
423Group: Daemons
424Requires: %{name}-server = %{epoch}:%{version}-%{release}
425Requires: upstart >= 0.6
426
427%description server-upstart
428Upstart job description for OpenSSH.
429
430%description server-upstart -l pl.UTF-8
431Opis zadania Upstart dla OpenSSH.
432
6e70f4f7 433%package gnome-askpass
52000378 434Summary: OpenSSH GNOME passphrase dialog
25e16946
ER
435Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
436Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
437Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
438Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
439Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
440Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
441Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
442Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
443Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
52000378 444Group: Applications/Networking
96f686c2 445Requires: %{name} = %{epoch}:%{version}-%{release}
f937b661 446Obsoletes: openssh-askpass
0a069c2e
ER
447Obsoletes: ssh-askpass
448Obsoletes: ssh-extras
52000378 449
6e70f4f7 450%description gnome-askpass
52000378 451Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 452executing commands in a remote machine. It is intended to replace
453rlogin and rsh, and provide secure encrypted communications between
454two untrusted hosts over an insecure network. X11 connections and
455arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 456
11530f15 457OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
458it up to date in terms of security and features, as well as removing
459all patented algorithms to seperate libraries (OpenSSL).
52000378
AF
460
461This package contains the GNOME passphrase dialog.
462
84ae85a3
JR
463%description gnome-askpass -l es.UTF-8
464Este paquete contiene un programa que abre una caja de diálogo para
6c34819e 465entrada de passphrase en GNOME.
466
84ae85a3
JR
467%description gnome-askpass -l pl.UTF-8
468Ssh (Secure Shell) to program służący do logowania się na zdalną
469maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
470zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
471pomiędzy dwoma hostami.
93e2d77c 472
84ae85a3 473Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
93e2d77c 474
84ae85a3
JR
475%description gnome-askpass -l pt_BR.UTF-8
476Esse pacote contém um programa que abre uma caixa de diálogo para
6c34819e 477entrada de passphrase no GNOME.
478
84ae85a3
JR
479%description gnome-askpass -l ru.UTF-8
480Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
481машину и для выполнения команд на удаленной машине.
cb086001 482
84ae85a3 483Этот пакет содержит диалог ввода ключевой фразы для использования под
cb086001 484GNOME.
485
84ae85a3
JR
486%description gnome-askpass -l uk.UTF-8
487Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
488машини та для виконання команд на віддаленій машині.
cb086001 489
84ae85a3 490Цей пакет містить діалог вводу ключової фрази для використання під
cb086001 491GNOME.
492
b32891d6
JR
493%package -n openldap-schema-openssh-lpk
494Summary: OpenSSH LDAP Public Key schema
495Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
496Group: Networking/Daemons
497Requires(post,postun): sed >= 4.0
498Requires: openldap-servers
499
500%description -n openldap-schema-openssh-lpk
501This package contains OpenSSH LDAP Public Key schema for openldap.
502
503%description -n openldap-schema-openssh-lpk -l pl.UTF-8
0d5b2bd4
ER
504Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
505openldap-a.
b32891d6 506
52000378 507%prep
ecf377a3 508%setup -q
2ebfbf87 509%{?with_kerberos5:%patch100 -p1}
4946f6e5 510%patch0 -p1
1aca01a4 511%patch2 -p1
200ba837 512%patch3 -p1
8d59ede4
JB
513%{?with_ldap:%patch4 -p1}
514%patch5 -p1
516496e1 515%{?with_hpn:%patch9 -p1}
8d59ede4 516%patch10 -p1
100234b3 517%patch11 -p1
35844bbb 518%patch12 -p1
52000378 519
a42c5034
ER
520%if "%{pld_release}" == "ac"
521# fix for missing x11.pc
522%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
523%endif
524
52000378 525%build
64f1c35c 526cp /usr/share/automake/config.sub .
0b24ec17 527%{__aclocal}
5c76eb87 528%{__autoconf}
37aa5700 529CPPFLAGS="-DCHROOT"
52000378 530%configure \
c59fae24 531 PERL=%{__perl} \
41897191
AM
532 --with-pam \
533 --with-mantype=man \
f9bf943b 534 --with-md5-passwords \
4946f6e5 535 --with-ipaddr-display \
f6c7fa07 536 %{?with_libedit:--with-libedit} \
93e2d77c 537 --with-4in6 \
06b95d40 538 --with-tcp-wrappers \
9cfed0b2 539 %{?with_ldap:--with-libs="-lldap -llber"} \
540 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
4a5c0c7d 541 %{?with_kerberos5:--with-kerberos5=/usr} \
a14c109c 542 --with-privsep-path=%{_privsepdir} \
05fbd2e9 543 --with-pid-dir=%{_localstatedir}/run \
2ebfbf87
ER
544%if "%{pld_release}" == "ac"
545 --with-xauth=/usr/X11R6/bin/xauth \
546%else
f1344723 547 --with-xauth=%{_bindir}/xauth \
2ebfbf87 548%endif
c7963a12
JR
549 --enable-utmpx \
550 --enable-wtmpx
82f989ae 551
b8002dec 552echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
f9bf943b 553
100832a0 554%{__make}
475ef6df 555
40cb2e83 556cd contrib
9cfed0b2 557%if %{with gnome}
40cb2e83
JB
558%{__make} gnome-ssh-askpass1 \
559 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
560%endif
9cfed0b2 561%if %{with gtk}
40cb2e83
JB
562%{__make} gnome-ssh-askpass2 \
563 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
564%endif
6fe24471
AF
565
566%install
567rm -rf $RPM_BUILD_ROOT
c0f446a0 568install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
b32891d6 569 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
8a7ba6eb 570install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
52000378 571
9a2a459a
PG
572%{__make} install \
573 DESTDIR=$RPM_BUILD_ROOT
0d32b20f 574
486d736c 575bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
40cb2e83 576
486d736c
JR
577install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
578install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
579install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
580install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
581ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
582install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
b32891d6 583install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
2b7669a6 584
c0f446a0
JK
585install %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
586
9cfed0b2 587%if %{with gnome}
40cb2e83
JB
588install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
589%endif
9cfed0b2 590%if %{with gtk}
40cb2e83 591install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
1d1e6997
PG
592%endif
593%if %{with gnome} || %{with gtk}
6157007b 594cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
1d1e6997
PG
595#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
596EOF
6157007b 597cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
1d1e6997
PG
598#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
599EOF
4ae0bc0d 600ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
40cb2e83 601%endif
6e70f4f7 602
0906c8d0 603install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
604install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
605
8e700b6b 606rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
5f72fe6f 607echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
41897191 608
ffbc041f 609touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
643dc12f 610
b8002dec 611cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
1d1e6997
PG
612#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
613EOF
614
92815192
ER
615rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
616rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
617
6fe24471
AF
618%clean
619rm -rf $RPM_BUILD_ROOT
620
b259ae2c
ER
621%post clients
622%env_update
623
624%postun clients
625%env_update
626
627%post gnome-askpass
628%env_update
629
630%postun gnome-askpass
631%env_update
632
8a304ceb 633%pre server
0225d3b8 634%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
4c8ae2f8 635
52000378 636%post server
d7fde396 637/sbin/chkconfig --add sshd
2c99507e 638%service sshd reload "openssh daemon"
40cb2e83
JB
639if ! grep -qs ssh /etc/security/passwd.conf ; then
640 umask 022
ec00afd0
JR
641 echo "ssh" >> /etc/security/passwd.conf
642fi
6fe24471 643
52000378 644%preun server
d7fde396 645if [ "$1" = "0" ]; then
b054de44 646 %service sshd stop
d7fde396 647 /sbin/chkconfig --del sshd
648fi
6fe24471 649
9b604401
JB
650%postun server
651if [ "$1" = "0" ]; then
5f4ffc90 652 %userremove sshd
9b604401
JB
653fi
654
c0f446a0
JK
655%post server-upstart
656%upstart_post sshd
657
658%postun server-upstart
659%upstart_postun sshd
660
7073aeeb
JR
661%post -n openldap-schema-openssh-lpk
662%openldap_schema_register %{schemadir}/openssh-lpk.schema
663%service -q ldap restart
664
665%postun -n openldap-schema-openssh-lpk
666if [ "$1" = "0" ]; then
667 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
668 %service -q ldap restart
669fi
670
6fe24471 671%files
52000378 672%defattr(644,root,root,755)
7cc45b9b 673%doc *.RNG TODO README OVERVIEW CREDITS Change*
a6eef44c 674%attr(755,root,root) %{_bindir}/ssh-key*
35844bbb 675%attr(755,root,root) %{_bindir}/ssh-vulnkey*
a6eef44c 676%{_mandir}/man1/ssh-key*.1*
35844bbb 677%{_mandir}/man1/ssh-vulnkey*.1*
52000378 678%dir %{_sysconfdir}
9df62d0f 679%dir %{_libexecdir}
52000378
AF
680
681%files clients
682%defattr(644,root,root,755)
96f686c2
JB
683%attr(755,root,root) %{_bindir}/ssh
684%attr(755,root,root) %{_bindir}/slogin
685%attr(755,root,root) %{_bindir}/sftp
686%attr(755,root,root) %{_bindir}/ssh-agent
687%attr(755,root,root) %{_bindir}/ssh-add
0906c8d0 688%attr(755,root,root) %{_bindir}/ssh-copy-id
96f686c2 689%attr(755,root,root) %{_bindir}/scp
794e0987
JB
690%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
691%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
52000378
AF
692%{_mandir}/man1/scp.1*
693%{_mandir}/man1/ssh.1*
41897191 694%{_mandir}/man1/slogin.1*
a6eef44c 695%{_mandir}/man1/sftp.1*
52000378
AF
696%{_mandir}/man1/ssh-agent.1*
697%{_mandir}/man1/ssh-add.1*
0906c8d0 698%{_mandir}/man1/ssh-copy-id.1*
902cef13 699%{_mandir}/man5/ssh_config.5*
2b7669a6 700%lang(it) %{_mandir}/it/man1/ssh.1*
701%lang(it) %{_mandir}/it/man5/ssh_config.5*
702%lang(pl) %{_mandir}/pl/man1/scp.1*
703%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
ec82f607
JB
704
705# for host-based auth (suid required for accessing private host key)
706#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
707#%{_mandir}/man8/ssh-keysign.8*
52000378 708
8a7ba6eb
AM
709%files clients-agent-profile_d
710%defattr(644,root,root,755)
711%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
712%attr(755,root,root) /etc/profile.d/ssh-agent.sh
713
714%files clients-agent-xinitrc
715%defattr(644,root,root,755)
716%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
717
52000378
AF
718%files server
719%defattr(644,root,root,755)
720%attr(755,root,root) %{_sbindir}/sshd
a6eef44c 721%attr(755,root,root) %{_libexecdir}/sftp-server
ad852e00 722%attr(755,root,root) %{_libexecdir}/ssh-keysign
50835229 723%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
52000378 724%{_mandir}/man8/sshd.8*
a6eef44c 725%{_mandir}/man8/sftp-server.8*
ad852e00 726%{_mandir}/man8/ssh-keysign.8*
50835229 727%{_mandir}/man8/ssh-pkcs11-helper.8*
902cef13 728%{_mandir}/man5/sshd_config.5*
78aa4c3c 729%{_mandir}/man5/moduli.5*
794e0987
JB
730%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
731%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
634d69b4 732%attr(640,root,root) %{_sysconfdir}/moduli
52000378 733%attr(754,root,root) /etc/rc.d/init.d/sshd
794e0987
JB
734%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
735%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
52000378 736
0d32b20f 737%if %{with gnome} || %{with gtk}
40cb2e83
JB
738%files gnome-askpass
739%defattr(644,root,root,755)
794e0987 740%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
40cb2e83
JB
741%dir %{_libexecdir}/ssh
742%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
4ae0bc0d 743%attr(755,root,root) %{_libexecdir}/ssh-askpass
40cb2e83 744%endif
b32891d6
JR
745
746%if %{with ldap}
747%files -n openldap-schema-openssh-lpk
748%defattr(644,root,root,755)
749%{schemadir}/openssh-lpk.schema
750%endif
c0f446a0 751
4ec733f6 752%if "%{pld_release}" != "ti"
c0f446a0
JK
753%files server-upstart
754%defattr(644,root,root,755)
755%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
4ec733f6 756%endif
This page took 0.302813 seconds and 4 git commands to generate.