]> git.pld-linux.org Git - packages/openssh.git/blame - openssh.spec
- Release: 3
[packages/openssh.git] / openssh.spec
CommitLineData
2ebfbf87
ER
1# TODO
2# - configure: WARNING: unrecognized options: --with-dns, --disable-suid-ssh
3#
2ca913e8 4# Conditional build:
f6c7fa07 5%bcond_with gnome # with gnome-askpass (GNOME 1.x) utility
cd53fc87 6%bcond_without gtk # without GTK+ (2.x)
b32891d6 7%bcond_without ldap # with ldap support
f6c7fa07 8%bcond_without libedit # without libedit (editline/history support in sftp client)
9cfed0b2 9%bcond_without kerberos5 # without kerberos5 support
70329622 10%bcond_without selinux # build without SELinux support
5c609334 11%bcond_with hpn # High Performance SSH/SCP - HPN-SSH including Cipher NONE (broken too often)
516496e1 12
cef904f1
JB
13# gtk2-based gnome-askpass means no gnome1-based
14%{?with_gtk:%undefine with_gnome}
cc788d8e 15
2ebfbf87
ER
16%if "%{pld_release}" == "ac"
17%define pam_ver 0.79.0
18%else
19%define pam_ver 0.99.7.1
20%endif
21
52000378 22Summary: OpenSSH free Secure Shell (SSH) implementation
25e16946
ER
23Summary(de.UTF-8): OpenSSH - freie Implementation der Secure Shell (SSH)
24Summary(es.UTF-8): Implementación libre de SSH
25Summary(fr.UTF-8): Implémentation libre du shell sécurisé OpenSSH (SSH)
26Summary(it.UTF-8): Implementazione gratuita OpenSSH della Secure Shell
27Summary(pl.UTF-8): Publicznie dostępna implementacja bezpiecznego shella (SSH)
28Summary(pt.UTF-8): Implementação livre OpenSSH do protocolo 'Secure Shell' (SSH)
29Summary(pt_BR.UTF-8): Implementação livre do SSH
30Summary(ru.UTF-8): OpenSSH - свободная реализация протокола Secure Shell (SSH)
31Summary(uk.UTF-8): OpenSSH - вільна реалізація протоколу Secure Shell (SSH)
52000378 32Name: openssh
6b22dba3 33Version: 5.5p1
4656df82 34Release: 3
f5fc6a92 35Epoch: 2
5d1c7089 36License: BSD
37Group: Applications/Networking
6481986b 38Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%{name}-%{version}.tar.gz
6b22dba3 39# Source0-md5: 88633408f4cb1eb11ec7e2ec58b519eb
486d736c
JR
40Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
41# Source1-md5: 66943d481cc422512b537bcc2c7400d1
42Source2: %{name}d.init
43Source3: %{name}d.pamd
44Source4: %{name}.sysconfig
45Source5: ssh-agent.sh
46Source6: ssh-agent.conf
b32891d6 47Source7: %{name}-lpk.schema
c0f446a0 48Source8: %{name}d.upstart
2ebfbf87 49Patch100: %{name}-heimdal.patch
89eac7b5 50Patch0: %{name}-no_libnsl.patch
8d59ede4
JB
51Patch2: %{name}-pam_misc.patch
52Patch3: %{name}-sigpipe.patch
b32891d6
JR
53# http://code.google.com/p/openssh-lpk/
54Patch4: %{name}-lpk.patch
8d59ede4 55Patch5: %{name}-config.patch
8d59ede4 56Patch7: %{name}-selinux.patch
0a069c2e 57# High Performance SSH/SCP - HPN-SSH - http://www.psc.edu/networking/projects/hpn-ssh/
0d5b2bd4
ER
58# http://www.psc.edu/networking/projects/hpn-ssh/openssh-5.2p1-hpn13v6.diff.gz
59Patch9: %{name}-5.2p1-hpn13v6.diff
8d59ede4 60Patch10: %{name}-include.patch
100234b3 61Patch11: %{name}-chroot.patch
342ae3ba 62# http://people.debian.org/~cjwatson/%{name}-blacklist.diff
cc788d8e 63Patch12: %{name}-blacklist.diff
e9cfdffe 64URL: http://www.openssh.com/
0a069c2e 65BuildRequires: %{__perl}
92d612e6 66BuildRequires: autoconf
8f12ae30 67BuildRequires: automake
9cfed0b2 68%{?with_gnome:BuildRequires: gnome-libs-devel}
69%{?with_gtk:BuildRequires: gtk+2-devel}
044fff96 70%{?with_kerberos5:BuildRequires: heimdal-devel >= 0.7}
f6c7fa07 71%{?with_libedit:BuildRequires: libedit-devel}
70329622 72%{?with_selinux:BuildRequires: libselinux-devel}
a14c109c 73BuildRequires: libwrap-devel
044fff96 74%{?with_ldap:BuildRequires: openldap-devel}
b12dd014 75BuildRequires: openssl-devel >= 0.9.7d
92d612e6 76BuildRequires: pam-devel
9cfed0b2 77%{?with_gtk:BuildRequires: pkgconfig}
2ebfbf87 78BuildRequires: rpm >= 4.4.9-56
9be30b5d 79BuildRequires: rpmbuild(macros) >= 1.318
a42c5034 80BuildRequires: sed >= 4.0
a14c109c 81BuildRequires: zlib-devel
2ebfbf87
ER
82%if "%{pld_release}" == "ac"
83Requires: filesystem >= 2.0-1
84Requires: pam >= 0.79.0
85%else
680fc8d4 86Requires: filesystem >= 3.0-11
2ebfbf87 87Requires: pam >= %{pam_ver}
35844bbb 88Suggests: openssh-blacklist
a9abed26 89Suggests: xorg-app-xauth
2ebfbf87 90%endif
f937b661 91Obsoletes: ssh
05fbd2e9 92BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52000378 93
b7b47957 94%define _sysconfdir /etc/ssh
1dd7cf18 95%define _libexecdir %{_libdir}/%{name}
a14c109c 96%define _privsepdir /usr/share/empty
b32891d6 97%define schemadir /usr/share/openldap/schema
6fe24471 98
c0f446a0
JK
99## to be moved to rpm-build-macros
100## TODO: handle RPM_SKIP_AUTO_RESTART
101
102# migrate from init script to upstart job
103%define upstart_post() \
104 if [ -f /var/lock/subsys/"%1" ] ; then \
105 /sbin/service --no-upstart "%1" stop \
106 /sbin/service "%1" start \
107 else \
108 /sbin/service "%1" try-restart \
109 fi
110
111# restart the job after upgrade or migrate to init script on removal
112%define upstart_postun() \
113 if [ -x /sbin/initctl ] && /sbin/initctl status "%1" 2>/dev/null | grep -q 'running' ; then \
114 /sbin/initctl stop "%1" 2>/dev/null \
115 [ -f "/etc/rc.d/init.d/%1" -o -f "/etc/init/%1.conf" ] && /sbin/service "%1" start \
116 fi
117
118
6fe24471
AF
119%description
120Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 121executing commands in a remote machine. It is intended to replace
122rlogin and rsh, and provide secure encrypted communications between
123two untrusted hosts over an insecure network. X11 connections and
124arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 125
11530f15 126OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
127it up to date in terms of security and features, as well as removing
128all patented algorithms to seperate libraries (OpenSSL).
6fe24471 129
11530f15 130This package includes the core files necessary for both the OpenSSH
131client and server. To make this package useful, you should also
132install openssh-clients, openssh-server, or both.
a42c5034 133
0d5b2bd4 134%if %{with hpn}
0a069c2e 135This release includes High Performance SSH/SCP patches from
a42c5034
ER
136http://www.psc.edu/networking/projects/hpn-ssh/ which are supposed to
137increase throughput on fast connections with high RTT (20-150 msec).
088aab43 138See the website for '-w' values for your connection and /proc/sys TCP
139values. BTW. in a LAN you have got generally RTT < 1 msec.
140%endif
6fe24471 141
84ae85a3 142%description -l de.UTF-8
aebfac88
JB
143OpenSSH (Secure Shell) stellt den Zugang zu anderen Rechnern her. Es
144ersetzt telnet, rlogin, rexec und rsh und stellt eine sichere,
84ae85a3
JR
145verschlüsselte Verbindung zwischen zwei nicht vertrauenswürdigen Hosts
146über eine unsicheres Netzwerk her. X11 Verbindungen und beliebige
147andere TCP/IP Ports können ebenso über den sicheren Channel
aebfac88
JB
148weitergeleitet werden.
149
84ae85a3
JR
150%description -l es.UTF-8
151SSH es un programa para accesar y ejecutar órdenes en computadores
152remotos. Sustituye rlogin y rsh, y suministra un canal de comunicación
6c34819e 153seguro entre dos servidores en una red insegura. Conexiones X11 y
84ae85a3 154puertas TCP/IP arbitrárias también pueden ser usadas por el canal
6c34819e 155seguro.
156
157OpenSSH es el resultado del trabajo del equipo de OpenBSD para
84ae85a3
JR
158continuar la última versión gratuita de SSH, actualizándolo en
159términos de seguridad y recursos,así también eliminando todos los
160algoritmos patentados y colocándolos en bibliotecas separadas
6c34819e 161(OpenSSL).
162
163Este paquete contiene "port" para Linux de OpenSSH. Se debe instalar
84ae85a3 164también el paquete openssh-clients u openssh-server o ambos.
6c34819e 165
84ae85a3
JR
166%description -l fr.UTF-8
167OpenSSH (Secure Shell) fournit un accès à un système distant. Il
aebfac88 168remplace telnet, rlogin, rexec et rsh, tout en assurant des
84ae85a3
JR
169communications cryptées securisées entre deux hôtes non fiabilisés sur
170un réseau non sécurisé. Des connexions X11 et des ports TCP/IP
171arbitraires peuvent également être transmis sur le canal sécurisé.
aebfac88 172
84ae85a3 173%description -l it.UTF-8
aebfac88
JB
174OpenSSH (Secure Shell) fornisce l'accesso ad un sistema remoto.
175Sostituisce telnet, rlogin, rexec, e rsh, e fornisce comunicazioni
176sicure e crittate tra due host non fidati su una rete non sicura. Le
177connessioni X11 ad una porta TCP/IP arbitraria possono essere
178inoltrate attraverso un canale sicuro.
179
84ae85a3
JR
180%description -l pl.UTF-8
181Ssh (Secure Shell) to program służący do logowania się na zdalną
182maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
183zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
184pomiędzy dwoma hostami.
93e2d77c 185
84ae85a3
JR
186Ten pakiet zawiera podstawowe pliki potrzebne zarówno po stronie
187klienta jak i serwera OpenSSH. Aby był użyteczny, trzeba zainstalować
188co najmniej jeden z pakietów: openssh-clients lub openssh-server.
a42c5034 189
0d5b2bd4 190%if %{with hpn}
84ae85a3
JR
191Ta wersja zawiera łaty z projektu High Performance SSH/SCP
192http://www.psc.edu/networking/projects/hpn-ssh/, które mają na celu
a42c5034
ER
193zwiększenie przepustowości transmisji dla szybkich połączeń z dużym
194RTT (20-150 msec). Na stronie projektu znaleźć można odpowednie dla
195danego połączenia wartości parametru '-w' oraz opcje /proc/sys dla
196TCP. Nawiasem mówiąc w sieciach LAN RTT < 1 msec.
088aab43 197%endif
aebfac88 198
84ae85a3 199%description -l pt.UTF-8
aebfac88 200OpenSSH (Secure Shell) fornece acesso a um sistema remoto. Substitui o
84ae85a3
JR
201telnet, rlogin, rexec, e o rsh e fornece comunicações seguras e
202cifradas entre duas máquinas sem confiança mútua sobre uma rede
203insegura. Ligações X11 e portos TCP/IP arbitrários também poder ser
aebfac88
JB
204reenviados pelo canal seguro.
205
84ae85a3
JR
206%description -l pt_BR.UTF-8
207SSH é um programa para acessar e executar comandos em máquinas
208remotas. Ele substitui rlogin e rsh, e provem um canal de comunicação
209seguro entre dois hosts em uma rede insegura. Conexões X11 e portas
210TCP/IP arbitrárias também podem ser usadas pelo canal seguro.
6c34819e 211
84ae85a3
JR
212OpenSSH é o resultado do trabalho da equipe do OpenBSD em continuar a
213última versão gratuita do SSH, atualizando-o em termos de segurança e
6c34819e 214recursos, assim como removendo todos os algoritmos patenteados e
215colocando-os em bibliotecas separadas (OpenSSL).
216
84ae85a3
JR
217Esse pacote contém o "port" pra Linux do OpenSSH. Você deve instalar
218também ou o pacote openssh-clients, ou o openssh-server, ou ambos.
219
220%description -l ru.UTF-8
221Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
222машину и для выполнения команд на удаленной машине. Она предназначена
223для замены rlogin и rsh и обеспечивает безопасную шифрованную
224коммуникацию между двумя хостами в сети, являющейся небезопасной.
225Соединения X11 и любые порты TCP/IP могут также быть проведены через
226безопасный канал.
227
228OpenSSH - это переделка командой разработчиков OpenBSD последней
229свободной версии SSH, доведенная до современного состояния в терминах
230уровня безопасности и поддерживаемых возможностей. Все патентованные
231алгоритмы вынесены в отдельные библиотеки (OpenSSL).
232
233Этот пакет содержит файлы, необходимые как для клиента, так и для
234сервера OpenSSH. Вам нужно будет установить еще openssh-clients,
235openssh-server, или оба пакета.
236
237%description -l uk.UTF-8
238Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
239машини та для виконання команд на віддаленій машині. Вона призначена
240для заміни rlogin та rsh і забезпечує безпечну шифровану комунікацію
241між двома хостами в мережі, яка не є безпечною. З'єднання X11 та
242довільні порти TCP/IP можуть також бути проведені через безпечний
243канал.
244
245OpenSSH - це переробка командою розробників OpenBSD останньої вільної
246версії SSH, доведена до сучасного стану в термінах рівня безпеки та
247підтримуваних можливостей. Всі патентовані алгоритми винесені до
248окремих бібліотек (OpenSSL).
249
250Цей пакет містить файли, необхідні як для клієнта, так і для сервера
251OpenSSH. Вам потрібно буде ще встановити openssh-clients,
252openssh-server, чи обидва пакети.
cb086001 253
52000378
AF
254%package clients
255Summary: OpenSSH Secure Shell protocol clients
25e16946
ER
256Summary(es.UTF-8): Clientes de OpenSSH
257Summary(pl.UTF-8): Klienci protokołu Secure Shell
258Summary(pt_BR.UTF-8): Clientes do OpenSSH
259Summary(ru.UTF-8): OpenSSH - клиенты протокола Secure Shell
260Summary(uk.UTF-8): OpenSSH - клієнти протоколу Secure Shell
52000378 261Group: Applications/Networking
f1608a0c 262Requires: %{name}
516496e1 263Provides: ssh-clients
a14c109c 264Obsoletes: ssh-clients
6fe24471 265
52000378
AF
266%description clients
267Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 268executing commands in a remote machine. It is intended to replace
269rlogin and rsh, and provide secure encrypted communications between
270two untrusted hosts over an insecure network. X11 connections and
271arbitrary TCP/IP ports can also be forwarded over the secure channel.
6fe24471 272
11530f15 273OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
274it up to date in terms of security and features, as well as removing
275all patented algorithms to seperate libraries (OpenSSL).
52000378 276
11530f15 277This package includes the clients necessary to make encrypted
278connections to SSH servers.
52000378 279
84ae85a3 280%description clients -l es.UTF-8
6c34819e 281Este paquete incluye los clientes que se necesitan para hacer
282conexiones codificadas con servidores SSH.
283
84ae85a3
JR
284%description clients -l pl.UTF-8
285Ssh (Secure Shell) to program służący do logowania się na zdalną
286maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
287zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
288pomiędzy dwoma hostami.
93e2d77c 289
84ae85a3 290Ten pakiet zawiera klientów służących do łączenia się z serwerami SSH.
93e2d77c 291
84ae85a3
JR
292%description clients -l pt_BR.UTF-8
293Esse pacote inclui os clientes necessários para fazer conexões
6c34819e 294encriptadas com servidores SSH.
295
84ae85a3
JR
296%description clients -l ru.UTF-8
297Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
298машину и для выполнения команд на удаленной машине.
cb086001 299
84ae85a3
JR
300Этот пакет содержит программы-клиенты, необходимые для установления
301зашифрованных соединений с серверами SSH.
cb086001 302
84ae85a3
JR
303%description clients -l uk.UTF-8
304Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
305машини та для виконання команд на віддаленій машині.
cb086001 306
84ae85a3
JR
307Цей пакет містить програми-клієнти, необхідні для встановлення
308зашифрованих з'єднань з серверами SSH.
cb086001 309
8a7ba6eb
AM
310%package clients-agent-profile_d
311Summary: OpenSSH Secure Shell agent init script
4944be5f 312Summary(pl.UTF-8): Skrypt startowy agenta OpenSSH
8a7ba6eb
AM
313Group: Applications/Networking
314Requires: %{name}-clients = %{epoch}:%{version}-%{release}
315
316%description clients-agent-profile_d
317profile.d scripts for starting SSH agent.
318
4944be5f
JB
319%description clients-agent-profile_d -l pl.UTF-8
320Skrypty profile.d do uruchamiania agenta SSH.
321
8a7ba6eb
AM
322%package clients-agent-xinitrc
323Summary: OpenSSH Secure Shell agent init script
324Summary(pl.UTF-8): Skrypt inicjujący agenta ssh przez xinitrc
325Group: Applications/Networking
326Requires: %{name}-clients-agent-profile_d = %{epoch}:%{version}-%{release}
327Requires: xinitrc
328
329%description clients-agent-xinitrc
330xinitrc scripts for starting SSH agent.
331
4944be5f
JB
332%description clients-agent-xinitrc -l pl.UTF-8
333Skrypty xinitrc do uruchamiania agenta SSH.
8a7ba6eb 334
52000378
AF
335%package server
336Summary: OpenSSH Secure Shell protocol server (sshd)
25e16946
ER
337Summary(de.UTF-8): OpenSSH Secure Shell Protocol-Server (sshd)
338Summary(es.UTF-8): Servidor OpenSSH para comunicaciones codificadas
339Summary(fr.UTF-8): Serveur de protocole du shell sécurisé OpenSSH (sshd)
340Summary(it.UTF-8): Server OpenSSH per il protocollo Secure Shell (sshd)
341Summary(pl.UTF-8): Serwer protokołu Secure Shell (sshd)
342Summary(pt.UTF-8): Servidor do protocolo 'Secure Shell' OpenSSH (sshd)
343Summary(pt_BR.UTF-8): Servidor OpenSSH para comunicações encriptadas
344Summary(ru.UTF-8): OpenSSH - сервер протокола Secure Shell (sshd)
345Summary(uk.UTF-8): OpenSSH - сервер протоколу Secure Shell (sshd)
52000378 346Group: Networking/Daemons
2ebfbf87 347Requires(post): /sbin/chkconfig
40cb2e83 348Requires(post): grep
0a069c2e 349Requires(post,preun): /sbin/chkconfig
9b604401 350Requires(postun): /usr/sbin/userdel
0a069c2e
ER
351Requires(pre): /bin/id
352Requires(pre): /usr/sbin/useradd
353Requires: %{name} = %{epoch}:%{version}-%{release}
2ebfbf87 354Requires: pam >= %{pam_ver}
c0f446a0 355Requires: rc-scripts >= 0.4.3.0
0a069c2e 356Requires: util-linux
0d5b2bd4 357Suggests: /bin/login
516496e1
ER
358Provides: ssh-server
359Provides: user(sshd)
52000378
AF
360
361%description server
362Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 363executing commands in a remote machine. It is intended to replace
364rlogin and rsh, and provide secure encrypted communications between
365two untrusted hosts over an insecure network. X11 connections and
366arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 367
11530f15 368OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
369it up to date in terms of security and features, as well as removing
370all patented algorithms to seperate libraries (OpenSSL).
52000378 371
11530f15 372This package contains the secure shell daemon. The sshd is the server
373part of the secure shell protocol and allows ssh clients to connect to
374your host.
6fe24471 375
84ae85a3 376%description server -l de.UTF-8
aebfac88
JB
377Dieses Paket installiert den sshd, den Server-Teil der OpenSSH.
378
84ae85a3 379%description server -l es.UTF-8
6c34819e 380Este paquete contiene el servidor SSH. sshd es la parte servidor del
381protocolo secure shell y permite que clientes ssh se conecten a su
382servidor.
383
84ae85a3 384%description server -l fr.UTF-8
aebfac88
JB
385Ce paquetage installe le 'sshd', partie serveur de OpenSSH.
386
84ae85a3 387%description server -l it.UTF-8
aebfac88
JB
388Questo pacchetto installa sshd, il server di OpenSSH.
389
84ae85a3
JR
390%description server -l pl.UTF-8
391Ssh (Secure Shell) to program służący do logowania się na zdalną
392maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
393zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
394pomiędzy dwoma hostami.
93e2d77c 395
84ae85a3 396Ten pakiet zawiera serwer sshd (do którego mogą łączyć się klienci
11530f15 397ssh).
93e2d77c 398
84ae85a3 399%description server -l pt.UTF-8
aebfac88
JB
400Este pacote intala o sshd, o servidor do OpenSSH.
401
84ae85a3
JR
402%description server -l pt_BR.UTF-8
403Esse pacote contém o servidor SSH. O sshd é a parte servidor do
6c34819e 404protocolo secure shell e permite que clientes ssh se conectem ao seu
405host.
406
84ae85a3
JR
407%description server -l ru.UTF-8
408Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
409машину и для выполнения команд на удаленной машине.
cb086001 410
84ae85a3
JR
411Этот пакет содержит sshd - "демон" Secure Shell. sshd - это серверная
412часть протокола Secure Shell, позволяющая клиентам ssh соединяться с
413вашим хостом.
cb086001 414
84ae85a3
JR
415%description server -l uk.UTF-8
416Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
417машини та для виконання команд на віддаленій машині.
cb086001 418
84ae85a3
JR
419Цей пакет містить sshd - "демон" Secure Shell. sshd - це серверна
420частина протоколу Secure Shell, яка дозволяє клієнтам ssh зв'язуватись
421з вашим хостом.
cb086001 422
c0f446a0
JK
423%package server-upstart
424Summary: Upstart job description for OpenSSH server
425Summary(pl.UTF-8): Opis zadania Upstart dla serwera OpenSSH
426Group: Daemons
427Requires: %{name}-server = %{epoch}:%{version}-%{release}
428Requires: upstart >= 0.6
429
430%description server-upstart
431Upstart job description for OpenSSH.
432
433%description server-upstart -l pl.UTF-8
434Opis zadania Upstart dla OpenSSH.
435
6e70f4f7 436%package gnome-askpass
52000378 437Summary: OpenSSH GNOME passphrase dialog
25e16946
ER
438Summary(de.UTF-8): OpenSSH GNOME Passwort-Dialog
439Summary(es.UTF-8): Diálogo para introducción de passphrase para GNOME
440Summary(fr.UTF-8): Dialogue pass-phrase GNOME d'OpenSSH
441Summary(it.UTF-8): Finestra di dialogo GNOME per la frase segreta di OpenSSH
442Summary(pl.UTF-8): Odpytywacz hasła OpenSSH dla GNOME
443Summary(pt.UTF-8): Diálogo de pedido de senha para GNOME do OpenSSH
444Summary(pt_BR.UTF-8): Diálogo para entrada de passphrase para GNOME
445Summary(ru.UTF-8): OpenSSH - диалог ввода ключевой фразы (passphrase) для GNOME
446Summary(uk.UTF-8): OpenSSH - діалог вводу ключової фрази (passphrase) для GNOME
52000378 447Group: Applications/Networking
96f686c2 448Requires: %{name} = %{epoch}:%{version}-%{release}
f937b661 449Obsoletes: openssh-askpass
0a069c2e
ER
450Obsoletes: ssh-askpass
451Obsoletes: ssh-extras
52000378 452
6e70f4f7 453%description gnome-askpass
52000378 454Ssh (Secure Shell) a program for logging into a remote machine and for
11530f15 455executing commands in a remote machine. It is intended to replace
456rlogin and rsh, and provide secure encrypted communications between
457two untrusted hosts over an insecure network. X11 connections and
458arbitrary TCP/IP ports can also be forwarded over the secure channel.
52000378 459
11530f15 460OpenSSH is OpenBSD's rework of the last free version of SSH, bringing
461it up to date in terms of security and features, as well as removing
462all patented algorithms to seperate libraries (OpenSSL).
52000378
AF
463
464This package contains the GNOME passphrase dialog.
465
84ae85a3
JR
466%description gnome-askpass -l es.UTF-8
467Este paquete contiene un programa que abre una caja de diálogo para
6c34819e 468entrada de passphrase en GNOME.
469
84ae85a3
JR
470%description gnome-askpass -l pl.UTF-8
471Ssh (Secure Shell) to program służący do logowania się na zdalną
472maszynę i uruchamiania na niej aplikacji. W zamierzeniu openssh ma
473zastąpić rlogin, rsh i dostarczyć bezpieczne, szyfrowane połączenie
474pomiędzy dwoma hostami.
93e2d77c 475
84ae85a3 476Ten pakiet zawiera ,,odpytywacz hasła'' dla GNOME.
93e2d77c 477
84ae85a3
JR
478%description gnome-askpass -l pt_BR.UTF-8
479Esse pacote contém um programa que abre uma caixa de diálogo para
6c34819e 480entrada de passphrase no GNOME.
481
84ae85a3
JR
482%description gnome-askpass -l ru.UTF-8
483Ssh (Secure Shell) - это программа для "захода" (login) на удаленную
484машину и для выполнения команд на удаленной машине.
cb086001 485
84ae85a3 486Этот пакет содержит диалог ввода ключевой фразы для использования под
cb086001 487GNOME.
488
84ae85a3
JR
489%description gnome-askpass -l uk.UTF-8
490Ssh (Secure Shell) - це програма для "заходу" (login) до віддаленої
491машини та для виконання команд на віддаленій машині.
cb086001 492
84ae85a3 493Цей пакет містить діалог вводу ключової фрази для використання під
cb086001 494GNOME.
495
b32891d6
JR
496%package -n openldap-schema-openssh-lpk
497Summary: OpenSSH LDAP Public Key schema
498Summary(pl.UTF-8): Schemat klucza publicznego LDAP dla OpenSSH
499Group: Networking/Daemons
500Requires(post,postun): sed >= 4.0
501Requires: openldap-servers
502
503%description -n openldap-schema-openssh-lpk
504This package contains OpenSSH LDAP Public Key schema for openldap.
505
506%description -n openldap-schema-openssh-lpk -l pl.UTF-8
0d5b2bd4
ER
507Ten pakiet zawiera schemat klucza publicznego LDAP dla OpenSSH dla
508openldap-a.
b32891d6 509
52000378 510%prep
ecf377a3 511%setup -q
2ebfbf87 512%{?with_kerberos5:%patch100 -p1}
4946f6e5 513%patch0 -p1
1aca01a4 514%patch2 -p1
200ba837 515%patch3 -p1
8d59ede4
JB
516%{?with_ldap:%patch4 -p1}
517%patch5 -p1
8d59ede4 518%patch7 -p1
516496e1 519%{?with_hpn:%patch9 -p1}
8d59ede4 520%patch10 -p1
100234b3 521%patch11 -p1
35844bbb 522%patch12 -p1
52000378 523
a42c5034
ER
524%if "%{pld_release}" == "ac"
525# fix for missing x11.pc
526%{__sed} -i -e '/pkg-config/s/ x11//' contrib/Makefile
527%endif
528
52000378 529%build
64f1c35c 530cp /usr/share/automake/config.sub .
0b24ec17 531%{__aclocal}
5c76eb87 532%{__autoconf}
37aa5700 533CPPFLAGS="-DCHROOT"
52000378 534%configure \
c59fae24 535 PERL=%{__perl} \
ad852e00 536 --with-dns \
41897191
AM
537 --with-pam \
538 --with-mantype=man \
f9bf943b 539 --with-md5-passwords \
4946f6e5 540 --with-ipaddr-display \
f6c7fa07 541 %{?with_libedit:--with-libedit} \
93e2d77c 542 --with-4in6 \
41897191 543 --disable-suid-ssh \
06b95d40 544 --with-tcp-wrappers \
9cfed0b2 545 %{?with_ldap:--with-libs="-lldap -llber"} \
546 %{?with_ldap:--with-cppflags="-DWITH_LDAP_PUBKEY"} \
4a5c0c7d 547 %{?with_kerberos5:--with-kerberos5=/usr} \
a14c109c 548 --with-privsep-path=%{_privsepdir} \
05fbd2e9 549 --with-pid-dir=%{_localstatedir}/run \
2ebfbf87
ER
550%if "%{pld_release}" == "ac"
551 --with-xauth=/usr/X11R6/bin/xauth \
552%else
c7963a12 553 --with-xauth=/usr/bin/xauth \
2ebfbf87 554%endif
c7963a12
JR
555 --enable-utmpx \
556 --enable-wtmpx
82f989ae 557
b8002dec 558echo '#define LOGIN_PROGRAM "/bin/login"' >>config.h
f9bf943b 559
100832a0 560%{__make}
475ef6df 561
40cb2e83 562cd contrib
9cfed0b2 563%if %{with gnome}
40cb2e83
JB
564%{__make} gnome-ssh-askpass1 \
565 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
566%endif
9cfed0b2 567%if %{with gtk}
40cb2e83
JB
568%{__make} gnome-ssh-askpass2 \
569 CC="%{__cc} %{rpmldflags} %{rpmcflags}"
570%endif
6fe24471
AF
571
572%install
573rm -rf $RPM_BUILD_ROOT
c0f446a0 574install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{init,pam.d,rc.d/init.d,sysconfig,security,env.d}} \
b32891d6 575 $RPM_BUILD_ROOT{%{_libexecdir}/ssh,%{schemadir}}
8a7ba6eb 576install -d $RPM_BUILD_ROOT/etc/{profile.d,X11/xinit/xinitrc.d}
52000378 577
9a2a459a
PG
578%{__make} install \
579 DESTDIR=$RPM_BUILD_ROOT
0d32b20f 580
486d736c 581bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
40cb2e83 582
486d736c
JR
583install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
584install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/sshd
585install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/sshd
586install %{SOURCE5} $RPM_BUILD_ROOT/etc/profile.d
587ln -sf /etc/profile.d/ssh-agent.sh $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/ssh-agent.sh
588install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
b32891d6 589install %{SOURCE7} $RPM_BUILD_ROOT%{schemadir}
2b7669a6 590
c0f446a0
JK
591install %{SOURCE8} $RPM_BUILD_ROOT/etc/init/sshd.conf
592
9cfed0b2 593%if %{with gnome}
40cb2e83
JB
594install contrib/gnome-ssh-askpass1 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
595%endif
9cfed0b2 596%if %{with gtk}
40cb2e83 597install contrib/gnome-ssh-askpass2 $RPM_BUILD_ROOT%{_libexecdir}/ssh/ssh-askpass
1d1e6997
PG
598%endif
599%if %{with gnome} || %{with gtk}
6157007b 600cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_SERVER
1d1e6997
PG
601#GNOME_SSH_ASKPASS_GRAB_SERVER="true"
602EOF
6157007b 603cat << 'EOF' >$RPM_BUILD_ROOT/etc/env.d/GNOME_SSH_ASKPASS_GRAB_POINTER
1d1e6997
PG
604#GNOME_SSH_ASKPASS_GRAB_POINTER="true"
605EOF
4ae0bc0d 606ln -s %{_libexecdir}/ssh/ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/ssh-askpass
40cb2e83 607%endif
6e70f4f7 608
0906c8d0 609install contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
610install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
611
8e700b6b 612rm -f $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
5f72fe6f 613echo ".so ssh.1" > $RPM_BUILD_ROOT%{_mandir}/man1/slogin.1
41897191 614
ffbc041f 615touch $RPM_BUILD_ROOT/etc/security/blacklist.sshd
643dc12f 616
b8002dec 617cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/SSH_ASKPASS
1d1e6997
PG
618#SSH_ASKPASS="%{_libexecdir}/ssh-askpass"
619EOF
620
92815192
ER
621rm -f $RPM_BUILD_ROOT%{_datadir}/Ssh.bin # ???
622rm -f $RPM_BUILD_ROOT%{_mandir}/README.openssh-non-english-man-pages
623
6fe24471
AF
624%clean
625rm -rf $RPM_BUILD_ROOT
626
b259ae2c
ER
627%post clients
628%env_update
629
630%postun clients
631%env_update
632
633%post gnome-askpass
634%env_update
635
636%postun gnome-askpass
637%env_update
638
8a304ceb 639%pre server
0225d3b8 640%useradd -P %{name}-server -u 40 -d %{_privsepdir} -s /bin/false -c "OpenSSH PrivSep User" -g nobody sshd
4c8ae2f8 641
52000378 642%post server
d7fde396 643/sbin/chkconfig --add sshd
2c99507e 644%service sshd reload "openssh daemon"
40cb2e83
JB
645if ! grep -qs ssh /etc/security/passwd.conf ; then
646 umask 022
ec00afd0
JR
647 echo "ssh" >> /etc/security/passwd.conf
648fi
6fe24471 649
52000378 650%preun server
d7fde396 651if [ "$1" = "0" ]; then
b054de44 652 %service sshd stop
d7fde396 653 /sbin/chkconfig --del sshd
654fi
6fe24471 655
9b604401
JB
656%postun server
657if [ "$1" = "0" ]; then
5f4ffc90 658 %userremove sshd
9b604401
JB
659fi
660
c0f446a0
JK
661%post server-upstart
662%upstart_post sshd
663
664%postun server-upstart
665%upstart_postun sshd
666
7073aeeb
JR
667%post -n openldap-schema-openssh-lpk
668%openldap_schema_register %{schemadir}/openssh-lpk.schema
669%service -q ldap restart
670
671%postun -n openldap-schema-openssh-lpk
672if [ "$1" = "0" ]; then
673 %openldap_schema_unregister %{schemadir}/openssh-lpk.schema
674 %service -q ldap restart
675fi
676
6fe24471 677%files
52000378 678%defattr(644,root,root,755)
7cc45b9b 679%doc *.RNG TODO README OVERVIEW CREDITS Change*
a6eef44c 680%attr(755,root,root) %{_bindir}/ssh-key*
35844bbb 681%attr(755,root,root) %{_bindir}/ssh-vulnkey*
a6eef44c 682%{_mandir}/man1/ssh-key*.1*
35844bbb 683%{_mandir}/man1/ssh-vulnkey*.1*
52000378 684%dir %{_sysconfdir}
9df62d0f 685%dir %{_libexecdir}
52000378
AF
686
687%files clients
688%defattr(644,root,root,755)
96f686c2
JB
689%attr(755,root,root) %{_bindir}/ssh
690%attr(755,root,root) %{_bindir}/slogin
691%attr(755,root,root) %{_bindir}/sftp
692%attr(755,root,root) %{_bindir}/ssh-agent
693%attr(755,root,root) %{_bindir}/ssh-add
0906c8d0 694%attr(755,root,root) %{_bindir}/ssh-copy-id
96f686c2 695%attr(755,root,root) %{_bindir}/scp
794e0987
JB
696%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh_config
697%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/SSH_ASKPASS
52000378
AF
698%{_mandir}/man1/scp.1*
699%{_mandir}/man1/ssh.1*
41897191 700%{_mandir}/man1/slogin.1*
a6eef44c 701%{_mandir}/man1/sftp.1*
52000378
AF
702%{_mandir}/man1/ssh-agent.1*
703%{_mandir}/man1/ssh-add.1*
0906c8d0 704%{_mandir}/man1/ssh-copy-id.1*
902cef13 705%{_mandir}/man5/ssh_config.5*
2b7669a6 706%lang(it) %{_mandir}/it/man1/ssh.1*
707%lang(it) %{_mandir}/it/man5/ssh_config.5*
708%lang(pl) %{_mandir}/pl/man1/scp.1*
709%lang(zh_CN) %{_mandir}/zh_CN/man1/scp.1*
ec82f607
JB
710
711# for host-based auth (suid required for accessing private host key)
712#%attr(4755,root,root) %{_libexecdir}/ssh-keysign
713#%{_mandir}/man8/ssh-keysign.8*
52000378 714
8a7ba6eb
AM
715%files clients-agent-profile_d
716%defattr(644,root,root,755)
717%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ssh-agent.conf
718%attr(755,root,root) /etc/profile.d/ssh-agent.sh
719
720%files clients-agent-xinitrc
721%defattr(644,root,root,755)
722%attr(755,root,root) /etc/X11/xinit/xinitrc.d/ssh-agent.sh
723
52000378
AF
724%files server
725%defattr(644,root,root,755)
726%attr(755,root,root) %{_sbindir}/sshd
a6eef44c 727%attr(755,root,root) %{_libexecdir}/sftp-server
ad852e00 728%attr(755,root,root) %{_libexecdir}/ssh-keysign
50835229 729%attr(755,root,root) %{_libexecdir}/ssh-pkcs11-helper
52000378 730%{_mandir}/man8/sshd.8*
a6eef44c 731%{_mandir}/man8/sftp-server.8*
ad852e00 732%{_mandir}/man8/ssh-keysign.8*
50835229 733%{_mandir}/man8/ssh-pkcs11-helper.8*
902cef13 734%{_mandir}/man5/sshd_config.5*
78aa4c3c 735%{_mandir}/man5/moduli.5*
794e0987
JB
736%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sshd_config
737%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sshd
634d69b4 738%attr(640,root,root) %{_sysconfdir}/moduli
52000378 739%attr(754,root,root) /etc/rc.d/init.d/sshd
794e0987
JB
740%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/sshd
741%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.sshd
52000378 742
0d32b20f 743%if %{with gnome} || %{with gtk}
40cb2e83
JB
744%files gnome-askpass
745%defattr(644,root,root,755)
794e0987 746%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GNOME_SSH_ASKPASS*
40cb2e83
JB
747%dir %{_libexecdir}/ssh
748%attr(755,root,root) %{_libexecdir}/ssh/ssh-askpass
4ae0bc0d 749%attr(755,root,root) %{_libexecdir}/ssh-askpass
40cb2e83 750%endif
b32891d6
JR
751
752%if %{with ldap}
753%files -n openldap-schema-openssh-lpk
754%defattr(644,root,root,755)
755%{schemadir}/openssh-lpk.schema
756%endif
c0f446a0
JK
757
758%files server-upstart
759%defattr(644,root,root,755)
760%config(noreplace) %verify(not md5 mtime size) /etc/init/sshd.conf
This page took 0.281865 seconds and 4 git commands to generate.