]> git.pld-linux.org Git - packages/opencv.git/commitdiff
- fix c/c++ mixed header auto/th/opencv-4.5.1-3
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 7 Mar 2021 19:03:59 +0000 (20:03 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 7 Mar 2021 19:03:59 +0000 (20:03 +0100)
- rel 3

no-cxx-in-c-header.patch [new file with mode: 0644]
opencv.spec

diff --git a/no-cxx-in-c-header.patch b/no-cxx-in-c-header.patch
new file mode 100644 (file)
index 0000000..930087e
--- /dev/null
@@ -0,0 +1,18 @@
+--- opencv-4.5.1/modules/core/include/opencv2/core/cvdef.h~    2020-12-21 21:01:38.000000000 +0100
++++ opencv-4.5.1/modules/core/include/opencv2/core/cvdef.h     2021-03-07 19:39:51.440476065 +0100
+@@ -719,6 +719,7 @@
+ /****************************************************************************************\
+ *                                    C++ 11                                              *
+ \****************************************************************************************/
++#ifdef __cplusplus
+ #ifndef CV_CXX11
+ #  if __cplusplus >= 201103L || (defined(_MSC_VER) && _MSC_VER >= 1800)
+ #    define CV_CXX11 1
+@@ -760,6 +761,7 @@
+ #ifndef CV_CONSTEXPR
+ #  define CV_CONSTEXPR
+ #endif
++#endif
+ // Integer types portatibility
+ #ifdef OPENCV_STDINT_HEADER
index 32261fc5a4b561ef2e55ccc8d9a0ec3e3a9198f9..82a532b2e266ab03ad7c11288f20091c39f208e5 100644 (file)
@@ -60,7 +60,7 @@ Summary:      A library of programming functions mainly aimed at real time computer v
 Summary(pl.UTF-8):     Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
 Name:          opencv
 Version:       4.5.1
-Release:       2
+Release:       3
 Epoch:         1
 %if %{with unicap} || %{with xine}
 License:       GPL (enforced by used libraries), BSD (opencv itself)
@@ -105,6 +105,7 @@ Source40:   https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
 Patch0:                %{name}-ximea.patch
 Patch1:                python-install.patch
 Patch2:                pkgconfig-paths.patch
+Patch3:                no-cxx-in-c-header.patch
 URL:           http://www.opencv.org/
 %{?with_pvapi:BuildRequires:   AVT_GigE_SDK-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -330,6 +331,7 @@ Wiązania Pythona 3 do OpenCV.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cache_file() {
        f="$1"
This page took 0.035363 seconds and 4 git commands to generate.