]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
32261fc5a4b561ef2e55ccc8d9a0ec3e3a9198f9
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        2
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 Patch2:         pkgconfig-paths.patch
108 URL:            http://www.opencv.org/
109 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
110 %{?with_opencl:BuildRequires:   OpenCL-devel}
111 BuildRequires:  Mesa-khrplatform-devel
112 BuildRequires:  OpenEXR-devel
113 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
114 %{?with_opengl:BuildRequires:   OpenGL-devel}
115 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
116 %{?with_openni:BuildRequires:   OpenNI-devel}
117 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
118 %{?with_java:BuildRequires:     ant}
119 BuildRequires:  boost-devel
120 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
121 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
122 BuildRequires:  cmake >= 2.8
123 BuildRequires:  doxygen
124 BuildRequires:  eigen3 >= 3
125 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
126 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
127 BuildRequires:  gflags-devel
128 BuildRequires:  gl2ps-devel
129 BuildRequires:  glog-devel
130 %if %{with gstreamer}
131 BuildRequires:  gstreamer-devel >= 1.0
132 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
133 %endif
134 BuildRequires:  jasper-devel
135 %{?with_java:BuildRequires:     jdk}
136 BuildRequires:  libdc1394-devel >= 2
137 %{?with_openmp:BuildRequires:   libgomp-devel}
138 BuildRequires:  libjpeg-devel
139 BuildRequires:  libpng-devel
140 BuildRequires:  libraw1394-devel
141 BuildRequires:  libstdc++-devel
142 BuildRequires:  libtiff-devel
143 BuildRequires:  libtool
144 %if %{with unicap}
145 BuildRequires:  libucil-devel
146 BuildRequires:  libunicap-devel
147 %endif
148 BuildRequires:  libv4l-devel
149 BuildRequires:  ogre-devel
150 BuildRequires:  pkgconfig
151 BuildRequires:  protobuf-devel
152 BuildRequires:  python >= 2.0
153 BuildRequires:  python-devel >= 2.0
154 BuildRequires:  python-numpy-devel
155 BuildRequires:  python3 >= 1:3.2
156 BuildRequires:  python3-devel >= 1:3.2
157 BuildRequires:  python3-numpy-devel
158 BuildRequires:  rpm-pythonprov
159 BuildRequires:  rpmbuild(macros) >= 1.606
160 BuildRequires:  sed >= 4.0
161 BuildRequires:  sphinx-pdg
162 BuildRequires:  swig-python
163 %{?with_tbb:BuildRequires:      tbb-devel}
164 %if %{with vtk}
165 BuildRequires:  vtk-devel >= 5.8.0
166 BuildRequires:  vtk-java >= 5.8.0
167 BuildRequires:  vtk-python3-devel >= 5.8.0
168 %endif
169 %{?with_xine:BuildRequires:     xine-lib-devel}
170 BuildRequires:  xorg-lib-libX11-devel
171 BuildRequires:  zlib-devel
172 %if %{with qt}
173 BuildRequires:  QtCore-devel >= 4
174 BuildRequires:  QtGui-devel >= 4
175 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
176 BuildRequires:  qt4-qmake >= 4
177 %else
178 BuildRequires:  gtk+2-devel >= 2.0
179 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
180 %endif
181 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
182 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
183
184 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
185 %define         sover   %(echo %{version} | cut -d. -f1-2)
186
187 %description
188 OpenCV (Open Source Computer Vision) is a library of programming
189 functions mainly aimed at real time computer vision.
190
191 Example applications of the OpenCV library are:
192 - Human-Computer Interaction (HCI)
193 - Object Identification, Segmentation and Recognition
194 - Face Recognition
195 - Gesture Recognition
196 - Motion Tracking
197 - Ego Motion, Motion Understanding
198 - Structure From Motion (SFM)
199 - Stereo and Multi-Camera Calibration and Depth Computation
200 - Mobile Robotics.
201
202 %description -l pl.UTF-8
203 OpenCV (Open Source Computer Vision) to biblioteka funkcji
204 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
205
206 Przykładowe zastosowania biblioteki OpenCV to
207 - interakcje człowiek-komputer (HCI)
208 - identyfikacja, segmentacja i rozpoznawanie obiektów
209 - rozpoznawanie twarzy
210 - rozpoznawanie gestów
211 - śledzenie ruchu
212 - rozumienie ruchu
213 - SFM (Structure From Motion)
214 - kalibracja dwu- i wielokamerowa, obliczanie głębi
215 - robotyka ruchu.
216
217 %package core
218 Summary:        OpenCV core libraries
219 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
220 Group:          Libraries
221 Conflicts:      opencv < 2.4.6.2-1
222
223 %description core
224 This package contains the OpenCV C/C++ core libraries.
225
226 %description core -l pl.UTF-8
227 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
228
229 %package viz
230 Summary:        OpenCV viz library (VTK support)
231 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
232 Group:          Libraries
233 Requires:       %{name} = %{epoch}:%{version}-%{release}
234
235 %description viz
236 OpenCV viz library (VTK support).
237
238 %description viz -l pl.UTF-8
239 Biblioteka OpenCV viz (obsługa VTK).
240
241 %package devel
242 Summary:        Header files for OpenCV library
243 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
244 Group:          Development/Libraries
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246 %if %{with vtk}
247 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
248 %endif
249 Obsoletes:      opencv-static
250
251 %description devel
252 Header files for OpenCV library.
253
254 %description devel -l pl.UTF-8
255 Pliki nagłówkowe biblioteki OpenCV.
256
257 %package doc
258 Summary:        Manual for OpenCV
259 Summary(fr.UTF-8):      Documentation pour OpenCV
260 Summary(it.UTF-8):      Documentazione di OpenCV
261 Summary(pl.UTF-8):      Podręcznik dla OpenCV
262 Group:          Documentation
263 # noarch subpackages only when building with rpm5
264 BuildArch:      noarch
265
266 %description doc
267 Documentation for OpenCV.
268
269 %description doc -l fr.UTF-8
270 Documentation pour OpenCV.
271
272 %description doc -l it.UTF-8
273 Documentazione di OpenCV.
274
275 %description doc -l pl.UTF-8
276 Dokumentacja do OpenCV.
277
278 %package examples
279 Summary:        OpenCV code examples
280 Group:          Documentation
281 BuildArch:      noarch
282
283 %description examples
284 OpenCV code examples.
285
286 %package -n java-opencv
287 Summary:        OpenCV Java bindings
288 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
289 Group:          Libraries/Java
290 Requires:       %{name} = %{epoch}:%{version}-%{release}
291 Requires:       jre
292
293 %description -n java-opencv
294 OpenCV Java bindings.
295
296 %description -n java-opencv -l pl.UTF-8
297 Wiązania Javy do OpenCV.
298
299 %package -n python-opencv
300 Summary:        OpenCV Python 2 bindings
301 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
302 Group:          Libraries/Python
303 Requires:       %{name} = %{epoch}:%{version}-%{release}
304 Requires:       python-libs
305
306 %description -n python-opencv
307 OpenCV Python 2 bindings.
308
309 %description -n python-opencv -l pl.UTF-8
310 Wiązania Pythona 2 do OpenCV.
311
312 %package -n python3-opencv
313 Summary:        OpenCV Python 3 bindings
314 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
315 Group:          Libraries/Python
316 Requires:       %{name} = %{epoch}:%{version}-%{release}
317 Requires:       python3-libs
318
319 %description -n python3-opencv
320 OpenCV Python 3 bindings.
321
322 %description -n python3-opencv -l pl.UTF-8
323 Wiązania Pythona 3 do OpenCV.
324
325 %prep
326 %setup -q -a1
327
328 %undos CMakeLists.txt
329
330 %patch0 -p1
331 %patch1 -p1
332 %patch2 -p1
333
334 cache_file() {
335         f="$1"
336         d="$2"
337         md5="$(md5sum "$f" | awk '{print $1}')"
338         file="$(basename "$f")"
339         mkdir -p ".cache/$d"
340         install "$f" ".cache/$d/$md5-$file"
341 }
342 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
343         cache_file $f xfeatures2d/boostdesc
344 done
345 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
346         cache_file $f xfeatures2d/vgg
347 done
348 cache_file %{SOURCE30} data
349 cache_file %{SOURCE40} ade
350
351 %build
352 mkdir -p build
353 cd build
354
355 # handle cmake & ccache
356 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
357 if [[ "%{__cc}" = *ccache* ]]; then
358         cc="%{__cc}"
359         cxx="%{__cxx}"
360         ccache="
361         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
362         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
363         "
364 fi
365
366 %cmake .. \
367         $ccache \
368         -DENABLE_PRECOMPILED_HEADERS=OFF \
369         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
370         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
371         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
372         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
373         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
374         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
375         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
376         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
377         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
378         -DBUILD_NEW_PYTHON_SUPPORT=ON \
379         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
380 %if %{with examples}
381         -DINSTALL_C_EXAMPLES=ON \
382         -DINSTALL_PYTHON_EXAMPLES=ON \
383 %endif
384         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
385         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
386         %{?with_opencl:-DWITH_OPENCL=ON} \
387         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
388         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
389         %{?with_opengl:-DWITH_OPENGL=ON} \
390         %{?with_openmp:-DWITH_OPENMP=ON} \
391         %{?with_openni:-DWITH_OPENNI=ON} \
392         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
393         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
394         %{?with_tbb:-DWITH_TBB=ON} \
395         %{?with_unicap:-DWITH_UNICAP=ON} \
396         %{!?with_v4l:-DWITH_V4L=OFF} \
397         %{?with_vtk:-DWITH_VTK=ON} \
398         %{?with_ximea:-DWITH_XIMEA=ON} \
399         %{?with_xine:-DWITH_XINE=ON} \
400         -DWITH_IPP=OFF
401
402 %{__make}
403
404 %install
405 rm -rf $RPM_BUILD_ROOT
406 %{__make} -C build install \
407         DESTDIR=$RPM_BUILD_ROOT
408
409 %if %{with examples}
410 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
411 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
412 %endif
413
414 # disable completeness check incompatible with split packaging
415 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
416
417 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
418 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
419 %py_postclean
420
421 %if %{with java}
422 # move to proper directories, create symlink
423 install -d $RPM_BUILD_ROOT%{_javadir}
424 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
425 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
426         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
427 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
428 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
429 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
430 %endif
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %post   -p /sbin/ldconfig
436 %postun -p /sbin/ldconfig
437
438 %post   core -p /sbin/ldconfig
439 %postun core -p /sbin/ldconfig
440
441 %post   viz -p /sbin/ldconfig
442 %postun viz -p /sbin/ldconfig
443
444 %post   -n java-opencv -p /sbin/ldconfig
445 %postun -n java-opencv -p /sbin/ldconfig
446
447 %files
448 %defattr(644,root,root,755)
449 %attr(755,root,root) %{_bindir}/opencv_annotation
450 #%attr(755,root,root) %{_bindir}/opencv_createsamples
451 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
452 #%attr(755,root,root) %{_bindir}/opencv_traincascade
453 %attr(755,root,root) %{_bindir}/opencv_version
454 %attr(755,root,root) %{_bindir}/opencv_visualisation
455 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
456 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
457 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
458 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
460 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
462 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
464 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
466 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
467 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
468 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
469 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
470 # contrib modules
471 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
472 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
473 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
475 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
477 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
479 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
481 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
482 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
483 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
484 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
485 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
487 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
488 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
489 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
490 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
491 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
493 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
494 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
495 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
497 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
498 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
499 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
523 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
525 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
527 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
529 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
547 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
549 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
550
551 %dir %{_datadir}/opencv4
552 %{_datadir}/opencv4/haarcascades
553 %{_datadir}/opencv4/lbpcascades
554 %{_datadir}/opencv4/quality
555
556 %files core
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
560 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
562 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
564 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
565 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
566 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
567 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
568 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
570 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
572 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
574 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
576
577 %if %{with vtk}
578 %files viz
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
582 %endif
583
584 %files devel
585 %defattr(644,root,root,755)
586 # core
587 %{_libdir}/libopencv_core.so
588 %{_libdir}/libopencv_flann.so
589 %{_libdir}/libopencv_imgproc.so
590 %{_libdir}/libopencv_ml.so
591 %{_libdir}/libopencv_photo.so
592 %{_libdir}/libopencv_video.so
593 # GUI/extensions (base package)
594 %{_libdir}/libopencv_calib3d.so
595 %{_libdir}/libopencv_features2d.so
596 %{_libdir}/libopencv_highgui.so
597 %{_libdir}/libopencv_objdetect.so
598 %{_libdir}/libopencv_stitching.so
599 %{_libdir}/libopencv_superres.so
600 %{_libdir}/libopencv_videostab.so
601 %{_libdir}/libopencv_imgcodecs.so
602 %{_libdir}/libopencv_shape.so
603 %{_libdir}/libopencv_videoio.so
604 # contrib
605 %{_libdir}/libopencv_aruco.so
606 %{_libdir}/libopencv_bgsegm.so
607 %{_libdir}/libopencv_bioinspired.so
608 %{_libdir}/libopencv_ccalib.so
609 %{_libdir}/libopencv_datasets.so
610 %{_libdir}/libopencv_dnn.so
611 %{_libdir}/libopencv_dnn_objdetect.so
612 %{_libdir}/libopencv_dpm.so
613 %{_libdir}/libopencv_face.so
614 %{_libdir}/libopencv_freetype.so
615 %{_libdir}/libopencv_fuzzy.so
616 %{_libdir}/libopencv_hdf.so
617 %{_libdir}/libopencv_hfs.so
618 %{_libdir}/libopencv_img_hash.so
619 %{_libdir}/libopencv_line_descriptor.so
620 %{_libdir}/libopencv_optflow.so
621 %{_libdir}/libopencv_ovis.so
622 %{_libdir}/libopencv_phase_unwrapping.so
623 %{_libdir}/libopencv_plot.so
624 %{_libdir}/libopencv_reg.so
625 %{_libdir}/libopencv_rgbd.so
626 %{_libdir}/libopencv_saliency.so
627 %{_libdir}/libopencv_sfm.so
628 %{_libdir}/libopencv_stereo.so
629 %{_libdir}/libopencv_structured_light.so
630 %{_libdir}/libopencv_surface_matching.so
631 %{_libdir}/libopencv_text.so
632 %{_libdir}/libopencv_tracking.so
633 %{_libdir}/libopencv_xfeatures2d.so
634 %{_libdir}/libopencv_ximgproc.so
635 %{_libdir}/libopencv_xobjdetect.so
636 %{_libdir}/libopencv_xphoto.so
637 %{_libdir}/libopencv_alphamat.so
638 %{_libdir}/libopencv_dnn_superres.so
639 %{_libdir}/libopencv_gapi.so
640 %{_libdir}/libopencv_intensity_transform.so
641 %{_libdir}/libopencv_mcc.so
642 %{_libdir}/libopencv_quality.so
643 %{_libdir}/libopencv_rapid.so
644 # viz
645 %if %{with vtk}
646 %{_libdir}/libopencv_viz.so
647 %endif
648 %{_includedir}/opencv4
649 %dir %{_libdir}/cmake/opencv4
650 %{_libdir}/cmake/opencv4/OpenCV*.cmake
651 %{_pkgconfigdir}/opencv4.pc
652
653 %files doc
654 %defattr(644,root,root,755)
655 # TODO: probably could rebuild them and package via make install
656 %doc doc/*
657
658 %if %{with examples}
659 %files examples
660 %defattr(644,root,root,755)
661 %{_examplesdir}/%{name}-%{version}
662 %endif
663
664 %if %{with java}
665 %files -n java-opencv
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
668 %{_javadir}/opencv-%{jver}.jar
669 %{_javadir}/opencv.jar
670 %endif
671
672 %files -n python-opencv
673 %defattr(644,root,root,755)
674 %dir %{py_sitedir}/cv2
675 %dir %{py_sitedir}/cv2/python-*
676 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
677 %{py_sitedir}/cv2/*.py[co]
678
679 %files -n python3-opencv
680 %defattr(644,root,root,755)
681 %dir %{py3_sitedir}/cv2
682 %dir %{py3_sitedir}/cv2/python-*
683 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
684 %{py3_sitedir}/cv2/*.py
This page took 0.061397 seconds and 2 git commands to generate.