]> git.pld-linux.org Git - packages/opencv.git/blob - opencv.spec
- fix c/c++ mixed header
[packages/opencv.git] / opencv.spec
1 # TODO:
2 # - contrib subpackage(s)
3 # - contrib BRs:
4 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6 #   opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7 #   opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8 #   opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9 #   opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
10 # unpackaged (3.4.0)
11 #/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12 #/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13 #/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14 #/usr/share/OpenCV/valgrind.supp
15 #/usr/share/OpenCV/valgrind_3rdparty.supp
16
17 #
18 # - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
19 # - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
20 # - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
21 #
22 # Conditional build:
23 # - general options:
24 %bcond_with     tbb             # Threading Building Blocks support (everywhere)
25 %bcond_with     sse             # use SSE instructions
26 %bcond_with     sse2            # use SSE2 instructions
27 %bcond_with     sse3            # use SSE3 instructions
28 %bcond_with     ssse3           # use SSSE3 instructions
29 %bcond_with     sse41           # use SSE4.1 instructions
30 %bcond_with     sse42           # use SSE4.2 instructions
31 %bcond_with     avx             # use AVX instructions
32 %bcond_without  opencl          # OpenCL support
33 %bcond_with     opencl_amdblas  # AMD OpenCL BLAS routines
34 %bcond_with     opencl_amdfft   # AMD OpenCL FFT routines
35 %bcond_without  opengl          # OpenGL support
36 %bcond_without  openmp          # OpenMP support (available when not using tbb)
37 %bcond_without  examples        # Install examples
38 # - bindings
39 %bcond_without  java            # Java binding
40 # - highgui options:
41 %bcond_without  ffmpeg          # FFMpeg support in highgui
42 %bcond_without  gstreamer       # GStreamer support in highgui
43 %bcond_with     openni          # OpenNI (Natural Interaction) support in highgui
44 %bcond_with     pvapi           # PvAPI (AVT GigE cameras) support in highgui (proprietary)
45 %bcond_with     qt              # Qt backend instead of GTK+ in highgui
46 %bcond_with     unicap          # Unicap support in highgui (GPL)
47 %bcond_without  v4l             # Video4Linux in highgui
48 %bcond_with     ximea           # m3API (XIMEA cameras) support in highgui (proprietary)
49 %bcond_with     xine            # XINE support in highgui (GPL)
50 # - other modules
51 %bcond_without  vtk             # VTK library support (opencv_viz module)
52
53 %ifarch pentium3 pentium4 %{x8664} x32
54 %define         with_sse        1
55 %endif
56 %ifarch pentium4 %{x8664} x32
57 %define         with_sse2       1
58 %endif
59 Summary:        A library of programming functions mainly aimed at real time computer vision
60 Summary(pl.UTF-8):      Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
61 Name:           opencv
62 Version:        4.5.1
63 Release:        3
64 Epoch:          1
65 %if %{with unicap} || %{with xine}
66 License:        GPL (enforced by used libraries), BSD (opencv itself)
67 %else
68 License:        BSD
69 %endif
70 Group:          Libraries
71 Source0:        https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
72 # Source0-md5:  2205d3169238ec1f184438a96de68513
73 Source1:        https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
74 # Source1-md5:  19a31bf7271978ab426112dbf5d1b83f
75 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76 Source10:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77 # Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78 Source11:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79 # Source11-md5: 232c966b13651bd0e46a1497b0852191
80 Source12:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81 # Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82 Source13:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83 # Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84 Source14:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85 # Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86 Source15:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87 # Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88 Source16:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89 # Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90 # See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91 Source20:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92 # Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93 Source21:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94 # Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95 Source22:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96 # Source22-md5: 7cd47228edec52b6d82f46511af325c5
97 Source23:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98 # Source23-md5: 151805e03568c9f490a5e3a872777b75
99 # See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
100 Source30:       https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101 # Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102 # See opencv-4.5.1/modules/gapi/CMakeLists.txt
103 Source40:       https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104 # Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
105 Patch0:         %{name}-ximea.patch
106 Patch1:         python-install.patch
107 Patch2:         pkgconfig-paths.patch
108 Patch3:         no-cxx-in-c-header.patch
109 URL:            http://www.opencv.org/
110 %{?with_pvapi:BuildRequires:    AVT_GigE_SDK-devel}
111 %{?with_opencl:BuildRequires:   OpenCL-devel}
112 BuildRequires:  Mesa-khrplatform-devel
113 BuildRequires:  OpenEXR-devel
114 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
115 %{?with_opengl:BuildRequires:   OpenGL-devel}
116 # as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
117 %{?with_openni:BuildRequires:   OpenNI-devel}
118 %{?with_ximea:BuildRequires:    XIMEA-devel >= 4}
119 %{?with_java:BuildRequires:     ant}
120 BuildRequires:  boost-devel
121 %{?with_opencl_amdblas:BuildRequires:   clAmdBlas-devel}
122 %{?with_opencl_amdfft:BuildRequires:    clAmdFft-devel}
123 BuildRequires:  cmake >= 2.8
124 BuildRequires:  doxygen
125 BuildRequires:  eigen3 >= 3
126 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel >= 0.7}
127 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
128 BuildRequires:  gflags-devel
129 BuildRequires:  gl2ps-devel
130 BuildRequires:  glog-devel
131 %if %{with gstreamer}
132 BuildRequires:  gstreamer-devel >= 1.0
133 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
134 %endif
135 BuildRequires:  jasper-devel
136 %{?with_java:BuildRequires:     jdk}
137 BuildRequires:  libdc1394-devel >= 2
138 %{?with_openmp:BuildRequires:   libgomp-devel}
139 BuildRequires:  libjpeg-devel
140 BuildRequires:  libpng-devel
141 BuildRequires:  libraw1394-devel
142 BuildRequires:  libstdc++-devel
143 BuildRequires:  libtiff-devel
144 BuildRequires:  libtool
145 %if %{with unicap}
146 BuildRequires:  libucil-devel
147 BuildRequires:  libunicap-devel
148 %endif
149 BuildRequires:  libv4l-devel
150 BuildRequires:  ogre-devel
151 BuildRequires:  pkgconfig
152 BuildRequires:  protobuf-devel
153 BuildRequires:  python >= 2.0
154 BuildRequires:  python-devel >= 2.0
155 BuildRequires:  python-numpy-devel
156 BuildRequires:  python3 >= 1:3.2
157 BuildRequires:  python3-devel >= 1:3.2
158 BuildRequires:  python3-numpy-devel
159 BuildRequires:  rpm-pythonprov
160 BuildRequires:  rpmbuild(macros) >= 1.606
161 BuildRequires:  sed >= 4.0
162 BuildRequires:  sphinx-pdg
163 BuildRequires:  swig-python
164 %{?with_tbb:BuildRequires:      tbb-devel}
165 %if %{with vtk}
166 BuildRequires:  vtk-devel >= 5.8.0
167 BuildRequires:  vtk-java >= 5.8.0
168 BuildRequires:  vtk-python3-devel >= 5.8.0
169 %endif
170 %{?with_xine:BuildRequires:     xine-lib-devel}
171 BuildRequires:  xorg-lib-libX11-devel
172 BuildRequires:  zlib-devel
173 %if %{with qt}
174 BuildRequires:  QtCore-devel >= 4
175 BuildRequires:  QtGui-devel >= 4
176 %{?with_opengl:BuildRequires:   QtOpenGL-devel >= 4}
177 BuildRequires:  qt4-qmake >= 4
178 %else
179 BuildRequires:  gtk+2-devel >= 2.0
180 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
181 %endif
182 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
183 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
184
185 %define         jver    %(echo %{version} | cut -d. -f1-3 | tr -d .)
186 %define         sover   %(echo %{version} | cut -d. -f1-2)
187
188 %description
189 OpenCV (Open Source Computer Vision) is a library of programming
190 functions mainly aimed at real time computer vision.
191
192 Example applications of the OpenCV library are:
193 - Human-Computer Interaction (HCI)
194 - Object Identification, Segmentation and Recognition
195 - Face Recognition
196 - Gesture Recognition
197 - Motion Tracking
198 - Ego Motion, Motion Understanding
199 - Structure From Motion (SFM)
200 - Stereo and Multi-Camera Calibration and Depth Computation
201 - Mobile Robotics.
202
203 %description -l pl.UTF-8
204 OpenCV (Open Source Computer Vision) to biblioteka funkcji
205 przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
206
207 Przykładowe zastosowania biblioteki OpenCV to
208 - interakcje człowiek-komputer (HCI)
209 - identyfikacja, segmentacja i rozpoznawanie obiektów
210 - rozpoznawanie twarzy
211 - rozpoznawanie gestów
212 - śledzenie ruchu
213 - rozumienie ruchu
214 - SFM (Structure From Motion)
215 - kalibracja dwu- i wielokamerowa, obliczanie głębi
216 - robotyka ruchu.
217
218 %package core
219 Summary:        OpenCV core libraries
220 Summary(pl.UTF-8):      Podstawowe biblioteki OpenCV
221 Group:          Libraries
222 Conflicts:      opencv < 2.4.6.2-1
223
224 %description core
225 This package contains the OpenCV C/C++ core libraries.
226
227 %description core -l pl.UTF-8
228 Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
229
230 %package viz
231 Summary:        OpenCV viz library (VTK support)
232 Summary(pl.UTF-8):      Biblioteka OpenCV viz (obsługa VTK)
233 Group:          Libraries
234 Requires:       %{name} = %{epoch}:%{version}-%{release}
235
236 %description viz
237 OpenCV viz library (VTK support).
238
239 %description viz -l pl.UTF-8
240 Biblioteka OpenCV viz (obsługa VTK).
241
242 %package devel
243 Summary:        Header files for OpenCV library
244 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OpenCV
245 Group:          Development/Libraries
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247 %if %{with vtk}
248 Requires:       %{name}-viz = %{epoch}:%{version}-%{release}
249 %endif
250 Obsoletes:      opencv-static
251
252 %description devel
253 Header files for OpenCV library.
254
255 %description devel -l pl.UTF-8
256 Pliki nagłówkowe biblioteki OpenCV.
257
258 %package doc
259 Summary:        Manual for OpenCV
260 Summary(fr.UTF-8):      Documentation pour OpenCV
261 Summary(it.UTF-8):      Documentazione di OpenCV
262 Summary(pl.UTF-8):      Podręcznik dla OpenCV
263 Group:          Documentation
264 # noarch subpackages only when building with rpm5
265 BuildArch:      noarch
266
267 %description doc
268 Documentation for OpenCV.
269
270 %description doc -l fr.UTF-8
271 Documentation pour OpenCV.
272
273 %description doc -l it.UTF-8
274 Documentazione di OpenCV.
275
276 %description doc -l pl.UTF-8
277 Dokumentacja do OpenCV.
278
279 %package examples
280 Summary:        OpenCV code examples
281 Group:          Documentation
282 BuildArch:      noarch
283
284 %description examples
285 OpenCV code examples.
286
287 %package -n java-opencv
288 Summary:        OpenCV Java bindings
289 Summary(pl.UTF-8):      Wiązania Javy do OpenCV
290 Group:          Libraries/Java
291 Requires:       %{name} = %{epoch}:%{version}-%{release}
292 Requires:       jre
293
294 %description -n java-opencv
295 OpenCV Java bindings.
296
297 %description -n java-opencv -l pl.UTF-8
298 Wiązania Javy do OpenCV.
299
300 %package -n python-opencv
301 Summary:        OpenCV Python 2 bindings
302 Summary(pl.UTF-8):      Wiązania Pythona 2 do OpenCV
303 Group:          Libraries/Python
304 Requires:       %{name} = %{epoch}:%{version}-%{release}
305 Requires:       python-libs
306
307 %description -n python-opencv
308 OpenCV Python 2 bindings.
309
310 %description -n python-opencv -l pl.UTF-8
311 Wiązania Pythona 2 do OpenCV.
312
313 %package -n python3-opencv
314 Summary:        OpenCV Python 3 bindings
315 Summary(pl.UTF-8):      Wiązania Pythona 3 do OpenCV
316 Group:          Libraries/Python
317 Requires:       %{name} = %{epoch}:%{version}-%{release}
318 Requires:       python3-libs
319
320 %description -n python3-opencv
321 OpenCV Python 3 bindings.
322
323 %description -n python3-opencv -l pl.UTF-8
324 Wiązania Pythona 3 do OpenCV.
325
326 %prep
327 %setup -q -a1
328
329 %undos CMakeLists.txt
330
331 %patch0 -p1
332 %patch1 -p1
333 %patch2 -p1
334 %patch3 -p1
335
336 cache_file() {
337         f="$1"
338         d="$2"
339         md5="$(md5sum "$f" | awk '{print $1}')"
340         file="$(basename "$f")"
341         mkdir -p ".cache/$d"
342         install "$f" ".cache/$d/$md5-$file"
343 }
344 for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
345         cache_file $f xfeatures2d/boostdesc
346 done
347 for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
348         cache_file $f xfeatures2d/vgg
349 done
350 cache_file %{SOURCE30} data
351 cache_file %{SOURCE40} ade
352
353 %build
354 mkdir -p build
355 cd build
356
357 # handle cmake & ccache
358 # http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
359 if [[ "%{__cc}" = *ccache* ]]; then
360         cc="%{__cc}"
361         cxx="%{__cxx}"
362         ccache="
363         -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
364         -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
365         "
366 fi
367
368 %cmake .. \
369         $ccache \
370         -DENABLE_PRECOMPILED_HEADERS=OFF \
371         -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
372         -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
373         -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
374         -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
375         -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
376         -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
377         -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
378         -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
379         -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
380         -DBUILD_NEW_PYTHON_SUPPORT=ON \
381         -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
382 %if %{with examples}
383         -DINSTALL_C_EXAMPLES=ON \
384         -DINSTALL_PYTHON_EXAMPLES=ON \
385 %endif
386         %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
387         %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
388         %{?with_opencl:-DWITH_OPENCL=ON} \
389         %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
390         %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
391         %{?with_opengl:-DWITH_OPENGL=ON} \
392         %{?with_openmp:-DWITH_OPENMP=ON} \
393         %{?with_openni:-DWITH_OPENNI=ON} \
394         %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
395         %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
396         %{?with_tbb:-DWITH_TBB=ON} \
397         %{?with_unicap:-DWITH_UNICAP=ON} \
398         %{!?with_v4l:-DWITH_V4L=OFF} \
399         %{?with_vtk:-DWITH_VTK=ON} \
400         %{?with_ximea:-DWITH_XIMEA=ON} \
401         %{?with_xine:-DWITH_XINE=ON} \
402         -DWITH_IPP=OFF
403
404 %{__make}
405
406 %install
407 rm -rf $RPM_BUILD_ROOT
408 %{__make} -C build install \
409         DESTDIR=$RPM_BUILD_ROOT
410
411 %if %{with examples}
412 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
413 mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
414 %endif
415
416 # disable completeness check incompatible with split packaging
417 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
418
419 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
420 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
421 %py_postclean
422
423 %if %{with java}
424 # move to proper directories, create symlink
425 install -d $RPM_BUILD_ROOT%{_javadir}
426 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
427 sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
428         $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
429 %{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
430 rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
431 ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
432 %endif
433
434 %clean
435 rm -rf $RPM_BUILD_ROOT
436
437 %post   -p /sbin/ldconfig
438 %postun -p /sbin/ldconfig
439
440 %post   core -p /sbin/ldconfig
441 %postun core -p /sbin/ldconfig
442
443 %post   viz -p /sbin/ldconfig
444 %postun viz -p /sbin/ldconfig
445
446 %post   -n java-opencv -p /sbin/ldconfig
447 %postun -n java-opencv -p /sbin/ldconfig
448
449 %files
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_bindir}/opencv_annotation
452 #%attr(755,root,root) %{_bindir}/opencv_createsamples
453 %attr(755,root,root) %{_bindir}/opencv_interactive-calibration
454 #%attr(755,root,root) %{_bindir}/opencv_traincascade
455 %attr(755,root,root) %{_bindir}/opencv_version
456 %attr(755,root,root) %{_bindir}/opencv_visualisation
457 %attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
458 %attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
460 %attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
462 %attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
463 %attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
464 %attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
466 %attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
467 %attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
468 %attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
469 %attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
470 %attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
472 # contrib modules
473 %attr(755,root,root) %{_bindir}/opencv_waldboost_detector
474 %attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
475 %attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
477 %attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
478 %attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
479 %attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
480 %attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
481 %attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
482 %attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
483 %attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
484 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
485 %attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
487 %attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
488 %attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
489 %attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
490 %attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
491 %attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
493 %attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
494 %attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
495 %attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
497 %attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
498 %attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
499 %attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
500 %attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
501 %attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
502 %attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
503 %attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
505 %attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
506 %attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
507 %attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
508 %attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
509 %attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
510 %attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
511 %attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
512 %attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
513 %attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
514 %attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
515 %attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
516 %attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
517 %attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
518 %attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
519 %attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
521 %attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
522 %attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
523 %attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
524 %attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
525 %attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
527 %attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
529 %attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
531 %attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
533 %attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
535 %attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
537 %attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
538 %attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
539 %attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
540 %attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
541 %attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
542 %attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
543 %attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
544 %attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
545 %attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
546 %attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
547 %attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
549 %attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
551 %attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
552
553 %dir %{_datadir}/opencv4
554 %{_datadir}/opencv4/haarcascades
555 %{_datadir}/opencv4/lbpcascades
556 %{_datadir}/opencv4/quality
557
558 %files core
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
562 %attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
564 %attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
565 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
566 %attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
567 %attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
568 %attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
570 %attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
572 %attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
574 %attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
576 %attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
578
579 %if %{with vtk}
580 %files viz
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
584 %endif
585
586 %files devel
587 %defattr(644,root,root,755)
588 # core
589 %{_libdir}/libopencv_core.so
590 %{_libdir}/libopencv_flann.so
591 %{_libdir}/libopencv_imgproc.so
592 %{_libdir}/libopencv_ml.so
593 %{_libdir}/libopencv_photo.so
594 %{_libdir}/libopencv_video.so
595 # GUI/extensions (base package)
596 %{_libdir}/libopencv_calib3d.so
597 %{_libdir}/libopencv_features2d.so
598 %{_libdir}/libopencv_highgui.so
599 %{_libdir}/libopencv_objdetect.so
600 %{_libdir}/libopencv_stitching.so
601 %{_libdir}/libopencv_superres.so
602 %{_libdir}/libopencv_videostab.so
603 %{_libdir}/libopencv_imgcodecs.so
604 %{_libdir}/libopencv_shape.so
605 %{_libdir}/libopencv_videoio.so
606 # contrib
607 %{_libdir}/libopencv_aruco.so
608 %{_libdir}/libopencv_bgsegm.so
609 %{_libdir}/libopencv_bioinspired.so
610 %{_libdir}/libopencv_ccalib.so
611 %{_libdir}/libopencv_datasets.so
612 %{_libdir}/libopencv_dnn.so
613 %{_libdir}/libopencv_dnn_objdetect.so
614 %{_libdir}/libopencv_dpm.so
615 %{_libdir}/libopencv_face.so
616 %{_libdir}/libopencv_freetype.so
617 %{_libdir}/libopencv_fuzzy.so
618 %{_libdir}/libopencv_hdf.so
619 %{_libdir}/libopencv_hfs.so
620 %{_libdir}/libopencv_img_hash.so
621 %{_libdir}/libopencv_line_descriptor.so
622 %{_libdir}/libopencv_optflow.so
623 %{_libdir}/libopencv_ovis.so
624 %{_libdir}/libopencv_phase_unwrapping.so
625 %{_libdir}/libopencv_plot.so
626 %{_libdir}/libopencv_reg.so
627 %{_libdir}/libopencv_rgbd.so
628 %{_libdir}/libopencv_saliency.so
629 %{_libdir}/libopencv_sfm.so
630 %{_libdir}/libopencv_stereo.so
631 %{_libdir}/libopencv_structured_light.so
632 %{_libdir}/libopencv_surface_matching.so
633 %{_libdir}/libopencv_text.so
634 %{_libdir}/libopencv_tracking.so
635 %{_libdir}/libopencv_xfeatures2d.so
636 %{_libdir}/libopencv_ximgproc.so
637 %{_libdir}/libopencv_xobjdetect.so
638 %{_libdir}/libopencv_xphoto.so
639 %{_libdir}/libopencv_alphamat.so
640 %{_libdir}/libopencv_dnn_superres.so
641 %{_libdir}/libopencv_gapi.so
642 %{_libdir}/libopencv_intensity_transform.so
643 %{_libdir}/libopencv_mcc.so
644 %{_libdir}/libopencv_quality.so
645 %{_libdir}/libopencv_rapid.so
646 # viz
647 %if %{with vtk}
648 %{_libdir}/libopencv_viz.so
649 %endif
650 %{_includedir}/opencv4
651 %dir %{_libdir}/cmake/opencv4
652 %{_libdir}/cmake/opencv4/OpenCV*.cmake
653 %{_pkgconfigdir}/opencv4.pc
654
655 %files doc
656 %defattr(644,root,root,755)
657 # TODO: probably could rebuild them and package via make install
658 %doc doc/*
659
660 %if %{with examples}
661 %files examples
662 %defattr(644,root,root,755)
663 %{_examplesdir}/%{name}-%{version}
664 %endif
665
666 %if %{with java}
667 %files -n java-opencv
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
670 %{_javadir}/opencv-%{jver}.jar
671 %{_javadir}/opencv.jar
672 %endif
673
674 %files -n python-opencv
675 %defattr(644,root,root,755)
676 %dir %{py_sitedir}/cv2
677 %dir %{py_sitedir}/cv2/python-*
678 %attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
679 %{py_sitedir}/cv2/*.py[co]
680
681 %files -n python3-opencv
682 %defattr(644,root,root,755)
683 %dir %{py3_sitedir}/cv2
684 %dir %{py3_sitedir}/cv2/python-*
685 %attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
686 %{py3_sitedir}/cv2/*.py
This page took 0.09803 seconds and 3 git commands to generate.