]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
pass our CC, cleanup, fix bad copy-paste
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Name:           libdom
7 Version:        0.0.1
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  dea386cfe4fc65b79a1815b0515fc688
13 URL:            http://www.netsurf-browser.org/projects/libdom/
14 BuildRequires:  libhubbub-devel >= 0.2.0
15 BuildRequires:  libparserutils-devel >= 0.1.2
16 BuildRequires:  libwapcaplet-devel >= 0.2.0
17 BuildRequires:  libxml2-devel
18 BuildRequires:  netsurf-buildsystem
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 LibDOM is an implementation of the W3C DOM, written in C. It is
23 currently in development for use with NetSurf and is intended to be
24 suitable for use in other projects too.
25
26 %package devel
27 Summary:        libdom library headers
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 This is the libraries, include files and other resources you can use
34 to incorporate libdom into applications.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
38 programach.
39
40 %package static
41 Summary:        libdom static libraries
42 Summary(pl.UTF-8):      Statyczne biblioteki libdom
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 This is package with static libdom libraries.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka libdom.
51
52 %prep
53 %setup -q
54
55 %build
56 export CC="%{__cc}"
57 export CFLAGS="%{rpmcflags}"
58 export LDFLAGS="%{rpmldflags}"
59
60 %{__make} Q= \
61         PREFIX=%{_prefix} \
62         COMPONENT_TYPE=lib-shared
63
64 %if %{with static_libs}
65 %{__make} Q= \
66         PREFIX=%{_prefix} \
67         COMPONENT_TYPE=lib-static
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} install Q= \
73         PREFIX=%{_prefix} \
74         COMPONENT_TYPE=lib-shared \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %if %{with static_libs}
78 %{__make} install Q= \
79         PREFIX=%{_prefix} \
80         COMPONENT_TYPE=lib-static \
81         DESTDIR=$RPM_BUILD_ROOT
82 %endif
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/lib*.so
97 %{_includedir}/dom
98 %{_pkgconfigdir}/*pc
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/lib*.a
104 %endif
This page took 0.062858 seconds and 4 git commands to generate.