]> git.pld-linux.org Git - packages/libdom.git/blame - libdom.spec
pass our CC, cleanup, fix bad copy-paste
[packages/libdom.git] / libdom.spec
CommitLineData
d9686636 1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
a9f7cd23 4
d9686636 5Summary: Implementation of W3C DOM
6Name: libdom
7Version: 0.0.1
8Release: 1
9License: MIT
10Group: Libraries
11Source0: http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12# Source0-md5: dea386cfe4fc65b79a1815b0515fc688
13URL: http://www.netsurf-browser.org/projects/libdom/
14BuildRequires: libhubbub-devel >= 0.2.0
15BuildRequires: libparserutils-devel >= 0.1.2
16BuildRequires: libwapcaplet-devel >= 0.2.0
17BuildRequires: libxml2-devel
18BuildRequires: netsurf-buildsystem
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22LibDOM is an implementation of the W3C DOM, written in C. It is
23currently in development for use with NetSurf and is intended to be
24suitable for use in other projects too.
25
26%package devel
27Summary: libdom library headers
28Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdom
29Group: Development/Libraries
30Requires: %{name} = %{version}-%{release}
31
32%description devel
33This is the libraries, include files and other resources you can use
34to incorporate libdom into applications.
35
36%description devel -l pl.UTF-8
37Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
38programach.
39
40%package static
41Summary: libdom static libraries
42Summary(pl.UTF-8): Statyczne biblioteki libdom
43Group: Development/Libraries
44Requires: %{name}-devel = %{version}-%{release}
45
46%description static
47This is package with static libdom libraries.
48
49%description static -l pl.UTF-8
50Statyczna biblioteka libdom.
51
52%prep
53%setup -q
54
55%build
a9f7cd23
ER
56export CC="%{__cc}"
57export CFLAGS="%{rpmcflags}"
58export LDFLAGS="%{rpmldflags}"
59
60%{__make} Q= \
61 PREFIX=%{_prefix} \
62 COMPONENT_TYPE=lib-shared
d9686636 63
d9686636 64%if %{with static_libs}
a9f7cd23
ER
65%{__make} Q= \
66 PREFIX=%{_prefix} \
67 COMPONENT_TYPE=lib-static
d9686636 68%endif
69
70%install
71rm -rf $RPM_BUILD_ROOT
a9f7cd23 72%{__make} install Q= \
d9686636 73 PREFIX=%{_prefix} \
74 COMPONENT_TYPE=lib-shared \
a9f7cd23 75 DESTDIR=$RPM_BUILD_ROOT
d9686636 76
77%if %{with static_libs}
a9f7cd23 78%{__make} install Q= \
d9686636 79 PREFIX=%{_prefix} \
80 COMPONENT_TYPE=lib-static \
a9f7cd23 81 DESTDIR=$RPM_BUILD_ROOT
d9686636 82%endif
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(644,root,root,755)
92%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
93
94%files devel
95%defattr(644,root,root,755)
96%attr(755,root,root) %{_libdir}/lib*.so
97%{_includedir}/dom
98%{_pkgconfigdir}/*pc
99
100%if %{with static_libs}
101%files static
102%defattr(644,root,root,755)
103%{_libdir}/lib*.a
104%endif
This page took 0.086988 seconds and 4 git commands to generate.