]> git.pld-linux.org Git - packages/libdom.git/blob - libdom.spec
- updated -devel dependencies
[packages/libdom.git] / libdom.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of W3C DOM
6 Summary(pl.UTF-8):      Implementacja W3C DOM
7 Name:           libdom
8 Version:        0.4.2
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  715c8018dbf0ed8b61a1afcc8cb13ed9
14 URL:            http://www.netsurf-browser.org/projects/libdom/
15 BuildRequires:  expat-devel >= 1.95
16 BuildRequires:  libhubbub-devel >= 0.3.8
17 BuildRequires:  libparserutils-devel >= 0.2.5
18 BuildRequires:  libwapcaplet-devel >= 0.4.3
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  netsurf-buildsystem >= 1.10
21 BuildRequires:  pkgconfig
22 Requires:       libhubbub >= 0.3.8
23 Requires:       libparserutils >= 0.2.5
24 Requires:       libwapcaplet >= 0.4.3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 LibDOM is an implementation of the W3C DOM, written in C. It is
29 currently in development for use with NetSurf and is intended to be
30 suitable for use in other projects too.
31
32 %description -l pl.UTF-8
33 LibDOM to implementacja W3C DOM, napisana w C. Jest rozwijana do
34 wykorzystania w ramach projektu NetSurf, ale także z myślą o
35 możliwości użycia w innych projektach.
36
37 %package devel
38 Summary:        libdom library headers
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdom
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       expat-devel >= 1.95
43 Requires:       libhubbub-devel >= 0.3.8
44 Requires:       libwapcaplet-devel >= 0.4.3
45
46 %description devel
47 This package contains the include files and other resources you can
48 use to incorporate libdom into applications.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe pozwalające na używanie biblioteki libdom w swoich
52 programach.
53
54 %package static
55 Summary:        libdom static library
56 Summary(pl.UTF-8):      Statyczna biblioteka libdom
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 This is package with static libdom library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka libdom.
65
66 %prep
67 %setup -q
68
69 %build
70 export AR="%{__ar}"
71 export CC="%{__cc}"
72 export CFLAGS="%{rpmcflags}"
73 export LDFLAGS="%{rpmldflags}"
74
75 %{__make} \
76         Q= \
77         PREFIX=%{_prefix} \
78         LIBDIR=%{_lib} \
79         COMPONENT_TYPE=lib-shared
80
81 %if %{with static_libs}
82 %{__make} \
83         Q= \
84         PREFIX=%{_prefix} \
85         LIBDIR=%{_lib} \
86         COMPONENT_TYPE=lib-static
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 export AR="%{__ar}"
93 export CC="%{__cc}"
94 export CFLAGS="%{rpmcflags}"
95 export LDFLAGS="%{rpmldflags}"
96
97 %{__make} install \
98         Q= \
99         PREFIX=%{_prefix} \
100         LIBDIR=%{_lib} \
101         COMPONENT_TYPE=lib-shared \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %if %{with static_libs}
105 %{__make} install \
106         Q= \
107         PREFIX=%{_prefix} \
108         LIBDIR=%{_lib} \
109         COMPONENT_TYPE=lib-static \
110         DESTDIR=$RPM_BUILD_ROOT
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc COPYING README
122 %attr(755,root,root) %{_libdir}/libdom.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libdom.so.0
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libdom.so
128 %{_includedir}/dom
129 %{_pkgconfigdir}/libdom.pc
130
131 %if %{with static_libs}
132 %files static
133 %defattr(644,root,root,755)
134 %{_libdir}/libdom.a
135 %endif
This page took 0.092315 seconds and 4 git commands to generate.