]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- added pl.po
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         14
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        2
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  eb83767c877990c8a7540693d196c822
14 Source1:        %{name}.pl.po
15 Patch0:         %{name}-without_ps_pdf.patch
16 Patch1:         %{name}-eps.patch
17 URL:            http://gstreamer.net/
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  bison >= 1.35
21 BuildRequires:  check >= 0.9.3-2
22 BuildRequires:  docbook-utils >= 0.6.10
23 BuildRequires:  flex
24 BuildRequires:  gettext-devel >= 0.11.5
25 BuildRequires:  glib2-devel >= 1:2.12.0
26 BuildRequires:  gtk-doc >= 1.6
27 BuildRequires:  libtool >= 1.4
28 BuildRequires:  libxml2-devel >= 1:2.6.26
29 BuildRequires:  nasm
30 BuildRequires:  perl-base
31 BuildRequires:  pkgconfig >= 1:0.9.0
32 BuildRequires:  popt-devel >= 1.6.3
33 # not sure it is a right place for this BR
34 BuildRequires:  python-PyXML
35 BuildRequires:  transfig
36 BuildRequires:  xmlto
37 Requires:       glib2 >= 1:2.12.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
41 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
42
43 %description
44 GStreamer is a streaming-media framework, based on graphs of filters
45 which operate on media data. Applications using this library can do
46 anything from real-time sound processing to playing videos, and just
47 about anything else media-related. Its plugin-based architecture means
48 that new data types or processing capabilities can be added simply by
49 installing new plugins.
50
51 %description -l pl.UTF-8
52 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
53 grafie filtrów operujących na danych medialnych. Aplikacje używające
54 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
55 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
56 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
57 nowych typów danych lub możliwości obróbki.
58
59 %package devel
60 Summary:        Include files for GStreamer streaming-media framework
61 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 1:2.12.0
65 Requires:       libxml2-devel >= 1:2.6.26
66 Requires:       popt-devel >= 1.6.3
67
68 %description devel
69 This package contains the includes files necessary to develop
70 applications and plugins for GStreamer.
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
74 i wtyczek do GStreamera.
75
76 %package static
77 Summary:        GStreamer static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static versions of GStreamer libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne wersje bibliotek GStreamer.
87
88 %package apidocs
89 Summary:        GStreamer API documentation
90 Summary(pl.UTF-8):      Dokumentacja API Gstreamera
91 Group:          Documentation
92 Requires:       gtk-doc-common
93
94 %description apidocs
95 GStreamer API documentation.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API Gstreamera.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104
105 cp %{SOURCE1} po/pl.po
106 echo 'pl' >> po/LINGUAS
107
108 %build
109 # po/Makefile.in.in is modified
110 #{__gettextize}
111 %{__libtoolize}
112 %{__aclocal} -I common/m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-examples \
118         --disable-pspdf \
119         --disable-tests \
120         --enable-docbook \
121         --enable-gtk-doc \
122         --with-html-dir=%{_gtkdocdir}
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
134 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
135         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
136
137 %find_lang %{name} --all-name --with-gnome
138
139 # no static modules and *.la for them - shut up check files
140 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_bindir}/*
152 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
153 %dir %{_gstlibdir}
154 %attr(755,root,root) %{_gstlibdir}/*.so
155 %{_mandir}/man1/*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/lib*.so
160 %{_libdir}/lib*.la
161 %{_docdir}/%{name}-devel-%{version}
162 %{_gstincludedir}
163 %{_pkgconfigdir}/*
164 %{_aclocaldir}/*
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/lib*.a
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %{_gtkdocdir}/*
This page took 0.081097 seconds and 4 git commands to generate.