]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- updated to 1.24.2
[packages/gstreamer.git] / gstreamer.spec
1 # TODO: suid/capabilities for ptp-helper? (-Dptp-helper-permissions=capabilities or -Dptp-helper-setuid-user=/-Dptp-helper-setuid-group=)
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # hotdoc based API documentation
5 %bcond_without  ptp_helper      # ptp-helper (requires rust)
6 %bcond_without  static_libs     # static libraries
7
8 %define         gstmver         1.0
9
10 Summary:        GStreamer Streaming-media framework runtime
11 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
12 Name:           gstreamer
13 Version:        1.24.2
14 Release:        1
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        https://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.xz
18 # Source0-md5:  fd0faca3054dd579768f81288be822d4
19 Patch0:         %{name}-inspect-rpm-format.patch
20 URL:            https://gstreamer.freedesktop.org/
21 BuildRequires:  automake
22 BuildRequires:  bash-completion-devel >= 1:2.0
23 BuildRequires:  bison >= 1.875
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  elfutils-devel
26 BuildRequires:  flex >= 2.5.31
27 BuildRequires:  gettext-tools >= 0.17
28 BuildRequires:  glib2-devel >= 1:2.64.0
29 %if %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
30 BuildRequires:  glibc-localedb-all
31 %endif
32 BuildRequires:  glibc-misc
33 BuildRequires:  gobject-introspection-devel >= 1.31.1
34 %{?with_apidocs:BuildRequires:  hotdoc >= 0.11.0}
35 BuildRequires:  libcap-devel
36 %ifarch %{ix86} %{x8664} x32 %{arm} hppa ia64 mips ppc ppc64 sh
37 BuildRequires:  libunwind-devel
38 %endif
39 BuildRequires:  meson >= 1.1
40 BuildRequires:  ninja >= 1.5
41 BuildRequires:  perl-base
42 BuildRequires:  pkgconfig >= 1:0.9.0
43 BuildRequires:  python3 >= 1:3.2
44 BuildRequires:  python3-modules >= 1:3.2
45 %{?with_ptp_helper:BuildRequires:       rust >= 1.48}
46 BuildRequires:  rpm-build >= 4.6
47 BuildRequires:  rpmbuild(macros) >= 1.736
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 Requires:       glib2 >= 1:2.64.0
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
55 %define         gstlibexecdir   %{_libexecdir}/gstreamer-%{gstmver}
56 %define         gstincludedir   %{_includedir}/gstreamer-%{gstmver}
57
58 %description
59 GStreamer is a streaming-media framework, based on graphs of filters
60 which operate on media data. Applications using this library can do
61 anything from real-time sound processing to playing videos, and just
62 about anything else media-related. Its plugin-based architecture means
63 that new data types or processing capabilities can be added simply by
64 installing new plugins.
65
66 %description -l pl.UTF-8
67 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
68 grafie filtrów operujących na danych medialnych. Aplikacje używające
69 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
70 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
71 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
72 nowych typów danych lub możliwości obróbki.
73
74 %package devel
75 Summary:        Include files for GStreamer streaming-media framework
76 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       glib2-devel >= 1:2.64.0
80 Obsoletes:      gstreamer-plugins-bad-devel < 0.10.10
81 Conflicts:      gstreamer-plugins-bad-devel < 1.14
82
83 %description devel
84 This package contains the includes files necessary to develop
85 applications and plugins for GStreamer.
86
87 %description devel -l pl.UTF-8
88 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
89 i wtyczek do GStreamera.
90
91 %package static
92 Summary:        GStreamer static libraries
93 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static versions of GStreamer libraries.
99
100 %description static -l pl.UTF-8
101 Statyczne wersje bibliotek GStreamer.
102
103 %package apidocs
104 Summary:        GStreamer API documentation
105 Summary(pl.UTF-8):      Dokumentacja API GStreamera
106 Group:          Documentation
107 BuildArch:      noarch
108
109 %description apidocs
110 GStreamer API documentation.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API GStreamera.
114
115 %package gdb
116 Summary:        GStreamer pretty printers for GDB
117 Summary(pl.UTF-8):      Funkcje wypisujące dane GStreamer dla GDB
118 Group:          Development/Debuggers
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       gdb
121
122 %description gdb
123 This package contains Python scripts for GDB pretty printing of the
124 GStreamer types.
125
126 %description gdb -l pl.UTF-8
127 Ten pakiet zawiera skrypty Pythona dla GDB służące do ładnego
128 wypisywania typów GStreamer.
129
130 %package -n bash-completion-gstreamer
131 Summary:        Bash completion for GStreamer utilities
132 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów narzędzi GStreamera
133 Group:          Applications/Shells
134 Requires:       %{name} = %{version}-%{release}
135 Requires:       bash-completion >= 1:2.0
136
137 %description -n bash-completion-gstreamer
138 Bash completion for GStreamer utilities: gst-inspect and gst-launch.
139
140 %description -n bash-completion-gstreamer -l pl.UTF-8
141 Bashowe uzupełnianie parametrów narzędzi GStreamera: gst-inspect oraz
142 gst-launch.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147
148 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' docs/gst-plugins-doc-cache-generator.py
149
150 %build
151 %meson build \
152         %{!?with_static_libs:--default-library=shared} \
153         %{?with_apidocs:-Ddoc=enabled} \
154         -Dexamples=disabled \
155         -Dtests=disabled
156
157 %ninja_build -C build
158
159 %if %{with apidocs}
160 cd build/docs
161 for component in base check controller gstreamer net ; do
162         LC_ALL=C.UTF-8 hotdoc run --conf-file ${component}-doc.json
163 done
164 for component in coreelements coretracers ; do
165         LC_ALL=C.UTF-8 hotdoc run --conf-file plugin-${component}.json
166 done
167 %endif
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171
172 %ninja_install -C build
173
174 %find_lang %{name} --all-name --with-gnome
175
176 %py3_comp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb
177 %py3_ocomp $RPM_BUILD_ROOT%{_datadir}/gstreamer-1.0/gdb
178
179 # no static modules - shut up check files
180 %if %{with static_libs}
181 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/lib*.a
182 %{__rm} $RPM_BUILD_ROOT%{gstlibdir}/pkgconfig/*.pc
183 %endif
184
185 %if %{with apidocs}
186 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
187 cp -pr build/docs/{base,check,controller,gstreamer,net}-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
188 cp -pr build/docs/plugin-{coreelements,coretracers} $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
189 %endif
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %post   -p /sbin/ldconfig
195 %postun -p /sbin/ldconfig
196
197 %files -f %{name}.lang
198 %defattr(644,root,root,755)
199 %doc AUTHORS ChangeLog MAINTAINERS NEWS README.md RELEASE
200 %attr(755,root,root) %{_bindir}/gst-inspect-1.0
201 %attr(755,root,root) %{_bindir}/gst-launch-1.0
202 %attr(755,root,root) %{_bindir}/gst-stats-1.0
203 %attr(755,root,root) %{_bindir}/gst-typefind-1.0
204 %attr(755,root,root) %{_libdir}/libgstbase-%{gstmver}.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libgstbase-%{gstmver}.so.0
206 %attr(755,root,root) %{_libdir}/libgstcheck-%{gstmver}.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/libgstcheck-%{gstmver}.so.0
208 %attr(755,root,root) %{_libdir}/libgstcontroller-%{gstmver}.so.*.*.*
209 %attr(755,root,root) %ghost %{_libdir}/libgstcontroller-%{gstmver}.so.0
210 %attr(755,root,root) %{_libdir}/libgstnet-%{gstmver}.so.*.*.*
211 %attr(755,root,root) %ghost %{_libdir}/libgstnet-%{gstmver}.so.0
212 %attr(755,root,root) %{_libdir}/libgstreamer-%{gstmver}.so.*.*.*
213 %attr(755,root,root) %ghost %{_libdir}/libgstreamer-%{gstmver}.so.0
214 %if "%{_libexecdir}" != "%{_libdir}"
215 %dir %{gstlibexecdir}
216 %endif
217 %attr(755,root,root) %{gstlibexecdir}/gst-plugin-scanner
218 %if %{with ptp_helper}
219 # %caps(cap_net_bind_service,cap_net_admin,cap_sys_nice=ep) ?
220 %attr(755,root,root) %{gstlibexecdir}/gst-ptp-helper
221 %endif
222 %dir %{gstlibdir}
223 %attr(755,root,root) %{gstlibdir}/libgstcoreelements.so
224 %attr(755,root,root) %{gstlibdir}/libgstcoretracers.so
225 # common for some plugins
226 %dir %{_datadir}/gstreamer-1.0
227 %{_mandir}/man1/gst-inspect-1.0.1*
228 %{_mandir}/man1/gst-launch-1.0.1*
229 %{_mandir}/man1/gst-stats-1.0.1*
230 %{_mandir}/man1/gst-typefind-1.0.1*
231 %{_libdir}/girepository-1.0/Gst-%{gstmver}.typelib
232 %{_libdir}/girepository-1.0/GstBase-%{gstmver}.typelib
233 %{_libdir}/girepository-1.0/GstCheck-%{gstmver}.typelib
234 %{_libdir}/girepository-1.0/GstController-%{gstmver}.typelib
235 %{_libdir}/girepository-1.0/GstNet-%{gstmver}.typelib
236
237 %files devel
238 %defattr(644,root,root,755)
239 %if %{with apidocs}
240 %attr(755,root,root) %{gstlibexecdir}/gst-hotdoc-plugins-scanner
241 %attr(755,root,root) %{gstlibexecdir}/gst-plugins-doc-cache-generator
242 %endif
243 %attr(755,root,root) %{_libdir}/libgstbase-%{gstmver}.so
244 %attr(755,root,root) %{_libdir}/libgstcheck-%{gstmver}.so
245 %attr(755,root,root) %{_libdir}/libgstcontroller-%{gstmver}.so
246 %attr(755,root,root) %{_libdir}/libgstnet-%{gstmver}.so
247 %attr(755,root,root) %{_libdir}/libgstreamer-%{gstmver}.so
248 %dir %{gstincludedir}
249 %{gstincludedir}/gst
250 %{_pkgconfigdir}/gstreamer-%{gstmver}.pc
251 %{_pkgconfigdir}/gstreamer-base-%{gstmver}.pc
252 %{_pkgconfigdir}/gstreamer-check-%{gstmver}.pc
253 %{_pkgconfigdir}/gstreamer-controller-%{gstmver}.pc
254 %{_pkgconfigdir}/gstreamer-net-%{gstmver}.pc
255 %{_aclocaldir}/gst-element-check-%{gstmver}.m4
256 %{_datadir}/gir-1.0/Gst-%{gstmver}.gir
257 %{_datadir}/gir-1.0/GstBase-%{gstmver}.gir
258 %{_datadir}/gir-1.0/GstCheck-%{gstmver}.gir
259 %{_datadir}/gir-1.0/GstController-%{gstmver}.gir
260 %{_datadir}/gir-1.0/GstNet-%{gstmver}.gir
261
262 %if %{with static_libs}
263 %files static
264 %defattr(644,root,root,755)
265 %{_libdir}/libgstbase-%{gstmver}.a
266 %{_libdir}/libgstcheck-%{gstmver}.a
267 %{_libdir}/libgstcontroller-%{gstmver}.a
268 %{_libdir}/libgstnet-%{gstmver}.a
269 %{_libdir}/libgstreamer-%{gstmver}.a
270 %endif
271
272 %if %{with apidocs}
273 %files apidocs
274 %defattr(644,root,root,755)
275 %dir %{_docdir}/gstreamer-%{gstmver}
276 %{_docdir}/gstreamer-%{gstmver}/base-doc
277 %{_docdir}/gstreamer-%{gstmver}/check-doc
278 %{_docdir}/gstreamer-%{gstmver}/controller-doc
279 %{_docdir}/gstreamer-%{gstmver}/gstreamer-doc
280 %{_docdir}/gstreamer-%{gstmver}/net-doc
281 %{_docdir}/gstreamer-%{gstmver}/plugin-coreelements
282 %{_docdir}/gstreamer-%{gstmver}/plugin-coretracers
283 %endif
284
285 %files gdb
286 %defattr(644,root,root,755)
287 %{_datadir}/gdb/auto-load%{_libdir}/libgstreamer-%{gstmver}.so.*.*.*-gdb.py
288 %{_datadir}/gstreamer-1.0/gdb
289
290 %files -n bash-completion-gstreamer
291 %defattr(644,root,root,755)
292 %{bash_compdir}/gst-inspect-1.0
293 %{bash_compdir}/gst-launch-1.0
294 %attr(755,root,root) %{gstlibexecdir}/gst-completion-helper
295 %attr(755,root,root) %{_datadir}/bash-completion/helpers/gst
This page took 0.438865 seconds and 4 git commands to generate.