]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- fixed dir pre-installation
[packages/gstreamer.git] / gstreamer.spec
1
2 %define         _vmajor         0.10
3 %define         _vminor         3
4
5 Summary:        GStreamer Streaming-media framework runtime
6 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
7 Name:           gstreamer
8 Version:        %{_vmajor}.%{_vminor}
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
13 # Source0-md5:  bee72ad6bccc334e5c8af72c1ff4ffce
14 Patch0:         %{name}-without_ps_pdf.patch
15 Patch1:         %{name}-eps.patch
16 URL:            http://gstreamer.net/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6
19 BuildRequires:  bison >= 1.35
20 BuildRequires:  docbook-utils >= 0.6.10
21 BuildRequires:  flex
22 BuildRequires:  glib2-devel >= 1:2.8.0
23 BuildRequires:  gtk-doc >= 1.3
24 BuildRequires:  libtool >= 1.4
25 BuildRequires:  libxml2-devel >= 2.4.17
26 BuildRequires:  nasm
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  popt-devel >= 1.6.3
30 # not sure it is a right place for this BR
31 BuildRequires:  python-PyXML
32 BuildRequires:  transfig
33 BuildRequires:  xmlto
34 Requires:       glib2 >= 1:2.8.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _gstlibdir      %{_libdir}/gstreamer-%{_vmajor}
38 %define         _gstincludedir  %{_includedir}/gstreamer-%{_vmajor}
39
40 %description
41 GStreamer is a streaming-media framework, based on graphs of filters
42 which operate on media data. Applications using this library can do
43 anything from real-time sound processing to playing videos, and just
44 about anything else media-related. Its plugin-based architecture means
45 that new data types or processing capabilities can be added simply by
46 installing new plugins.
47
48 %description -l pl
49 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
50 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
51 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
52 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zanego z
53 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
54 nowych typów danych lub mo¿liwo¶ci obróbki.
55
56 %package devel
57 Summary:        Include files for GStreamer streaming-media framework
58 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       glib2-devel >= 1:2.8.0
62 Requires:       libxml2-devel >= 2.4.17
63 Requires:       popt-devel >= 1.6.3
64
65 %description devel
66 This package contains the includes files necessary to develop
67 applications and plugins for GStreamer.
68
69 %description devel -l pl
70 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
71 i wtyczek do GStreamera.
72
73 %package static
74 Summary:        GStreamer static libraries
75 Summary(pl):    Biblioteki statyczne GStreamer
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static versions of GStreamer libraries.
81
82 %description static -l pl
83 Statyczne wersje bibliotek GStreamer.
84
85 %package apidocs
86 Summary:        GStreamer API documentation
87 Summary(pl):    Dokumentacja API Gstreamera
88 Group:          Documentation
89 Requires:       gtk-doc-common
90
91 %description apidocs
92 GStreamer API documentation.
93
94 %description apidocs -l pl
95 Dokumentacja API Gstreamera.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal} -I common/m4
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108
109 %configure \
110         --disable-examples \
111         --disable-tests \
112         --enable-docbook \
113         --enable-gtk-doc \
114         --with-html-dir=%{_gtkdocdir}
115         
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{_vmajor},%{version}}
126 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
127         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
128
129 %find_lang %{name} --all-name --with-gnome
130
131 # no static modules and *.la for them - shut up check files
132 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README TODO
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
145 %dir %{_gstlibdir}
146 %attr(755,root,root) %{_gstlibdir}/*.so
147 %{_mandir}/man1/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/lib*.so
152 %{_libdir}/lib*.la
153 %{_docdir}/%{name}-devel-%{version}
154 %{_gstincludedir}
155 %{_pkgconfigdir}/*
156 %{_aclocaldir}/*
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/lib*.a
161
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/*
This page took 0.065053 seconds and 4 git commands to generate.