]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- up to version 0.8.3
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.3
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
9 # Source0-md5:  090bdbd35c9b831746694d020356d5b6
10 Patch0:         %{name}-without_ps_pdf.patch
11 URL:            http://gstreamer.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  ghostscript
17 BuildRequires:  glib2-devel >= 1:2.4.2
18 BuildRequires:  gtk-doc >= 1.0
19 BuildRequires:  libtool
20 BuildRequires:  libxml2-devel >= 2.4.17
21 BuildRequires:  nasm
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel >= 1.6.3
25 BuildRequires:  transfig
26 BuildRequires:  xmlto
27 Requires(post): /sbin/ldconfig
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
31 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
32 %define         _gstcachedir    %{_var}/cache/gstreamer
33
34 %description
35 GStreamer is a streaming-media framework, based on graphs of filters
36 which operate on media data. Applications using this library can do
37 anything from real-time sound processing to playing videos, and just
38 about anything else media-related. Its plugin-based architecture means
39 that new data types or processing capabilities can be added simply by
40 installing new plugins.
41
42 %description -l pl
43 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
44 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
45 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
46 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
47 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
48 nowych typów danych lub mo¿liwo¶ci obróbki.
49
50 %package devel
51 Summary:        Include files for GStreamer streaming-media framework
52 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       glib2-devel >= 1:2.4.2
56 Requires:       libxml2-devel >= 2.4.17
57 Requires:       popt-devel >= 1.6.3
58
59 %description devel
60 This package contains the includes files necessary to develop
61 applications and plugins for GStreamer.
62
63 %description devel -l pl
64 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
65 i wtyczek do GStreamera.
66
67 %package static
68 Summary:        GStreamer static libraries
69 Summary(pl):    Biblioteki statyczne GStreamer
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static versions of GStreamer libraries.
75
76 %description static -l pl
77 Statyczne wersje bibliotek GStreamer.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 intltoolize --copy --force
85 %{__gettextize}
86 %{__libtoolize}
87 %{__aclocal} -I common/m4
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91
92 %configure \
93         --program-suffix="" \
94 %ifarch i586 i686 athlon
95         --enable-fast-stack-trash \
96 %else
97         --disable-fast-stack-trash \
98 %endif
99         --enable-glib2 \
100         --enable-libmmx \
101         --enable-atomic \
102         --disable-examples \
103         --disable-tests \
104         --disable-debug \
105         --disable-debug-color \
106         --enable-docs-build \
107         --with-html-dir=%{_gtkdocdir} \
108         --with-cachedir=%{_gstcachedir}
109         
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
120
121 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
122         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
123
124 %find_lang %{name} --all-name --with-gnome
125
126 # no static modules and *.la for them - shut up check files
127 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 /sbin/ldconfig
134 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml > /dev/null 2> /dev/null
135
136 %postun -p /sbin/ldconfig
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README TODO
141 %attr(755,root,root) %{_bindir}/*
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
143 %dir %{_gstlibdir}
144 %attr(755,root,root) %{_gstlibdir}/*.so
145 %dir %{_gstcachedir}
146 %ghost %{_gstcachedir}/registry.xml
147 %{_mandir}/man1/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc DEVEL
152 %attr(755,root,root) %{_libdir}/lib*.so
153 %{_libdir}/lib*.la
154 %{_gstincludedir}
155 %{_gtkdocdir}/*
156 %{_pkgconfigdir}/*
157 %{_aclocaldir}/*
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.a
This page took 0.050214 seconds and 4 git commands to generate.