]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- tst-clock1 needs accessible /proc/cpuinfo
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
5f56f24b 11%bcond_with nptl # use nptl instead of linuxthreads (implies tls)
87146167 12%bcond_with tls # use tls
c9d8e545 13%bcond_with tests # perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec 18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
76f01b70 19#
61918272 20
3900e225 21%{!?min_kernel:%global min_kernel 2.4.6}
61918272 22
23%if %{with nptl}
dc3eddd2 24# it seems that nptl uses cmpxchgl (available since i486) on x86
dd75ad7c 25%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
76131947
AM
26%if "%{min_kernel}" < "2.6.0"
27%global min_kernel 2.6.0
28%endif
5f56f24b
JB
29# NPTL requires TLS
30%define with_tls 1
61918272 31%else
5f56f24b 32%undefine with_nptl
3900e225 33%endif
61918272 34%endif
61918272 35
f3f771b7 36%if %{with tls}
dd75ad7c 37%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 38%undefine with_tls
f3f771b7
AM
39%endif
40%endif
41
e24149ab
PS
42%ifarch sparc64
43%undefine with_memusage
44%endif
45
121eb47e 46%define llh_version 7:2.6.6.0
baee199c 47%define _snap 20040722
e8c60795 48
236a5027 49Summary: GNU libc
50Summary(de): GNU libc
4a04bb32 51Summary(es): GNU libc
236a5027 52Summary(fr): GNU libc
c5387ad5 53