]> git.pld-linux.org Git - packages/gdal.git/commitdiff
Merge branch 'master' of git://git.pld-linux.org/packages/gdal
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Jun 2014 20:23:30 +0000 (22:23 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 14 Jun 2014 20:23:30 +0000 (22:23 +0200)
1  2 
gdal.spec

diff --combined gdal.spec
index 905201254a70305f68a75fbbbfe3aff26a1add28,a9ae74d6fe3e52eefbfe706e695d1a208898c054..2f8af60239db8c3d7eff914e28ae35ce52285b6a
+++ b/gdal.spec
@@@ -7,6 -7,8 +7,6 @@@
  # - libkml (1.3.0 needed, not released yet)
  # - wait for newer pcidsk, switch to external again
  # - csharp, java
 -# - DDS (--with-dds, BR [lib]crunch: http://code.google.com/p/crunch/)
 -# - SOSI (--with-sosi, BR: libfyba libfygm libfyut: https://github.com/kartverket/fyba)
  # - additional, proprietary(?) formats support:
  #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
  #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
@@@ -22,9 -24,7 +22,9 @@@
  #
  # Conditional build:
  %bcond_without        armadillo       # Armadillo support for faster TPS transform
 +%bcond_without        crnlib          # DDS support via crunch/crnlib
  %bcond_without        epsilon         # EPSILON wavelet compression support
 +%bcond_without        fyba            # SOSI geodata support using FYBA
  %bcond_with   grass           # GRASS support (note: dependency loop)
  %bcond_without        gta             # GTA format support
  %bcond_without        mysql           # MySQL DB support
@@@ -34,7 -34,6 +34,7 @@@
  %bcond_without        openjpeg        # OpenJPEG 2 (JPEG2000) support
  %bcond_with   podofo          # PDF support via podofo instead of poppler
  %bcond_without        poppler         # PDF support via poppler
 +%bcond_without        rasdaman        # Rasdaman support
  %bcond_without        spatialite      # SpatiaLite support
  %bcond_without        xerces          # Xerces support
  %bcond_without        java            # Java and MDB support
  %if %{with podofo}
  %undefine     with_poppler
  %endif
+ %define               php_name        php55
  Summary:      Geospatial Data Abstraction Library
  Summary(pl.UTF-8):    Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
  Name:         gdal
  Version:      1.11.0
- Release:      1
+ Release:      3
  License:      BSD-like
  Group:                Libraries
  Source0:      http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
@@@ -61,29 -61,22 +62,30 @@@ Patch4:            %{name}-format-security.patc
  Patch5:               %{name}-grass.patch
  Patch6:               %{name}-sse.patch
  Patch7:               %{name}-link.patch
 +Patch8:               %{name}-fyba.patch
 +Patch9:               %{name}-dds.patch
 +Patch10:      %{name}-gif.patch
 +Patch11:      %{name}-armadillo.patch
 +Patch12:      %{name}-oci.patch
 +Patch13:      %{name}-rasdaman.patch
  URL:          http://www.gdal.org/
+ %{?with_php:BuildRequires:    %{php_name}-devel}
  %{?with_opencl:BuildRequires: OpenCL-devel >= 1.0}
  %{?with_armadillo:BuildRequires:      armadillo-devel}
  BuildRequires:        autoconf >= 2.52
  BuildRequires:        automake
  BuildRequires:        cfitsio-devel
 +%{?with_dds:BuildRequires:    crnlib-devel}
  BuildRequires:        curl-devel
  BuildRequires:        doxygen >= 1.4.2
  %{?with_epsilon:BuildRequires:        epsilon-compressor-devel}
  BuildRequires:        expat-devel >= 1.95.0
 +%{?with_fyba:BuildRequires:   fyba-devel}
  BuildRequires:        freexl-devel >= 1.0
  BuildRequires:        gcc >= 6:4.1
  BuildRequires:        geos-devel >= 3.1.0
  BuildRequires:        giflib-devel >= 4.0
 -%{?with_grass:BuildRequires:  grass-devel >= 5.7}
 +%{?with_grass:BuildRequires:  grass-devel >= 6.4}
  BuildRequires:        hdf-devel >= 4.0
  BuildRequires:        hdf5-devel
  BuildRequires:        jasper-devel
@@@ -112,7 -105,6 +114,6 @@@ BuildRequires:     ogdi-devel >= 3.
  %{?with_oci:BuildRequires:    oracle-instantclient-devel >= 10.0.1}
  #BuildRequires:       pcidsk-devel > 0.3
  BuildRequires:        perl-devel
- %{?with_php:BuildRequires:    php-devel}
  %{?with_podofo:BuildRequires: podofo-devel}
  %{?with_poppler:BuildRequires:        poppler-devel >= 0.24}
  # ensure it's compiled with PQescapeStringConn support
@@@ -122,7 -114,6 +123,7 @@@ BuildRequires:     proj-devel >= 
  BuildRequires:        python-devel >= 1:2.5
  BuildRequires:        python-numpy-devel >= 1:1.0.0
  BuildRequires:        python-setuptools
 +%{?with_rasdaman:BuildRequires:       rasdaman-devel}
  BuildRequires:        rpm-pythonprov
  %{?with_ruby:BuildRequires:   rpm-rubyprov}
  BuildRequires:        rpmbuild(macros) >= 1.344
@@@ -170,10 -161,8 +171,10 @@@ Requires:        %{name} = %{version}-%{releas
  %{?with_opencl:Requires:      OpenCL-devel >= 1.0}
  %{?with_armadillo:Requires:   armadillo-devel}
  Requires:     cfitsio-devel
 +%{?with_dds:Requires: crnlib-devel}
  Requires:     curl-devel
  %{?with_epsilon:Requires:     epsilon-compressor-devel}
 +%{?with_fyba:Requires:        fyba-devel}
  Requires:     expat-devel >= 1.95.0
  Requires:     freexl-devel >= 1.0
  Requires:     geos-devel >= 3.1.0
@@@ -203,7 -192,6 +204,7 @@@ Requires:  ogdi-devel >= 3.
  %{?with_poppler:Requires:     poppler-devel >= 0.24}
  Requires:     postgresql-devel
  Requires:     proj-devel >= 4
 +%{?with_rasdaman:Requires:    rasdaman-devel}
  Requires:     sqlite3-devel >= 3.0.0
  %{?with_odbc:Requires:        unixODBC-devel}
  %{?with_xerces:Requires:      xerces-c-devel >= 2.7.0}
@@@ -240,17 -228,17 +241,17 @@@ Perl bindings for GDAL - Geo::GDAL, Geo
  %description -n perl-gdal -l pl.UTF-8
  Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
  
- %package -n php-gdal
+ %package -n %{php_name}-gdal
  Summary:      PHP bindings for GDAL library
  Summary(pl.UTF-8):    Wiązania PHP do biblioteki GDAL
  Group:                Development/Languages/PHP
  Requires:     %{name} = %{version}-%{release}
  %{?requires_php_extension}
  
- %description -n php-gdal
+ %description -n %{php_name}-gdal
  PHP bindings for GDAL library
  
- %description -n php-gdal -l pl.UTF-8
+ %description -n %{php_name}-gdal -l pl.UTF-8
  Wiązania PHP do biblioteki GDAL.
  
  %package -n python-gdal
@@@ -289,12 -277,6 +290,12 @@@ osr
  %patch5 -p1
  %patch6 -p1
  %patch7 -p1
 +%patch8 -p1
 +%patch9 -p1
 +%patch10 -p1
 +%patch11 -p1
 +%patch12 -p1
 +%patch13 -p1
  
  # need to regenerate (old ones don't support perl 5.10 or php 5.5)
  %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
@@@ -327,11 -309,11 +328,11 @@@ sed -i -e 's#^mandir=.*##g' configure.i
  %{__libtoolize}
  %{__aclocal} -I m4
  %{__autoconf}
 -# disable grass/libgrass here, it can be built from separate gdal-grass package
  %configure \
        --datadir=%{_datadir}/gdal \
        --with-dods-root=/usr \
        %{?with_armadillo:--with-armadillo} \
 +      %{?with_crnlib:--with-dds} \
        %{?with_epsilon:--with-epsilon} \
        %{?with_grass:--with-grass} \
        %{!?with_gta:--without-gta} \
        %{?with_podofo:--with-podofo} \
        %{?with_poppler:--with-poppler} \
        --with-python \
 +      %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
        %{?with_ruby:--with-ruby} \
 +      %{?with_fyba:--with-sosi} \
        %{?with_spatialite:--with-spatialite} \
        --with-sqlite3 \
        --with-webp \
        --with-xerces-inc=/usr/include/xercesc \
        --with-xerces-lib="-lxerces-c" \
        --without-libgrass
 -#     --with-rasdaman
  #     --with-pcidsk=/usr (needs > 0.3)
 -# csharp builds, but has no configure option
 +# csharp builds, but has no configure option nor install target
  
  # regenerate where needed
  %{__make} -j1 -C swig/perl generate
  %{__make} -j1 -C swig/ruby generate
  %endif
  
 -%{__make} -j1
 +%{__make} -j1 \
 +      %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
 +      %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
  
  %{__make} -j1 docs
  
@@@ -386,13 -365,14 +387,14 @@@ cp -a ogr/html _html/og
  
  %if %{with php}
  # missing in make install
- install -D swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
- install -D swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
- install -D swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
- install -D swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
+ install -d $RPM_BUILD_ROOT%{php_extensiondir}
+ install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
+ install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
+ install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
+ install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
  install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
  cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
- ; Enable gdal extension module
+ ; Enable gdal extension modules
  extension=gdal.so
  extension=gdalconst.so
  extension=ogr.so
@@@ -552,7 -532,7 +554,7 @@@ rm -rf $RPM_BUILD_ROO
  %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
  
  %if %{with php}
- %files -n php-gdal
+ %files -n %{php_name}-gdal
  %defattr(644,root,root,755)
  %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
  %attr(755,root,root) %{php_extensiondir}/gdal.so
This page took 0.035625 seconds and 4 git commands to generate.