]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
Merge branch 'master' of git://git.pld-linux.org/packages/gdal
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - additional, proprietary(?) formats support:
11 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
12 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
13 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
14 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
15 #   - MrSID (http://www.lizardtech.com/developer/)
16 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
17 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
18 #   - Ingres (--with-ingres=/path)
19 #   - Informix DB (--with-idb)
20 #   - DWGdirect (members only? http://www.opendwg.org/)
21 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
22 #
23 # Conditional build:
24 %bcond_without  armadillo       # Armadillo support for faster TPS transform
25 %bcond_without  crnlib          # DDS support via crunch/crnlib
26 %bcond_without  epsilon         # EPSILON wavelet compression support
27 %bcond_without  fyba            # SOSI geodata support using FYBA
28 %bcond_with     grass           # GRASS support (note: dependency loop)
29 %bcond_without  gta             # GTA format support
30 %bcond_without  mysql           # MySQL DB support
31 %bcond_with     oci             # ORACLE OCI DB and Georaster support
32 %bcond_without  odbc            # ODBC DB support
33 %bcond_without  opencl          # OpenCL (GPU) support
34 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
35 %bcond_with     podofo          # PDF support via podofo instead of poppler
36 %bcond_without  poppler         # PDF support via poppler
37 %bcond_without  rasdaman        # Rasdaman support
38 %bcond_without  spatialite      # SpatiaLite support
39 %bcond_without  xerces          # Xerces support
40 %bcond_without  java            # Java and MDB support
41 %bcond_without  php             # PHP binding
42 %bcond_without  ruby            # Ruby binding
43
44 %if %{with podofo}
45 %undefine       with_poppler
46 %endif
47 %define         php_name        php55
48 Summary:        Geospatial Data Abstraction Library
49 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
50 Name:           gdal
51 Version:        1.11.0
52 Release:        3
53 License:        BSD-like
54 Group:          Libraries
55 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
56 # Source0-md5:  31f2c4a7230b40e5fdc3cf12a100f96b
57 Patch0:         %{name}-perl.patch
58 Patch1:         %{name}-python_install.patch
59 Patch2:         %{name}-php.patch
60 Patch3:         %{name}-fpic.patch
61 Patch4:         %{name}-format-security.patch
62 Patch5:         %{name}-grass.patch
63 Patch6:         %{name}-sse.patch
64 Patch7:         %{name}-link.patch
65 Patch8:         %{name}-fyba.patch
66 Patch9:         %{name}-dds.patch
67 Patch10:        %{name}-gif.patch
68 Patch11:        %{name}-armadillo.patch
69 Patch12:        %{name}-oci.patch
70 Patch13:        %{name}-rasdaman.patch
71 URL:            http://www.gdal.org/
72 %{?with_php:BuildRequires:      %{php_name}-devel}
73 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
74 %{?with_armadillo:BuildRequires:        armadillo-devel}
75 BuildRequires:  autoconf >= 2.52
76 BuildRequires:  automake
77 BuildRequires:  cfitsio-devel
78 %{?with_dds:BuildRequires:      crnlib-devel}
79 BuildRequires:  curl-devel
80 BuildRequires:  doxygen >= 1.4.2
81 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
82 BuildRequires:  expat-devel >= 1.95.0
83 %{?with_fyba:BuildRequires:     fyba-devel}
84 BuildRequires:  freexl-devel >= 1.0
85 BuildRequires:  gcc >= 6:4.1
86 BuildRequires:  geos-devel >= 3.1.0
87 BuildRequires:  giflib-devel >= 4.0
88 %{?with_grass:BuildRequires:    grass-devel >= 6.4}
89 BuildRequires:  hdf-devel >= 4.0
90 BuildRequires:  hdf5-devel
91 BuildRequires:  jasper-devel
92 %{?with_java:BuildRequires:     jdk}
93 %{?with_java:BuildRequires:     jpackage-utils}
94 BuildRequires:  json-c-devel >= 0.11
95 BuildRequires:  libcsf-devel
96 BuildRequires:  libdap-devel >= 3.10
97 BuildRequires:  libgeotiff-devel >= 1.2.1
98 %{?with_gta:BuildRequires:      libgta-devel}
99 BuildRequires:  libjpeg-devel >= 6b
100 #BuildRequires: libkml-devel >= 1.3.0
101 BuildRequires:  libpng-devel >= 2:1.2.8
102 %{?with_spatialite:BuildRequires:       libspatialite-devel}
103 BuildRequires:  libstdc++-devel
104 BuildRequires:  libtiff-devel >= 4.0
105 BuildRequires:  libtool
106 BuildRequires:  libuuid-devel
107 BuildRequires:  libwebp-devel
108 BuildRequires:  libxml2-devel >= 2
109 %{?with_mysql:BuildRequires:    mysql-devel}
110 BuildRequires:  netcdf-devel >= 4.1
111 BuildRequires:  ogdi-devel >= 3.1
112 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
113 # 8.1.7 for DB support, 10.0.1 for georaster
114 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
115 #BuildRequires: pcidsk-devel > 0.3
116 BuildRequires:  perl-devel
117 %{?with_podofo:BuildRequires:   podofo-devel}
118 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
119 # ensure it's compiled with PQescapeStringConn support
120 BuildRequires:  postgresql-backend-devel >= 8.1.4
121 BuildRequires:  postgresql-devel >= 8.1.4
122 BuildRequires:  proj-devel >= 4
123 BuildRequires:  python-devel >= 1:2.5
124 BuildRequires:  python-numpy-devel >= 1:1.0.0
125 BuildRequires:  python-setuptools
126 %{?with_rasdaman:BuildRequires: rasdaman-devel}
127 BuildRequires:  rpm-pythonprov
128 %{?with_ruby:BuildRequires:     rpm-rubyprov}
129 BuildRequires:  rpmbuild(macros) >= 1.344
130 %{?with_ruby:BuildRequires:     ruby-devel}
131 BuildRequires:  sed >= 4.0
132 BuildRequires:  sqlite3-devel >= 3.0.0
133 BuildRequires:  swig-perl
134 BuildRequires:  swig-php >= 2.0.12-2
135 BuildRequires:  swig-python >= 1.3
136 %{?with_ruby:BuildRequires:     swig-ruby}
137 BuildRequires:  texlive-dvips
138 BuildRequires:  texlive-latex
139 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
140 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
141 BuildRequires:  xz-devel
142 BuildRequires:  zlib-devel >= 1.1.4
143 Requires:       freexl >= 1.0
144 Requires:       geos >= 3.1.0
145 Requires:       libgeotiff >= 1.2.1
146 Requires:       libpng >= 2:1.2.8
147 Requires:       libtiff >= 4.0
148 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
149
150 %description
151 GDAL is a translator library for raster geospatial data formats that
152 is released under an Open Source license. As a library, it presents a
153 single abstract data model to the calling application for all
154 supported formats. The related OGR library (which lives within the
155 GDAL source tree) provides a similar capability for simple features
156 vector data.
157
158 %description -l pl.UTF-8
159 GDAL to biblioteka konwertująca między formatami rastrowych danych
160 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
161 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
162 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
163 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
164 możliwości dla danych wektorowych.
165
166 %package devel
167 Summary:        GDAL library header files
168 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
169 Group:          Development/Libraries
170 Requires:       %{name} = %{version}-%{release}
171 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
172 %{?with_armadillo:Requires:     armadillo-devel}
173 Requires:       cfitsio-devel
174 %{?with_dds:Requires:   crnlib-devel}
175 Requires:       curl-devel
176 %{?with_epsilon:Requires:       epsilon-compressor-devel}
177 %{?with_fyba:Requires:  fyba-devel}
178 Requires:       expat-devel >= 1.95.0
179 Requires:       freexl-devel >= 1.0
180 Requires:       geos-devel >= 3.1.0
181 Requires:       giflib-devel >= 4.0
182 Requires:       hdf-devel >= 4.0
183 Requires:       hdf5-devel
184 Requires:       jasper-devel
185 Requires:       json-c-devel >= 0.11
186 Requires:       libcsf-devel
187 Requires:       libdap-devel >= 3.10
188 Requires:       libgeotiff-devel >= 1.2.1
189 %{?with_gta:Requires:   libgta-devel}
190 Requires:       libjpeg-devel >= 6b
191 Requires:       libpng-devel >= 2:1.2.8
192 %{?with_spatialite:Requires:    libspatialite-devel}
193 Requires:       libstdc++-devel
194 Requires:       libtiff-devel >= 4.0
195 Requires:       libuuid-devel
196 Requires:       libwebp-devel
197 Requires:       libxml2-devel >= 2
198 %{?with_mysql:Requires: mysql-devel}
199 Requires:       netcdf-devel >= 4
200 Requires:       ogdi-devel >= 3.1
201 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
202 #Requires:      pcidsk-devel > 0.3
203 %{?with_podofo:Requires:        podofo-devel}
204 %{?with_poppler:Requires:       poppler-devel >= 0.24}
205 Requires:       postgresql-devel
206 Requires:       proj-devel >= 4
207 %{?with_rasdaman:Requires:      rasdaman-devel}
208 Requires:       sqlite3-devel >= 3.0.0
209 %{?with_odbc:Requires:  unixODBC-devel}
210 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
211 Requires:       xz-devel
212 Requires:       zlib-devel >= 1.1.4
213
214 %description devel
215 GDAL library header files.
216
217 %description devel -l pl.UTF-8
218 Pliki nagłówkowe biblioteki GDAL.
219
220 %package static
221 Summary:        GDAL static libraries
222 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
223 Group:          Development/Libraries
224 Requires:       %{name}-devel = %{version}-%{release}
225
226 %description static
227 GDAL static libraries.
228
229 %description static -l pl.UTF-8
230 Statyczne biblioteki GDAL.
231
232 %package -n perl-gdal
233 Summary:        Perl bindings for GDAL
234 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
235 Group:          Development/Languages/Perl
236 Requires:       %{name} = %{version}-%{release}
237
238 %description -n perl-gdal
239 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
240
241 %description -n perl-gdal -l pl.UTF-8
242 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
243
244 %package -n %{php_name}-gdal
245 Summary:        PHP bindings for GDAL library
246 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
247 Group:          Development/Languages/PHP
248 Requires:       %{name} = %{version}-%{release}
249 %{?requires_php_extension}
250
251 %description -n %{php_name}-gdal
252 PHP bindings for GDAL library
253
254 %description -n %{php_name}-gdal -l pl.UTF-8
255 Wiązania PHP do biblioteki GDAL.
256
257 %package -n python-gdal
258 Summary:        GDAL Python module
259 Summary(pl.UTF-8):      Moduł Pythona GDAL
260 Group:          Libraries/Python
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       python-libs
263
264 %description -n python-gdal
265 GDAL Python module.
266
267 %description -n python-gdal -l pl.UTF-8
268 Moduł Pythona GDAL.
269
270 %package -n ruby-gdal
271 Summary:        Ruby bindings for GDAL
272 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
273 Group:          Development/Languages
274 Requires:       %{name} = %{version}-%{release}
275
276 %description -n ruby-gdal
277 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
278
279 %description -n ruby-gdal -l pl.UTF-8
280 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
281 osr.
282
283 %prep
284 %setup -q
285 %patch0 -p1
286 %patch1 -p1
287 %patch2 -p1
288 %patch3 -p1
289 %patch4 -p1
290 %patch5 -p1
291 %patch6 -p1
292 %patch7 -p1
293 %patch8 -p1
294 %patch9 -p1
295 %patch10 -p1
296 %patch11 -p1
297 %patch12 -p1
298 %patch13 -p1
299
300 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
301 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
302
303 %{__sed} -i \
304         -e 's/^CC=gcc/CC=%{__cc}/' \
305         -e 's/^CXX=g++/CXX=%{__cxx}/' \
306         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
307         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
308         swig/php/GNUmakefile
309 # Build with fPIC to allow Ruby bindings
310 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
311 # http://trac.osgeo.org/gdal/ticket/1994
312 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
313 # Install Ruby bindings to distribution specific directory
314 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
315
316 # Install Ruby bindings into the proper place
317 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
318 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
319
320 # our man path
321 sed -i -e 's#^mandir=.*##g' configure.in
322
323 %{__rm} -r man
324
325 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
326
327 %build
328 %{__libtoolize}
329 %{__aclocal} -I m4
330 %{__autoconf}
331 %configure \
332         --datadir=%{_datadir}/gdal \
333         --with-dods-root=/usr \
334         %{?with_armadillo:--with-armadillo} \
335         %{?with_crnlib:--with-dds} \
336         %{?with_epsilon:--with-epsilon} \
337         %{?with_grass:--with-grass} \
338         %{!?with_gta:--without-gta} \
339         --with-hide-internal-symbols \
340         %{?with_java:--with-java=%{java_home}} \
341         --with-liblzma \
342         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
343         %{?with_mysql:--with-mysql} \
344         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
345         %{?with_opencl:--with-opencl} \
346         --with-perl \
347         %{?with_php:--with-php} \
348         %{?with_podofo:--with-podofo} \
349         %{?with_poppler:--with-poppler} \
350         --with-python \
351         %{?with_rasdaman:--with-rasdaman=%{_libdir}/rasdaman} \
352         %{?with_ruby:--with-ruby} \
353         %{?with_fyba:--with-sosi} \
354         %{?with_spatialite:--with-spatialite} \
355         --with-sqlite3 \
356         --with-webp \
357         %{?with_xerces:--with-xerces} \
358         --with-xerces-inc=/usr/include/xercesc \
359         --with-xerces-lib="-lxerces-c" \
360         --without-libgrass
361 #       --with-pcidsk=/usr (needs > 0.3)
362 # csharp builds, but has no configure option nor install target
363
364 # regenerate where needed
365 %{__make} -j1 -C swig/perl generate
366 %if %{with ruby}
367 %{__make} -j1 -C swig/ruby generate
368 %endif
369
370 %{__make} -j1 \
371         %{?with_grass:GRASS_INCLUDE="-I/usr/include/grass64"} \
372         %{?with_fyba:SOSI_INC="-I/usr/include/fyba"}
373
374 %{__make} -j1 docs
375
376 %{__make} -j1 man
377
378 %install
379 rm -rf $RPM_BUILD_ROOT
380
381 %{__make} -j1 install install-man \
382         DESTDIR=$RPM_BUILD_ROOT
383
384 rm -rf _html
385 cp -a html _html
386 cp -a ogr/html _html/ogr
387
388 %if %{with php}
389 # missing in make install
390 install -d $RPM_BUILD_ROOT%{php_extensiondir}
391 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
392 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
393 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
394 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
395 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
396 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
397 ; Enable gdal extension modules
398 extension=gdal.so
399 extension=gdalconst.so
400 extension=ogr.so
401 extension=osr.so
402 EOF
403 %endif
404
405 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
406 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
407 %py_postclean
408
409 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
410 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
411 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
412 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
413 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
414
415 # some doxygen trash
416 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
417 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
418
419 %clean
420 rm -rf $RPM_BUILD_ROOT
421
422 %post   -p /sbin/ldconfig
423 %postun -p /sbin/ldconfig
424
425 %files
426 %defattr(644,root,root,755)
427 %doc NEWS PROVENANCE.TXT
428 %attr(755,root,root) %{_bindir}/epsg_tr.py
429 %attr(755,root,root) %{_bindir}/esri2wkt.py
430 %attr(755,root,root) %{_bindir}/gcps2vec.py
431 %attr(755,root,root) %{_bindir}/gcps2wld.py
432 %attr(755,root,root) %{_bindir}/gdal2tiles.py
433 %attr(755,root,root) %{_bindir}/gdal2xyz.py
434 %attr(755,root,root) %{_bindir}/gdal_auth.py
435 %attr(755,root,root) %{_bindir}/gdal_contour
436 %attr(755,root,root) %{_bindir}/gdal_calc.py
437 %attr(755,root,root) %{_bindir}/gdal_edit.py
438 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
439 %attr(755,root,root) %{_bindir}/gdal_grid
440 %attr(755,root,root) %{_bindir}/gdal_merge.py
441 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
442 %attr(755,root,root) %{_bindir}/gdal_proximity.py
443 %attr(755,root,root) %{_bindir}/gdal_rasterize
444 %attr(755,root,root) %{_bindir}/gdal_retile.py
445 %attr(755,root,root) %{_bindir}/gdal_sieve.py
446 %attr(755,root,root) %{_bindir}/gdal_translate
447 %attr(755,root,root) %{_bindir}/gdaladdo
448 %attr(755,root,root) %{_bindir}/gdalbuildvrt
449 %attr(755,root,root) %{_bindir}/gdalchksum.py
450 %attr(755,root,root) %{_bindir}/gdalcompare.py
451 %attr(755,root,root) %{_bindir}/gdaldem
452 %attr(755,root,root) %{_bindir}/gdalenhance
453 %attr(755,root,root) %{_bindir}/gdalident.py
454 %attr(755,root,root) %{_bindir}/gdalimport.py
455 %attr(755,root,root) %{_bindir}/gdalinfo
456 %attr(755,root,root) %{_bindir}/gdallocationinfo
457 %attr(755,root,root) %{_bindir}/gdalmanage
458 %attr(755,root,root) %{_bindir}/gdalmove.py
459 %attr(755,root,root) %{_bindir}/gdalserver
460 %attr(755,root,root) %{_bindir}/gdalsrsinfo
461 %attr(755,root,root) %{_bindir}/gdaltindex
462 %attr(755,root,root) %{_bindir}/gdaltransform
463 %attr(755,root,root) %{_bindir}/gdalwarp
464 %attr(755,root,root) %{_bindir}/mkgraticule.py
465 %attr(755,root,root) %{_bindir}/nearblack
466 %attr(755,root,root) %{_bindir}/ogr2ogr
467 %attr(755,root,root) %{_bindir}/ogrinfo
468 %attr(755,root,root) %{_bindir}/ogrlineref
469 %attr(755,root,root) %{_bindir}/ogrtindex
470 %attr(755,root,root) %{_bindir}/pct2rgb.py
471 %attr(755,root,root) %{_bindir}/rgb2pct.py
472 %attr(755,root,root) %{_bindir}/testepsg
473 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
475 %{_datadir}/gdal
476 %{_mandir}/man1/gdal2tiles.1*
477 %{_mandir}/man1/gdal_calc.1*
478 %{_mandir}/man1/gdal_contour.1*
479 %{_mandir}/man1/gdal_edit.1*
480 %{_mandir}/man1/gdal_fillnodata.1*
481 %{_mandir}/man1/gdal_grid.1*
482 %{_mandir}/man1/gdal_merge.1*
483 %{_mandir}/man1/gdal_polygonize.1*
484 %{_mandir}/man1/gdal_proximity.1*
485 %{_mandir}/man1/gdal_rasterize.1*
486 %{_mandir}/man1/gdal_retile.1*
487 %{_mandir}/man1/gdal_sieve.1*
488 %{_mandir}/man1/gdal_translate.1*
489 %{_mandir}/man1/gdal_utilities.1*
490 %{_mandir}/man1/gdaladdo.1*
491 %{_mandir}/man1/gdalbuildvrt.1*
492 %{_mandir}/man1/gdalcompare.1*
493 %{_mandir}/man1/gdaldem.1*
494 %{_mandir}/man1/gdalinfo.1*
495 %{_mandir}/man1/gdallocationinfo.1*
496 %{_mandir}/man1/gdalmanage.1*
497 %{_mandir}/man1/gdalmove.1*
498 %{_mandir}/man1/gdalsrsinfo.1*
499 %{_mandir}/man1/gdaltindex.1*
500 %{_mandir}/man1/gdaltransform.1*
501 %{_mandir}/man1/gdalwarp.1*
502 %{_mandir}/man1/nearblack.1*
503 %{_mandir}/man1/ogr2ogr.1*
504 %{_mandir}/man1/ogr_utilities.1*
505 %{_mandir}/man1/ogrinfo.1*
506 %{_mandir}/man1/ogrlineref.1*
507 %{_mandir}/man1/ogrtindex.1*
508 %{_mandir}/man1/pct2rgb.1*
509 %{_mandir}/man1/rgb2pct.1*
510
511 %files devel
512 %defattr(644,root,root,755)
513 %doc _html/*
514 %attr(755,root,root) %{_bindir}/gdal-config
515 %attr(755,root,root) %{_libdir}/libgdal.so
516 %{_libdir}/libgdal.la
517 %{_pkgconfigdir}/gdal.pc
518 %{_includedir}/cpl_*.h
519 %{_includedir}/cplkeywordparser.h
520 %{_includedir}/gdal*.h
521 %{_includedir}/gvgcpfit.h
522 %{_includedir}/memdataset.h
523 %{_includedir}/ogr_*.h
524 %{_includedir}/ogrsf_frmts.h
525 %{_includedir}/rawdataset.h
526 %{_includedir}/thinplatespline.h
527 %{_includedir}/vrtdataset.h
528 %{_mandir}/man1/gdal-config.1*
529
530 %files static
531 %defattr(644,root,root,755)
532 %{_libdir}/libgdal.a
533
534 %files -n perl-gdal
535 %defattr(644,root,root,755)
536 %dir %{perl_vendorarch}/Geo
537 %{perl_vendorarch}/Geo/GDAL.pm
538 %dir %{perl_vendorarch}/Geo/GDAL
539 %{perl_vendorarch}/Geo/GDAL/Const.pm
540 %{perl_vendorarch}/Geo/OGR.pm
541 %{perl_vendorarch}/Geo/OSR.pm
542 %dir %{perl_vendorarch}/auto/Geo
543 %dir %{perl_vendorarch}/auto/Geo/GDAL
544 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
545 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
546 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
547 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
548 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
549 %dir %{perl_vendorarch}/auto/Geo/OGR
550 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
551 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
552 %dir %{perl_vendorarch}/auto/Geo/OSR
553 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
554 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
555
556 %if %{with php}
557 %files -n %{php_name}-gdal
558 %defattr(644,root,root,755)
559 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
560 %attr(755,root,root) %{php_extensiondir}/gdal.so
561 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
562 %attr(755,root,root) %{php_extensiondir}/ogr.so
563 %attr(755,root,root) %{php_extensiondir}/osr.so
564 %endif
565
566 %files -n python-gdal
567 %defattr(644,root,root,755)
568 %{py_sitedir}/gdal.py[co]
569 %{py_sitedir}/gdalconst.py[co]
570 %{py_sitedir}/gdalnumeric.py[co]
571 %{py_sitedir}/ogr.py[co]
572 %{py_sitedir}/osr.py[co]
573 %{py_sitedir}/GDAL-*.egg-info
574 %dir %{py_sitedir}/osgeo
575 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
576 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
577 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
578 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
579 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
580 %{py_sitedir}/osgeo/*.py[co]
581
582 %if %{with ruby}
583 %files -n ruby-gdal
584 %defattr(644,root,root,755)
585 %dir %{ruby_vendorarchdir}/gdal
586 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
587 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
588 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
589 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
590 %endif
This page took 0.070985 seconds and 3 git commands to generate.