]> git.pld-linux.org Git - packages/gdal.git/blob - gdal.spec
build with php55
[packages/gdal.git] / gdal.spec
1 # TODO:
2 # - be reasonable about devel dependencies - you do not need all of them to
3 #   use gdal (probably a gdal module or driver shall not imply devel
4 #   dependency)
5 # - rasdaman (--with-rasdaman; http://rasdaman.eecs.jacobs-university.de/trac/rasdaman/wiki/Download)
6 # - libjpeg12 (needs patching to use system one, --with-jpeg12 is not sufficient as of 1.9.2)
7 # - libkml (1.3.0 needed, not released yet)
8 # - wait for newer pcidsk, switch to external again
9 # - csharp, java
10 # - DDS (--with-dds, BR [lib]crunch: http://code.google.com/p/crunch/)
11 # - SOSI (--with-sosi, BR: libfyba libfygm libfyut: https://github.com/kartverket/fyba)
12 # - additional, proprietary(?) formats support:
13 #   - FMEObjects (http://www.safe.com/support/support-resources/fme-downloads/)
14 #   - ESRI FileGDBAPI (http://resources.arcgis.com/content/geodatabases/10.0/file-gdb-api)
15 #   - ECW (http://www.erdas.com/products/ecw/ERDASECWJPEG2000SDK/Details.aspx)
16 #   - Kakadu/JPEG2000 (http://www.kakadusoftware.com/)
17 #   - MrSID (http://www.lizardtech.com/developer/)
18 #   - MSG/EUMETSAT (http://www.eumetsat.int/Home/Main/DataAccess/SupportSoftwareTools/index.htm)
19 #   - Oracle/OCI >= 10.0.1 (for georaster); Oracle/OCI >= 8.1.7 (as DB)
20 #   - Ingres (--with-ingres=/path)
21 #   - Informix DB (--with-idb)
22 #   - DWGdirect (members only? http://www.opendwg.org/)
23 #   - ESRI SDE (http://www.esri.com/software/arcgis/arcsde/index.html)
24 #
25 # Conditional build:
26 %bcond_without  armadillo       # Armadillo support for faster TPS transform
27 %bcond_without  epsilon         # EPSILON wavelet compression support
28 %bcond_with     grass           # GRASS support (note: dependency loop)
29 %bcond_without  gta             # GTA format support
30 %bcond_without  mysql           # MySQL DB support
31 %bcond_with     oci             # ORACLE OCI DB and Georaster support
32 %bcond_without  odbc            # ODBC DB support
33 %bcond_without  opencl          # OpenCL (GPU) support
34 %bcond_without  openjpeg        # OpenJPEG 2 (JPEG2000) support
35 %bcond_with     podofo          # PDF support via podofo instead of poppler
36 %bcond_without  poppler         # PDF support via poppler
37 %bcond_without  spatialite      # SpatiaLite support
38 %bcond_without  xerces          # Xerces support
39 %bcond_without  java            # Java and MDB support
40 %bcond_without  php             # PHP binding
41 %bcond_without  ruby            # Ruby binding
42
43 %if %{with podofo}
44 %undefine       with_poppler
45 %endif
46 %define         php_name        php55
47 Summary:        Geospatial Data Abstraction Library
48 Summary(pl.UTF-8):      Biblioteka abstrakcji danych dotyczących powierzchni Ziemi
49 Name:           gdal
50 Version:        1.11.0
51 Release:        3
52 License:        BSD-like
53 Group:          Libraries
54 Source0:        http://download.osgeo.org/gdal/%{version}/%{name}-%{version}.tar.xz
55 # Source0-md5:  31f2c4a7230b40e5fdc3cf12a100f96b
56 Patch0:         %{name}-perl.patch
57 Patch1:         %{name}-python_install.patch
58 Patch2:         %{name}-php.patch
59 Patch3:         %{name}-fpic.patch
60 Patch4:         %{name}-format-security.patch
61 Patch5:         %{name}-grass.patch
62 Patch6:         %{name}-sse.patch
63 Patch7:         %{name}-link.patch
64 URL:            http://www.gdal.org/
65 %{?with_php:BuildRequires:      %{php_name}-devel}
66 %{?with_opencl:BuildRequires:   OpenCL-devel >= 1.0}
67 %{?with_armadillo:BuildRequires:        armadillo-devel}
68 BuildRequires:  autoconf >= 2.52
69 BuildRequires:  automake
70 BuildRequires:  cfitsio-devel
71 BuildRequires:  curl-devel
72 BuildRequires:  doxygen >= 1.4.2
73 %{?with_epsilon:BuildRequires:  epsilon-compressor-devel}
74 BuildRequires:  expat-devel >= 1.95.0
75 BuildRequires:  freexl-devel >= 1.0
76 BuildRequires:  gcc >= 6:4.1
77 BuildRequires:  geos-devel >= 3.1.0
78 BuildRequires:  giflib-devel >= 4.0
79 %{?with_grass:BuildRequires:    grass-devel >= 5.7}
80 BuildRequires:  hdf-devel >= 4.0
81 BuildRequires:  hdf5-devel
82 BuildRequires:  jasper-devel
83 %{?with_java:BuildRequires:     jdk}
84 %{?with_java:BuildRequires:     jpackage-utils}
85 BuildRequires:  json-c-devel >= 0.11
86 BuildRequires:  libcsf-devel
87 BuildRequires:  libdap-devel >= 3.10
88 BuildRequires:  libgeotiff-devel >= 1.2.1
89 %{?with_gta:BuildRequires:      libgta-devel}
90 BuildRequires:  libjpeg-devel >= 6b
91 #BuildRequires: libkml-devel >= 1.3.0
92 BuildRequires:  libpng-devel >= 2:1.2.8
93 %{?with_spatialite:BuildRequires:       libspatialite-devel}
94 BuildRequires:  libstdc++-devel
95 BuildRequires:  libtiff-devel >= 4.0
96 BuildRequires:  libtool
97 BuildRequires:  libuuid-devel
98 BuildRequires:  libwebp-devel
99 BuildRequires:  libxml2-devel >= 2
100 %{?with_mysql:BuildRequires:    mysql-devel}
101 BuildRequires:  netcdf-devel >= 4.1
102 BuildRequires:  ogdi-devel >= 3.1
103 %{?with_openjpeg:BuildRequires: openjpeg2-devel >= 2.0.0-2}
104 # 8.1.7 for DB support, 10.0.1 for georaster
105 %{?with_oci:BuildRequires:      oracle-instantclient-devel >= 10.0.1}
106 #BuildRequires: pcidsk-devel > 0.3
107 BuildRequires:  perl-devel
108 %{?with_podofo:BuildRequires:   podofo-devel}
109 %{?with_poppler:BuildRequires:  poppler-devel >= 0.24}
110 # ensure it's compiled with PQescapeStringConn support
111 BuildRequires:  postgresql-backend-devel >= 8.1.4
112 BuildRequires:  postgresql-devel >= 8.1.4
113 BuildRequires:  proj-devel >= 4
114 BuildRequires:  python-devel >= 1:2.5
115 BuildRequires:  python-numpy-devel >= 1:1.0.0
116 BuildRequires:  python-setuptools
117 BuildRequires:  rpm-pythonprov
118 %{?with_ruby:BuildRequires:     rpm-rubyprov}
119 BuildRequires:  rpmbuild(macros) >= 1.344
120 %{?with_ruby:BuildRequires:     ruby-devel}
121 BuildRequires:  sed >= 4.0
122 BuildRequires:  sqlite3-devel >= 3.0.0
123 BuildRequires:  swig-perl
124 BuildRequires:  swig-php >= 2.0.12-2
125 BuildRequires:  swig-python >= 1.3
126 %{?with_ruby:BuildRequires:     swig-ruby}
127 BuildRequires:  texlive-dvips
128 BuildRequires:  texlive-latex
129 %{?with_odbc:BuildRequires:     unixODBC-devel >= 2.2.15}
130 %{?with_xerces:BuildRequires:   xerces-c-devel >= 2.7.0}
131 BuildRequires:  xz-devel
132 BuildRequires:  zlib-devel >= 1.1.4
133 Requires:       freexl >= 1.0
134 Requires:       geos >= 3.1.0
135 Requires:       libgeotiff >= 1.2.1
136 Requires:       libpng >= 2:1.2.8
137 Requires:       libtiff >= 4.0
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %description
141 GDAL is a translator library for raster geospatial data formats that
142 is released under an Open Source license. As a library, it presents a
143 single abstract data model to the calling application for all
144 supported formats. The related OGR library (which lives within the
145 GDAL source tree) provides a similar capability for simple features
146 vector data.
147
148 %description -l pl.UTF-8
149 GDAL to biblioteka konwertująca między formatami rastrowych danych
150 dotyczących powierzchni Ziemi, udostępniona na licencji Open Source.
151 Jako biblioteka udostępnia aplikacjom jeden abstrakcyjny model danych
152 do wszystkich obsługiwanych formatów. Powiązana z nią biblioteka OGR
153 (której źródła są dołączone do drzewa źródeł GDAL) daje podobne
154 możliwości dla danych wektorowych.
155
156 %package devel
157 Summary:        GDAL library header files
158 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GDAL
159 Group:          Development/Libraries
160 Requires:       %{name} = %{version}-%{release}
161 %{?with_opencl:Requires:        OpenCL-devel >= 1.0}
162 %{?with_armadillo:Requires:     armadillo-devel}
163 Requires:       cfitsio-devel
164 Requires:       curl-devel
165 %{?with_epsilon:Requires:       epsilon-compressor-devel}
166 Requires:       expat-devel >= 1.95.0
167 Requires:       freexl-devel >= 1.0
168 Requires:       geos-devel >= 3.1.0
169 Requires:       giflib-devel >= 4.0
170 Requires:       hdf-devel >= 4.0
171 Requires:       hdf5-devel
172 Requires:       jasper-devel
173 Requires:       json-c-devel >= 0.11
174 Requires:       libcsf-devel
175 Requires:       libdap-devel >= 3.10
176 Requires:       libgeotiff-devel >= 1.2.1
177 %{?with_gta:Requires:   libgta-devel}
178 Requires:       libjpeg-devel >= 6b
179 Requires:       libpng-devel >= 2:1.2.8
180 %{?with_spatialite:Requires:    libspatialite-devel}
181 Requires:       libstdc++-devel
182 Requires:       libtiff-devel >= 4.0
183 Requires:       libuuid-devel
184 Requires:       libwebp-devel
185 Requires:       libxml2-devel >= 2
186 %{?with_mysql:Requires: mysql-devel}
187 Requires:       netcdf-devel >= 4
188 Requires:       ogdi-devel >= 3.1
189 %{?with_openjpeg:Requires:      openjpeg2-devel >= 2.0.0-2}
190 #Requires:      pcidsk-devel > 0.3
191 %{?with_podofo:Requires:        podofo-devel}
192 %{?with_poppler:Requires:       poppler-devel >= 0.24}
193 Requires:       postgresql-devel
194 Requires:       proj-devel >= 4
195 Requires:       sqlite3-devel >= 3.0.0
196 %{?with_odbc:Requires:  unixODBC-devel}
197 %{?with_xerces:Requires:        xerces-c-devel >= 2.7.0}
198 Requires:       xz-devel
199 Requires:       zlib-devel >= 1.1.4
200
201 %description devel
202 GDAL library header files.
203
204 %description devel -l pl.UTF-8
205 Pliki nagłówkowe biblioteki GDAL.
206
207 %package static
208 Summary:        GDAL static libraries
209 Summary(pl.UTF-8):      Statyczne biblioteki GDAL
210 Group:          Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212
213 %description static
214 GDAL static libraries.
215
216 %description static -l pl.UTF-8
217 Statyczne biblioteki GDAL.
218
219 %package -n perl-gdal
220 Summary:        Perl bindings for GDAL
221 Summary(pl.UTF-8):      Wiązania Perla do pakietu GDAL
222 Group:          Development/Languages/Perl
223 Requires:       %{name} = %{version}-%{release}
224
225 %description -n perl-gdal
226 Perl bindings for GDAL - Geo::GDAL, Geo::OGR and Geo::OSR modules.
227
228 %description -n perl-gdal -l pl.UTF-8
229 Wiązania Perla do pakietu GDAL - moduły Geo::GDAL, Geo::OGR, Geo::OSR.
230
231 %package -n %{php_name}-gdal
232 Summary:        PHP bindings for GDAL library
233 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GDAL
234 Group:          Development/Languages/PHP
235 Requires:       %{name} = %{version}-%{release}
236 %{?requires_php_extension}
237
238 %description -n %{php_name}-gdal
239 PHP bindings for GDAL library
240
241 %description -n %{php_name}-gdal -l pl.UTF-8
242 Wiązania PHP do biblioteki GDAL.
243
244 %package -n python-gdal
245 Summary:        GDAL Python module
246 Summary(pl.UTF-8):      Moduł Pythona GDAL
247 Group:          Libraries/Python
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       python-libs
250
251 %description -n python-gdal
252 GDAL Python module.
253
254 %description -n python-gdal -l pl.UTF-8
255 Moduł Pythona GDAL.
256
257 %package -n ruby-gdal
258 Summary:        Ruby bindings for GDAL
259 Summary(pl.UTF-8):      Wiązania języka Ruby do pakietu GDAL
260 Group:          Development/Languages
261 Requires:       %{name} = %{version}-%{release}
262
263 %description -n ruby-gdal
264 Ruby bindings for GDAL - gdal, gdalconst, ogr and osr modules.
265
266 %description -n ruby-gdal -l pl.UTF-8
267 Wiązania języka Ruby do pakietu GDAL - moduły gdal, gdalconst, ogr i
268 osr.
269
270 %prep
271 %setup -q
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278 %patch6 -p1
279 %patch7 -p1
280
281 # need to regenerate (old ones don't support perl 5.10 or php 5.5)
282 %{__rm} swig/{perl,php}/{gdal_wrap.cpp,gdalconst_wrap.c,ogr_wrap.cpp,osr_wrap.cpp}
283
284 %{__sed} -i \
285         -e 's/^CC=gcc/CC=%{__cc}/' \
286         -e 's/^CXX=g++/CXX=%{__cxx}/' \
287         -e 's/^CFLAGS=-fpic/CFLAGS=%{rpmcflags} -fPIC/' \
288         -e 's/^LDFLAGS=-shared/LDFLAGS=%{rpmldflags} -shared/' \
289         swig/php/GNUmakefile
290 # Build with fPIC to allow Ruby bindings
291 # Xcompiler should normally achieve that -- http://trac.osgeo.org/gdal/ticket/3978
292 # http://trac.osgeo.org/gdal/ticket/1994
293 sed -i 's|\$(CFLAGS)|$(CFLAGS) -fPIC|g' swig/ruby/RubyMakefile.mk
294 # Install Ruby bindings to distribution specific directory
295 sed -i 's|RUBY_EXTENSIONS_DIR :=.*|RUBY_EXTENSIONS_DIR := %{ruby_vendorarchdir}|' swig/ruby/RubyMakefile.mk
296
297 # Install Ruby bindings into the proper place
298 sed -i -e 's|^$(INSTALL_DIR):|$(DESTDIR)$(INSTALL_DIR):|' swig/ruby/RubyMakefile.mk
299 sed -i -e 's|^install: $(INSTALL_DIR)|install: $(DESTDIR)$(INSTALL_DIR)|' swig/ruby/RubyMakefile.mk
300
301 # our man path
302 sed -i -e 's#^mandir=.*##g' configure.in
303
304 %{__rm} -r man
305
306 %{__sed} -i -e 's,DODS_INC="-I.*,DODS_INC="$(pkg-config --cflags libdap)",' configure.in
307
308 %build
309 %{__libtoolize}
310 %{__aclocal} -I m4
311 %{__autoconf}
312 # disable grass/libgrass here, it can be built from separate gdal-grass package
313 %configure \
314         --datadir=%{_datadir}/gdal \
315         --with-dods-root=/usr \
316         %{?with_armadillo:--with-armadillo} \
317         %{?with_epsilon:--with-epsilon} \
318         %{?with_grass:--with-grass} \
319         %{!?with_gta:--without-gta} \
320         --with-hide-internal-symbols \
321         %{?with_java:--with-java=%{java_home}} \
322         --with-liblzma \
323         %{?with_java:--with-mdb --with-jvm-lib-add-rpath} \
324         %{?with_mysql:--with-mysql} \
325         %{?with_oci:--with-oci --with-oci-include=/usr/include/oracle/client --with-oci-lib=%{_libdir}} \
326         %{?with_opencl:--with-opencl} \
327         --with-perl \
328         %{?with_php:--with-php} \
329         %{?with_podofo:--with-podofo} \
330         %{?with_poppler:--with-poppler} \
331         --with-python \
332         %{?with_ruby:--with-ruby} \
333         %{?with_spatialite:--with-spatialite} \
334         --with-sqlite3 \
335         --with-webp \
336         %{?with_xerces:--with-xerces} \
337         --with-xerces-inc=/usr/include/xercesc \
338         --with-xerces-lib="-lxerces-c" \
339         --without-libgrass
340 #       --with-rasdaman
341 #       --with-pcidsk=/usr (needs > 0.3)
342 # csharp builds, but has no configure option
343
344 # regenerate where needed
345 %{__make} -j1 -C swig/perl generate
346 %if %{with ruby}
347 %{__make} -j1 -C swig/ruby generate
348 %endif
349
350 %{__make} -j1
351
352 %{__make} -j1 docs
353
354 %{__make} -j1 man
355
356 %install
357 rm -rf $RPM_BUILD_ROOT
358
359 %{__make} -j1 install install-man \
360         DESTDIR=$RPM_BUILD_ROOT
361
362 rm -rf _html
363 cp -a html _html
364 cp -a ogr/html _html/ogr
365
366 %if %{with php}
367 # missing in make install
368 install -d $RPM_BUILD_ROOT%{php_extensiondir}
369 install -p swig/php/php_gdal.so $RPM_BUILD_ROOT%{php_extensiondir}/gdal.so
370 install -p swig/php/php_gdalconst.so $RPM_BUILD_ROOT%{php_extensiondir}/gdalconst.so
371 install -p swig/php/php_ogr.so $RPM_BUILD_ROOT%{php_extensiondir}/ogr.so
372 install -p swig/php/php_osr.so $RPM_BUILD_ROOT%{php_extensiondir}/osr.so
373 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
374 cat <<'EOF' >$RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gdal.ini
375 ; Enable gdal extension modules
376 extension=gdal.so
377 extension=gdalconst.so
378 extension=ogr.so
379 extension=osr.so
380 EOF
381 %endif
382
383 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
384 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
385 %py_postclean
386
387 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
388 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/.packlist
389 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/GDAL/Const/.packlist
390 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OGR/.packlist
391 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Geo/OSR/.packlist
392
393 # some doxygen trash
394 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal{compare,move}.dox
395 %{__rm} $RPM_BUILD_ROOT%{_bindir}/gdal_{calc,edit,fillnodata,polygonize,proximity,sieve}.dox
396
397 %clean
398 rm -rf $RPM_BUILD_ROOT
399
400 %post   -p /sbin/ldconfig
401 %postun -p /sbin/ldconfig
402
403 %files
404 %defattr(644,root,root,755)
405 %doc NEWS PROVENANCE.TXT
406 %attr(755,root,root) %{_bindir}/epsg_tr.py
407 %attr(755,root,root) %{_bindir}/esri2wkt.py
408 %attr(755,root,root) %{_bindir}/gcps2vec.py
409 %attr(755,root,root) %{_bindir}/gcps2wld.py
410 %attr(755,root,root) %{_bindir}/gdal2tiles.py
411 %attr(755,root,root) %{_bindir}/gdal2xyz.py
412 %attr(755,root,root) %{_bindir}/gdal_auth.py
413 %attr(755,root,root) %{_bindir}/gdal_contour
414 %attr(755,root,root) %{_bindir}/gdal_calc.py
415 %attr(755,root,root) %{_bindir}/gdal_edit.py
416 %attr(755,root,root) %{_bindir}/gdal_fillnodata.py
417 %attr(755,root,root) %{_bindir}/gdal_grid
418 %attr(755,root,root) %{_bindir}/gdal_merge.py
419 %attr(755,root,root) %{_bindir}/gdal_polygonize.py
420 %attr(755,root,root) %{_bindir}/gdal_proximity.py
421 %attr(755,root,root) %{_bindir}/gdal_rasterize
422 %attr(755,root,root) %{_bindir}/gdal_retile.py
423 %attr(755,root,root) %{_bindir}/gdal_sieve.py
424 %attr(755,root,root) %{_bindir}/gdal_translate
425 %attr(755,root,root) %{_bindir}/gdaladdo
426 %attr(755,root,root) %{_bindir}/gdalbuildvrt
427 %attr(755,root,root) %{_bindir}/gdalchksum.py
428 %attr(755,root,root) %{_bindir}/gdalcompare.py
429 %attr(755,root,root) %{_bindir}/gdaldem
430 %attr(755,root,root) %{_bindir}/gdalenhance
431 %attr(755,root,root) %{_bindir}/gdalident.py
432 %attr(755,root,root) %{_bindir}/gdalimport.py
433 %attr(755,root,root) %{_bindir}/gdalinfo
434 %attr(755,root,root) %{_bindir}/gdallocationinfo
435 %attr(755,root,root) %{_bindir}/gdalmanage
436 %attr(755,root,root) %{_bindir}/gdalmove.py
437 %attr(755,root,root) %{_bindir}/gdalserver
438 %attr(755,root,root) %{_bindir}/gdalsrsinfo
439 %attr(755,root,root) %{_bindir}/gdaltindex
440 %attr(755,root,root) %{_bindir}/gdaltransform
441 %attr(755,root,root) %{_bindir}/gdalwarp
442 %attr(755,root,root) %{_bindir}/mkgraticule.py
443 %attr(755,root,root) %{_bindir}/nearblack
444 %attr(755,root,root) %{_bindir}/ogr2ogr
445 %attr(755,root,root) %{_bindir}/ogrinfo
446 %attr(755,root,root) %{_bindir}/ogrlineref
447 %attr(755,root,root) %{_bindir}/ogrtindex
448 %attr(755,root,root) %{_bindir}/pct2rgb.py
449 %attr(755,root,root) %{_bindir}/rgb2pct.py
450 %attr(755,root,root) %{_bindir}/testepsg
451 %attr(755,root,root) %{_libdir}/libgdal.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libgdal.so.1
453 %{_datadir}/gdal
454 %{_mandir}/man1/gdal2tiles.1*
455 %{_mandir}/man1/gdal_calc.1*
456 %{_mandir}/man1/gdal_contour.1*
457 %{_mandir}/man1/gdal_edit.1*
458 %{_mandir}/man1/gdal_fillnodata.1*
459 %{_mandir}/man1/gdal_grid.1*
460 %{_mandir}/man1/gdal_merge.1*
461 %{_mandir}/man1/gdal_polygonize.1*
462 %{_mandir}/man1/gdal_proximity.1*
463 %{_mandir}/man1/gdal_rasterize.1*
464 %{_mandir}/man1/gdal_retile.1*
465 %{_mandir}/man1/gdal_sieve.1*
466 %{_mandir}/man1/gdal_translate.1*
467 %{_mandir}/man1/gdal_utilities.1*
468 %{_mandir}/man1/gdaladdo.1*
469 %{_mandir}/man1/gdalbuildvrt.1*
470 %{_mandir}/man1/gdalcompare.1*
471 %{_mandir}/man1/gdaldem.1*
472 %{_mandir}/man1/gdalinfo.1*
473 %{_mandir}/man1/gdallocationinfo.1*
474 %{_mandir}/man1/gdalmanage.1*
475 %{_mandir}/man1/gdalmove.1*
476 %{_mandir}/man1/gdalsrsinfo.1*
477 %{_mandir}/man1/gdaltindex.1*
478 %{_mandir}/man1/gdaltransform.1*
479 %{_mandir}/man1/gdalwarp.1*
480 %{_mandir}/man1/nearblack.1*
481 %{_mandir}/man1/ogr2ogr.1*
482 %{_mandir}/man1/ogr_utilities.1*
483 %{_mandir}/man1/ogrinfo.1*
484 %{_mandir}/man1/ogrlineref.1*
485 %{_mandir}/man1/ogrtindex.1*
486 %{_mandir}/man1/pct2rgb.1*
487 %{_mandir}/man1/rgb2pct.1*
488
489 %files devel
490 %defattr(644,root,root,755)
491 %doc _html/*
492 %attr(755,root,root) %{_bindir}/gdal-config
493 %attr(755,root,root) %{_libdir}/libgdal.so
494 %{_libdir}/libgdal.la
495 %{_pkgconfigdir}/gdal.pc
496 %{_includedir}/cpl_*.h
497 %{_includedir}/cplkeywordparser.h
498 %{_includedir}/gdal*.h
499 %{_includedir}/gvgcpfit.h
500 %{_includedir}/memdataset.h
501 %{_includedir}/ogr_*.h
502 %{_includedir}/ogrsf_frmts.h
503 %{_includedir}/rawdataset.h
504 %{_includedir}/thinplatespline.h
505 %{_includedir}/vrtdataset.h
506 %{_mandir}/man1/gdal-config.1*
507
508 %files static
509 %defattr(644,root,root,755)
510 %{_libdir}/libgdal.a
511
512 %files -n perl-gdal
513 %defattr(644,root,root,755)
514 %dir %{perl_vendorarch}/Geo
515 %{perl_vendorarch}/Geo/GDAL.pm
516 %dir %{perl_vendorarch}/Geo/GDAL
517 %{perl_vendorarch}/Geo/GDAL/Const.pm
518 %{perl_vendorarch}/Geo/OGR.pm
519 %{perl_vendorarch}/Geo/OSR.pm
520 %dir %{perl_vendorarch}/auto/Geo
521 %dir %{perl_vendorarch}/auto/Geo/GDAL
522 %{perl_vendorarch}/auto/Geo/GDAL/GDAL.bs
523 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/GDAL.so
524 %dir %{perl_vendorarch}/auto/Geo/GDAL/Const
525 %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.bs
526 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/GDAL/Const/Const.so
527 %dir %{perl_vendorarch}/auto/Geo/OGR
528 %{perl_vendorarch}/auto/Geo/OGR/OGR.bs
529 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OGR/OGR.so
530 %dir %{perl_vendorarch}/auto/Geo/OSR
531 %{perl_vendorarch}/auto/Geo/OSR/OSR.bs
532 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/OSR/OSR.so
533
534 %if %{with php}
535 %files -n %{php_name}-gdal
536 %defattr(644,root,root,755)
537 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gdal.ini
538 %attr(755,root,root) %{php_extensiondir}/gdal.so
539 %attr(755,root,root) %{php_extensiondir}/gdalconst.so
540 %attr(755,root,root) %{php_extensiondir}/ogr.so
541 %attr(755,root,root) %{php_extensiondir}/osr.so
542 %endif
543
544 %files -n python-gdal
545 %defattr(644,root,root,755)
546 %{py_sitedir}/gdal.py[co]
547 %{py_sitedir}/gdalconst.py[co]
548 %{py_sitedir}/gdalnumeric.py[co]
549 %{py_sitedir}/ogr.py[co]
550 %{py_sitedir}/osr.py[co]
551 %{py_sitedir}/GDAL-*.egg-info
552 %dir %{py_sitedir}/osgeo
553 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal.so
554 %attr(755,root,root) %{py_sitedir}/osgeo/_gdal_array.so
555 %attr(755,root,root) %{py_sitedir}/osgeo/_gdalconst.so
556 %attr(755,root,root) %{py_sitedir}/osgeo/_ogr.so
557 %attr(755,root,root) %{py_sitedir}/osgeo/_osr.so
558 %{py_sitedir}/osgeo/*.py[co]
559
560 %if %{with ruby}
561 %files -n ruby-gdal
562 %defattr(644,root,root,755)
563 %dir %{ruby_vendorarchdir}/gdal
564 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdal.so
565 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/gdalconst.so
566 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/ogr.so
567 %attr(755,root,root) %{ruby_vendorarchdir}/gdal/osr.so
568 %endif
This page took 0.085109 seconds and 3 git commands to generate.