]> git.pld-linux.org Git - packages/freerdp.git/blame - freerdp.spec
- up to 2.0 devel version (git snapshot) due to problems with compatibility with...
[packages/freerdp.git] / freerdp.spec
CommitLineData
e2f5e569
AO
1# TODO:
2# - fix DirectFB client build
3# - consider coexisting freerdp 1.x and 2.0 (some apps require 1.x version, e.g. vlc)
dd410870 4#
acdabdb6
JB
5# Conditional build:
6%bcond_without alsa # ALSA sound support
7%bcond_without cups # CUPS printing support
e2f5e569 8%bcond_with directfb # DirectFB client
acdabdb6
JB
9%bcond_without ffmpeg # FFmpeg audio/video decoding support
10%bcond_without pcsc # SmartCard support via PCSC-lite library
11%bcond_without pulseaudio # Pulseaudio sound support
e2f5e569 12%bcond_without wayland # Wayland client
acdabdb6
JB
13%bcond_without x11 # X11 client
14%bcond_with sse2 # SSE2 instructions
dd410870 15
acdabdb6
JB
16%ifarch %{x8664} pentium4
17%define with_sse2 1
18%endif
e2f5e569
AO
19%define rel 1
20%define snap 20160519
e07ea24b 21Summary: Remote Desktop Protocol client
acdabdb6 22Summary(pl.UTF-8): Klient protokołu RDP
e07ea24b 23Name: freerdp
e2f5e569
AO
24Version: 2.0.0
25Release: 0.%{snap}.%{rel}
acdabdb6 26License: Apache v2.0
e07ea24b 27Group: Applications/Communications
e2f5e569
AO
28# https://github.com/FreeRDP/FreeRDP/archive/master.tar.gz
29Source0: %{name}-%{version}-%{snap}.tar.gz
30# Source0-md5: ba0d58f19e6a2bd3ca1ac88593c7ed80
31Patch0: freerdp-DirectFB-include.patch
e07ea24b 32URL: http://www.freerdp.com/
acdabdb6
JB
33%{?with_directfb:BuildRequires: DirectFB-devel}
34%{?with_alsa:BuildRequires: alsa-lib-devel}
35BuildRequires: cmake >= 2.6
36%{?with_cups:BuildRequires: cups-devel}
e07ea24b 37BuildRequires: desktop-file-utils
acdabdb6 38%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
e07ea24b 39BuildRequires: openssl-devel
dd410870 40%{?with_pcsc:BuildRequires: pcsc-lite-devel}
acdabdb6
JB
41BuildRequires: pkgconfig
42%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
e2f5e569
AO
43%{?with_wayland:BuildRequires: wayland-devel}
44%if %{with x11}
e07ea24b
AM
45BuildRequires: xmlto
46BuildRequires: xorg-lib-libX11-devel
e5316440
ER
47BuildRequires: xorg-lib-libXcursor-devel
48BuildRequires: xorg-lib-libXdamage-devel
e07ea24b 49BuildRequires: xorg-lib-libXext-devel
acdabdb6 50BuildRequires: xorg-lib-libXfixes-devel
e07ea24b 51BuildRequires: xorg-lib-libXinerama-devel
acdabdb6 52BuildRequires: xorg-lib-libXtst-devel
7d17d2a0
ER
53BuildRequires: xorg-lib-libXv-devel
54BuildRequires: xorg-lib-libxkbfile
e2f5e569 55%endif
acdabdb6 56BuildRequires: zlib-devel
e5316440 57Requires: %{name}-libs = %{version}-%{release}
acdabdb6 58Requires: hicolor-icon-theme
e07ea24b 59Provides: xfreerdp = %{version}-%{release}
e2f5e569 60Conflicts: xfreerdp < 2.0.0
e5316440 61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e07ea24b
AM
62
63%description
acdabdb6 64xfreerdp is Remote Desktop Protocol (RDP) client from the FreeRDP
e07ea24b
AM
65project.
66
67xfreerdp can connect to RDP servers such as Microsoft Windows
68machines, xrdp and VirtualBox.
69
acdabdb6
JB
70%description -l pl.UTF-8
71xfreerdp to klient protokołu RDP (Remote Desktop Protocol) z projektu
72FreeRDP.
73
74xfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
75Microsoft Windows, xrdp oraz VirtualBox.
76
77%package dfb
78Summary: DirectFB based Remote Desktop Protocol klient
79Summary(pl.UTF-8): Klient protokołu RDP oparty na DirectFB
80Group: Applications/Communications
81Requires: %{name}-libs = %{version}-%{release}
acdabdb6
JB
82
83%description dfb
84DirectFB based Remote Desktop Protocol klient.
85
86dfreerdp can connect to RDP servers such as Microsoft Windows
87machines, xrdp and VirtualBox.
88
89%description -l pl.UTF-8
90Klient protokołu RDP oparty na DirectFB.
91
92dfreerdp może łączyć się z serwerami RDP, takimi jak maszyny z
93Microsoft Windows, xrdp oraz VirtualBox.
94
dd410870 95%package libs
e5316440 96Summary: Core libraries implementing the RDP protocol
acdabdb6
JB
97Summary(pl.UTF-8): Główne biblioteki implementujące protokół RDP
98Group: Libraries
e5316440 99
acdabdb6 100%description libs
e07ea24b
AM
101libfreerdp-core can be embedded in applications.
102
103libfreerdp-channels and libfreerdp-kbd might be convenient to use in X
104applications together with libfreerdp-core.
105
106libfreerdp-core can be extended with plugins handling RDP channels.
107
acdabdb6
JB
108%description libs -l pl.UTF-8
109libfreerdp-core może być osadzane w aplikacjach.
110
111libfreerdp-channels oraz libfreerdp-kbd mogą być wygodne przy użyciu
112wraz z libfreerdp-core w aplikacjach X.
113
114libfreerdp-core można rozszerzać przy użyciu wtyczek obsługujących
115kanały RDP.
116
117%package devel
118Summary: Development files for FreeRDP libraries
119Summary(pl.UTF-8): Pliki programistyczne bibliotek FreeRDP
120Group: Development/Libraries
121Requires: %{name}-libs = %{version}-%{release}
122
123%description devel
124This package contains the header files for developing applications
125that use FreeRDP libraries.
126
127%description devel -l pl.UTF-8
128Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
129wykorzystujących biblioteki FreeRDP.
130
e07ea24b 131%prep
e2f5e569 132%setup -q -n FreeRDP-master
acdabdb6 133%patch0 -p1
e07ea24b
AM
134
135cat << EOF > xfreerdp.desktop
136[Desktop Entry]
137Type=Application
138Name=X FreeRDP
139NoDisplay=true
140Comment=Connect to RDP server and display remote desktop
acdabdb6 141Comment[pl]=Połączenie z serwerem RDP i wyświetlanie zdalnego pulpitu
e07ea24b
AM
142Icon=%{name}
143Exec=%{_bindir}/xfreerdp
144Terminal=false
145Categories=Network;RemoteAccess;
146EOF
147
e07ea24b 148%build
e5316440
ER
149install -d build
150cd build
acdabdb6
JB
151%cmake .. \
152 -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
e2f5e569 153 %{?with_alsa:-DWITH_ALSA=ON}%{!?with_alsa:-DWITH_ALSA=OFF} \
acdabdb6 154 -DWITH_CUNIT=OFF \
e2f5e569
AO
155 %{?with_cups:-DWITH_CUPS=ON}%{!?with_cups:-DWITH_CUPS=OFF} \
156 %{?with_directfb:-DWITH_DIRECTFB=ON}%{!?with_directfb:-DWITH_DIRECTFB=OFF} \
157 %{?with_ffmpeg:-DWITH_FFMPEG=ON}%{!?with_ffmpeg:-DWITH_FFMPEG=OFF} \
158 %{?with_pcsc:-DWITH_PCSC=ON}%{!?with_pcsc:-DWITH_PCSC=OFF} \
159 %{?with_pulseaudio:-DWITH_PULSE=ON}%{!?with_pulseaudio:-DWITH_PULSE=OFF} \
acdabdb6 160 -DWITH_SERVER=ON \
e2f5e569
AO
161 %{?with_sse2:-DWITH_SSE2=ON}%{!?with_sse2:-DWITH_SSE2=OFF} \
162 %{?with_wayland:-DWITH_X11=ON}%{!?with_wayland:-DWITH_X11=OFF} \
163 %{?with_x11:-DWITH_X11=ON}%{!?with_x11:-DWITH_X11=OFF} \
e5316440
ER
164 -DWITH_XCURSOR=ON \
165 -DWITH_XEXT=ON \
166 -DWITH_XINERAMA=ON \
167 -DWITH_XKBFILE=ON \
acdabdb6 168 -DWITH_XV=ON
e5316440
ER
169
170%{__make}
e07ea24b
AM
171
172%install
173rm -rf $RPM_BUILD_ROOT
dd410870 174%{__make} -C build install \
e5316440
ER
175 INSTALL="install -p" \
176 DESTDIR=$RPM_BUILD_ROOT
e07ea24b 177
e2f5e569 178%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/cmake
e07ea24b
AM
179
180desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} xfreerdp.desktop
181install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
182
e07ea24b
AM
183%clean
184rm -rf $RPM_BUILD_ROOT
185
e07ea24b 186%post
acdabdb6
JB
187%update_icon_cache hicolor
188
189%postun
190%update_icon_cache hicolor
e07ea24b 191
e5316440
ER
192%post libs -p /sbin/ldconfig
193%postun libs -p /sbin/ldconfig
e07ea24b
AM
194
195%files
196%defattr(644,root,root,755)
e2f5e569
AO
197%attr(755,root,root) %{_bindir}/freerdp-shadow-cli
198%if %{with wayland}
199%attr(755,root,root) %{_bindir}/wlfreerdp
200%endif
201%if %{with x11}
e07ea24b 202%attr(755,root,root) %{_bindir}/xfreerdp
e2f5e569
AO
203%endif
204%attr(755,root,root) %{_bindir}/winpr-hash
205%attr(755,root,root) %{_bindir}/winpr-makecert
acdabdb6 206%{_mandir}/man1/xfreerdp.1*
e07ea24b 207%{_desktopdir}/xfreerdp.desktop
acdabdb6
JB
208%{_iconsdir}/hicolor/256x256/apps/freerdp.png
209
e2f5e569 210%if %{with directfb}
acdabdb6
JB
211%files dfb
212%defattr(644,root,root,755)
213%attr(755,root,root) %{_bindir}/dfreerdp
e2f5e569 214%endif
e07ea24b
AM
215
216%files libs
217%defattr(644,root,root,755)
acdabdb6 218%doc ChangeLog README
e2f5e569
AO
219%attr(755,root,root) %{_libdir}/libfreerdp-client.so.*.*.*
220%attr(755,root,root) %ghost %{_libdir}/libfreerdp-client.so.2
221%attr(755,root,root) %{_libdir}/libfreerdp-server.so.*.*.*
222%attr(755,root,root) %ghost %{_libdir}/libfreerdp-server.so.2
223%attr(755,root,root) %{_libdir}/libfreerdp-shadow.so.*.*.*
224%attr(755,root,root) %ghost %{_libdir}/libfreerdp-shadow.so.2
225%attr(755,root,root) %{_libdir}/libfreerdp-shadow-subsystem.so.*.*.*
226%attr(755,root,root) %ghost %{_libdir}/libfreerdp-shadow-subsystem.so.2
227%attr(755,root,root) %{_libdir}/libfreerdp.so.*.*.*
228%attr(755,root,root) %ghost %{_libdir}/libfreerdp.so.2
229%attr(755,root,root) %{_libdir}/libuwac.so.*.*.*
230%attr(755,root,root) %ghost %{_libdir}/libuwac.so.0
231%attr(755,root,root) %{_libdir}/libwinpr.so.*.*.*
232%attr(755,root,root) %ghost %{_libdir}/libwinpr.so.2
233%attr(755,root,root) %{_libdir}/libwinpr-tools.so.*.*.*
234%attr(755,root,root) %ghost %{_libdir}/libwinpr-tools.so.2
acdabdb6
JB
235
236%files devel
237%defattr(644,root,root,755)
e2f5e569
AO
238%attr(755,root,root) %{_libdir}/libfreerdp-client.so
239%attr(755,root,root) %{_libdir}/libfreerdp-server.so
240%attr(755,root,root) %{_libdir}/libfreerdp-shadow.so
241%attr(755,root,root) %{_libdir}/libfreerdp-shadow-subsystem.so
242%attr(755,root,root) %{_libdir}/libfreerdp.so
243%attr(755,root,root) %{_libdir}/libuwac.so
244%attr(755,root,root) %{_libdir}/libwinpr.so
245%attr(755,root,root) %{_libdir}/libwinpr-tools.so
246%{_includedir}/freerdp2
247%{_includedir}/uwac0
248%{_includedir}/winpr2
249%{_pkgconfigdir}/freerdp-client2.pc
250%{_pkgconfigdir}/freerdp-server2.pc
251%{_pkgconfigdir}/freerdp-shadow2.pc
252%{_pkgconfigdir}/freerdp2.pc
253%{_pkgconfigdir}/uwac0.pc
254%{_pkgconfigdir}/winpr-tools2.pc
255%{_pkgconfigdir}/winpr2.pc
This page took 0.292517 seconds and 4 git commands to generate.