]> git.pld-linux.org Git - packages/freerdp.git/blame - freerdp.spec
pldization and fixes
[packages/freerdp.git] / freerdp.spec
CommitLineData
e07ea24b
AM
1Summary: Remote Desktop Protocol client
2Name: freerdp
3Version: 1.0.1
4Release: 0.1
5License: ASL 2.0
6Group: Applications/Communications
7URL: http://www.freerdp.com/
8Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
9# https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
10Patch0: fastpath_send_input_pdu-sec_bytes.patch
e5316440 11Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
e07ea24b
AM
12BuildRequires: cmake
13BuildRequires: cups-devel
14BuildRequires: desktop-file-utils
e07ea24b
AM
15BuildRequires: libXv-devel
16BuildRequires: libxkbfile-devel
17BuildRequires: openssl-devel
18BuildRequires: pcsc-lite-devel
19BuildRequires: pulseaudio-devel
20BuildRequires: xmlto
21BuildRequires: xorg-lib-libX11-devel
e5316440
ER
22BuildRequires: xorg-lib-libXcursor-devel
23BuildRequires: xorg-lib-libXdamage-devel
e07ea24b
AM
24BuildRequires: xorg-lib-libXext-devel
25BuildRequires: xorg-lib-libXinerama-devel
e5316440
ER
26Requires: %{name}-libs = %{version}-%{release}
27Requires: %{name}-plugins = %{version}-%{release}
e07ea24b 28Provides: xfreerdp = %{version}-%{release}
e5316440 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e07ea24b
AM
30
31%description
32The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
33project.
34
35xfreerdp can connect to RDP servers such as Microsoft Windows
36machines, xrdp and VirtualBox.
37
e07ea24b 38%package libs
e5316440
ER
39Summary: Core libraries implementing the RDP protocol
40Group: Applications/Communications
41
e07ea24b
AM
42%description libs
43libfreerdp-core can be embedded in applications.
44
45libfreerdp-channels and libfreerdp-kbd might be convenient to use in X
46applications together with libfreerdp-core.
47
48libfreerdp-core can be extended with plugins handling RDP channels.
49
e07ea24b 50%package plugins
e5316440
ER
51Summary: Plugins for handling the standard RDP channels
52Group: Applications/Communications
53Requires: %{name}-libs = %{version}-%{release}
54
e07ea24b
AM
55%description plugins
56A set of plugins to the channel manager implementing the standard
57virtual channels extending RDP core functionality. For instance,
58sounds, clipboard sync, disk/printer redirection, etc.
59
e07ea24b 60%package devel
e07ea24b 61Summary: Development files for %{name}
e07ea24b 62Group: Development/Libraries
e5316440 63Requires: %{name}-libs = %{version}-%{release}
e07ea24b
AM
64
65%description devel
66The %{name}-devel package contains libraries and header files for
67developing applications that use %{name}-libs.
68
e07ea24b 69%prep
e07ea24b
AM
70%setup -q
71%patch0 -p1
e5316440 72%patch1 -p1
e07ea24b
AM
73
74cat << EOF > xfreerdp.desktop
75[Desktop Entry]
76Type=Application
77Name=X FreeRDP
78NoDisplay=true
79Comment=Connect to RDP server and display remote desktop
80Icon=%{name}
81Exec=%{_bindir}/xfreerdp
82Terminal=false
83Categories=Network;RemoteAccess;
84EOF
85
e07ea24b 86%build
e5316440
ER
87install -d build
88cd build
e07ea24b 89%cmake \
e5316440
ER
90 -DWITH_CUPS=ON \
91 -DWITH_PCSC=ON \
92 -DWITH_PULSEAUDIO=ON \
93 -DWITH_X11=ON \
94 -DWITH_XCURSOR=ON \
95 -DWITH_XEXT=ON \
96 -DWITH_XINERAMA=ON \
97 -DWITH_XKBFILE=ON \
98 -DWITH_XV=ON \
99 -DWITH_ALSA=OFF \
100 -DWITH_CUNIT=OFF \
101 -DWITH_DIRECTFB=OFF \
102 -DWITH_FFMPEG=OFF \
103 -DWITH_SSE2=OFF \
104 -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
105 ..
106
107%{__make}
e07ea24b
AM
108
109%install
110rm -rf $RPM_BUILD_ROOT
e5316440
ER
111%{__make} install \
112 INSTALL="install -p" \
113 DESTDIR=$RPM_BUILD_ROOT
e07ea24b
AM
114
115# No need for keymap files when using xkbfile
e5316440 116%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/freerdp
e07ea24b
AM
117
118desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} xfreerdp.desktop
119install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
120
e07ea24b
AM
121%clean
122rm -rf $RPM_BUILD_ROOT
123
e07ea24b
AM
124%post
125# This is no gtk application, but try to integrate nicely with GNOME if it is available
126gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
127
e5316440
ER
128%post libs -p /sbin/ldconfig
129%postun libs -p /sbin/ldconfig
e07ea24b
AM
130
131%files
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_bindir}/xfreerdp
134%{_mandir}/man1/xfreerdp.*
135%{_desktopdir}/xfreerdp.desktop
136%{_iconsdir}/hicolor/256x256/apps/%{name}.png
137
138%files libs
139%defattr(644,root,root,755)
140%doc LICENSE README ChangeLog
141%{_libdir}/lib%{name}-*.so.*
142%dir %{_libdir}/%{name}/
143
144%files plugins
145%defattr(644,root,root,755)
146%{_libdir}/%{name}/*
147
148%files devel
149%defattr(644,root,root,755)
150%{_includedir}/%{name}/
151%{_libdir}/lib%{name}-*.so
152%{_pkgconfigdir}/%{name}.pc
This page took 0.080286 seconds and 4 git commands to generate.