]> git.pld-linux.org Git - packages/freerdp.git/blame - freerdp.spec
add pcsc bcond (currently build broken), builds now
[packages/freerdp.git] / freerdp.spec
CommitLineData
dd410870
ER
1# Conditional build:
2#
3%bcond_with pcsc # SmartCard support via PCSC-lite library
4
e07ea24b
AM
5Summary: Remote Desktop Protocol client
6Name: freerdp
7Version: 1.0.1
8Release: 0.1
9License: ASL 2.0
10Group: Applications/Communications
11URL: http://www.freerdp.com/
12Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
e07ea24b
AM
13BuildRequires: cmake
14BuildRequires: cups-devel
15BuildRequires: desktop-file-utils
e07ea24b 16BuildRequires: openssl-devel
dd410870 17%{?with_pcsc:BuildRequires: pcsc-lite-devel}
e07ea24b
AM
18BuildRequires: pulseaudio-devel
19BuildRequires: xmlto
20BuildRequires: xorg-lib-libX11-devel
e5316440
ER
21BuildRequires: xorg-lib-libXcursor-devel
22BuildRequires: xorg-lib-libXdamage-devel
e07ea24b
AM
23BuildRequires: xorg-lib-libXext-devel
24BuildRequires: xorg-lib-libXinerama-devel
7d17d2a0
ER
25BuildRequires: xorg-lib-libXv-devel
26BuildRequires: xorg-lib-libxkbfile
e5316440
ER
27Requires: %{name}-libs = %{version}-%{release}
28Requires: %{name}-plugins = %{version}-%{release}
e07ea24b 29Provides: xfreerdp = %{version}-%{release}
e5316440 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e07ea24b
AM
31
32%description
33The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
34project.
35
36xfreerdp can connect to RDP servers such as Microsoft Windows
37machines, xrdp and VirtualBox.
38
dd410870 39%package libs
e5316440
ER
40Summary: Core libraries implementing the RDP protocol
41Group: Applications/Communications
42
e07ea24b
AM
43%description libs
44libfreerdp-core can be embedded in applications.
45
46libfreerdp-channels and libfreerdp-kbd might be convenient to use in X
47applications together with libfreerdp-core.
48
49libfreerdp-core can be extended with plugins handling RDP channels.
50
dd410870 51%package plugins
e5316440
ER
52Summary: Plugins for handling the standard RDP channels
53Group: Applications/Communications
54Requires: %{name}-libs = %{version}-%{release}
55
e07ea24b
AM
56%description plugins
57A set of plugins to the channel manager implementing the standard
58virtual channels extending RDP core functionality. For instance,
59sounds, clipboard sync, disk/printer redirection, etc.
60
dd410870 61%package devel
e07ea24b 62Summary: Development files for %{name}
e07ea24b 63Group: Development/Libraries
e5316440 64Requires: %{name}-libs = %{version}-%{release}
e07ea24b
AM
65
66%description devel
67The %{name}-devel package contains libraries and header files for
68developing applications that use %{name}-libs.
69
e07ea24b 70%prep
e07ea24b 71%setup -q
e07ea24b
AM
72
73cat << EOF > xfreerdp.desktop
74[Desktop Entry]
75Type=Application
76Name=X FreeRDP
77NoDisplay=true
78Comment=Connect to RDP server and display remote desktop
79Icon=%{name}
80Exec=%{_bindir}/xfreerdp
81Terminal=false
82Categories=Network;RemoteAccess;
83EOF
84
e07ea24b 85%build
e5316440
ER
86install -d build
87cd build
e07ea24b 88%cmake \
e5316440 89 -DWITH_CUPS=ON \
dd410870 90 %{?with_pcsc:-DWITH_PCSC=ON} \
e5316440
ER
91 -DWITH_PULSEAUDIO=ON \
92 -DWITH_X11=ON \
93 -DWITH_XCURSOR=ON \
94 -DWITH_XEXT=ON \
95 -DWITH_XINERAMA=ON \
96 -DWITH_XKBFILE=ON \
97 -DWITH_XV=ON \
98 -DWITH_ALSA=OFF \
99 -DWITH_CUNIT=OFF \
100 -DWITH_DIRECTFB=OFF \
101 -DWITH_FFMPEG=OFF \
102 -DWITH_SSE2=OFF \
103 -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
104 ..
105
106%{__make}
e07ea24b
AM
107
108%install
109rm -rf $RPM_BUILD_ROOT
dd410870 110%{__make} -C build install \
e5316440
ER
111 INSTALL="install -p" \
112 DESTDIR=$RPM_BUILD_ROOT
e07ea24b
AM
113
114# No need for keymap files when using xkbfile
e5316440 115%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/freerdp
e07ea24b
AM
116
117desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} xfreerdp.desktop
118install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
119
e07ea24b
AM
120%clean
121rm -rf $RPM_BUILD_ROOT
122
e07ea24b
AM
123%post
124# This is no gtk application, but try to integrate nicely with GNOME if it is available
125gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
126
e5316440
ER
127%post libs -p /sbin/ldconfig
128%postun libs -p /sbin/ldconfig
e07ea24b
AM
129
130%files
131%defattr(644,root,root,755)
132%attr(755,root,root) %{_bindir}/xfreerdp
133%{_mandir}/man1/xfreerdp.*
134%{_desktopdir}/xfreerdp.desktop
135%{_iconsdir}/hicolor/256x256/apps/%{name}.png
136
137%files libs
138%defattr(644,root,root,755)
139%doc LICENSE README ChangeLog
140%{_libdir}/lib%{name}-*.so.*
141%dir %{_libdir}/%{name}/
142
143%files plugins
144%defattr(644,root,root,755)
145%{_libdir}/%{name}/*
146
147%files devel
148%defattr(644,root,root,755)
149%{_includedir}/%{name}/
150%{_libdir}/lib%{name}-*.so
151%{_pkgconfigdir}/%{name}.pc
This page took 0.237952 seconds and 4 git commands to generate.