]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- removed two lines with define
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.0.28
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        ftp://ftp.fox-toolkit.org/pub/%{name}-%{version}.tar.gz
9 URL:            http://www.cfdrc.com/FOX/fox.html
10 BuildRequires:  OpenGL-devel
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  libstdc++-devel
15 Requires:       OpenGL
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
19
20 %description
21 FOX is a C++-Based Library for Graphical User Interface Development
22 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
23 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
24 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
25 graphics. Subclassing of basic FOX widgets allows for easy extension
26 beyond the built-in widgets by application writers.
27
28 %description -l pl
29 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
30 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
31 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
32 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
33 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
34 rozszerzanie.
35
36 %package progs
37 Summary:        FOX example applications
38 Summary(pl):    Przyk³ady aplikacji w FOX
39 Group:          X11/Applications
40 Requires:       %{name} = %{version}
41 Obsoletes:      %{name}-example-apps
42
43 %description progs
44 Editor and file browser, written with FOX.
45
46 %description progs -l pl
47 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
48
49 %package devel
50 Summary:        Header files and development documentation for the FOX library
51 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
52 Group:          X11/Development/Libraries
53 Requires:       %{name} = %{version}
54
55 %description devel
56 Header files and development documentation for the FOX library.
57
58 %description devel -l pl
59 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
60
61 %package static
62 Summary:        FOX static libraries
63 Summary(pl):    Biblioteki statyczne FOX
64 Group:          X11/Development/Libraries
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 FOX static libraries.
69
70 %description static -l pl
71 Biblioteki statyczne FOX.
72
73 %prep
74 %setup -q
75
76 %build
77 rm -f missing
78 libtoolize -c -f
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 CPPFLAGS="%{rpmcflags} -frtti" \
83 #CFLAGS="%{rpmcflags} -frtti" \
84 %configure \
85         --with-opengl=mesa \
86         --enable-release
87 %{__make} GL_LIBS="-lGL -lGLU"
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT/%{_datadir}
92
93 %{__make} install DESTDIR=$RPM_BUILD_ROOT
94
95 cp -p pathfinder/.libs/PathFinder $RPM_BUILD_ROOT%{_bindir}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*
106
107 %files progs
108 %defattr(644,root,root,755)
109 %attr(755,root,root) /%{_bindir}/adie
110 %attr(755,root,root) /%{_bindir}/calculator
111 %attr(755,root,root) /%{_bindir}/PathFinder
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc ADDITIONS AUTHORS README TRACING doc
116 %attr(755,root,root) %{_bindir}/reswrap
117 %attr(755,root,root) %{_libdir}/lib*.so
118 %{_libdir}/lib*.la
119 %{_mandir}/man1/*
120 %{_includedir}/fox
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/lib*.a
This page took 0.085944 seconds and 4 git commands to generate.