]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
Release 2 (by relup.sh)
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # CUPS support
4 %bcond_without  openjpeg        # JPEG2000 support
5 %bcond_without  static_libs     # don't build static libraries
6 #
7 Summary:        The FOX C++ GUI Toolkit
8 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
9 Name:           fox
10 # NOTE: after switching to 1.8.x keep stable (1.8.x) on HEAD and devel (1.9.x) on DEVEL
11 Version:        1.7.84
12 Release:        2
13 License:        LGPL v3+ with relinking exemption
14 Group:          X11/Libraries
15 Source0:        http://fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
16 # Source0-md5:  48eaf928985a52be0ef628f51fb5599f
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-link.patch
19 Patch2:         %{name}-Makefile.patch
20 Patch3:         x32.patch
21 URL:            http://www.fox-toolkit.org/
22 BuildRequires:  OpenGL-GLU-devel
23 BuildRequires:  autoconf >= 2.59-9
24 BuildRequires:  automake
25 BuildRequires:  bzip2-devel >= 1.0.2
26 %{?with_cups:BuildRequires:     cups-devel}
27 BuildRequires:  doxygen
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libpng-devel >= 1.2.5
30 BuildRequires:  libstdc++-devel
31 BuildRequires:  libtiff-devel >= 3.5.7
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  libwebp-devel
34 %{?with_openjpeg:BuildRequires: openjpeg-devel}
35 BuildRequires:  pkgconfig
36 BuildRequires:  xorg-lib-libXcursor-devel
37 BuildRequires:  xorg-lib-libXext-devel
38 BuildRequires:  xorg-lib-libXft-devel
39 BuildRequires:  xorg-lib-libXi-devel
40 BuildRequires:  xorg-lib-libXrandr-devel
41 BuildRequires:  zlib-devel >= 1.1.4
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 FOX is a C++-Based Library for Graphical User Interface Development
46 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
47 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
48 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
49 graphics. Subclassing of basic FOX widgets allows for easy extension
50 beyond the built-in widgets by application writers.
51
52 %description -l pl.UTF-8
53 FOX jest biblioteką bazującą na C++ do projektowania graficznych
54 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
55 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
56 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
57 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
58 rozszerzanie.
59
60 %package progs
61 Summary:        FOX example applications
62 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
63 Group:          X11/Applications
64 Requires:       %{name} = %{version}-%{release}
65 Obsoletes:      fox-example-apps < 0.99.173
66
67 %description progs
68 Editor and file browser, written with FOX.
69
70 %description progs -l pl.UTF-8
71 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
72
73 %package devel
74 Summary:        Header files for FOX library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       OpenGL-GLU-devel
79 Requires:       bzip2-devel >= 1.0.2
80 Requires:       cups-devel
81 Requires:       libjpeg-devel >= 6b
82 Requires:       libpng-devel >= 1.2.5
83 Requires:       libstdc++-devel
84 Requires:       libtiff-devel >= 3.5.7
85 Requires:       libwebp-devel
86 %{?with_openjpeg:Requires:      openjpeg-devel}
87 Requires:       xorg-lib-libXcursor-devel
88 Requires:       xorg-lib-libXext-devel
89 Requires:       xorg-lib-libXft-devel
90 Requires:       xorg-lib-libXi-devel
91 Requires:       xorg-lib-libXrandr-devel
92 Requires:       zlib-devel >= 1.1.4
93
94 %description devel
95 Header files for FOX library.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe biblioteki FOX.
99
100 %package static
101 Summary:        FOX static libraries
102 Summary(pl.UTF-8):      Biblioteki statyczne FOX
103 Group:          X11/Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105
106 %description static
107 FOX static libraries.
108
109 %description static -l pl.UTF-8
110 Biblioteki statyczne FOX.
111
112 %package doc
113 Summary:        Development documentation for FOX library
114 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
115 Group:          X11/Development/Libraries
116
117 %description doc
118 Development documentation for FOX library.
119
120 %description doc -l pl.UTF-8
121 Dokumentacja programisty do biblioteki FOX.
122
123 %package examples
124 Summary:        FOX - example programs
125 Summary(pl.UTF-8):      FOX - programy przykładowe
126 Group:          X11/Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128
129 %description examples
130 FOX - example programs.
131
132 %description examples -l pl.UTF-8
133 FOX - przykładowe programy.
134
135 %prep
136 %setup -q
137 %patch0 -p1
138 %patch1 -p1
139 %patch2 -p1
140 %patch3 -p1
141
142 %build
143 %{__libtoolize}
144 %{__aclocal}
145 %{__autoconf}
146 %{__automake}
147 %configure \
148         %{?with_cups:--enable-cups} \
149         %{?debug:--enable-debug}%{!?debug:--enable-release} \
150         %{?with_openjpeg:--enable-jp2} \
151         --enable-static%{!?with_static_libs:=no} \
152         --enable-webp \
153         --with-opengl \
154         --with-shape \
155         --with-xcursor \
156         --with-xft \
157         --with-xim \
158         --with-xrandr \
159         --with-xshm
160
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
171
172 %{__make} -C tests clean
173 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
174
175 %{__rm} doc/Makefile* doc/*/Makefile*
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 %doc AUTHORS LICENSE_ADDENDUM README
186 %attr(755,root,root) %{_bindir}/ControlPanel
187 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
189 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
191 %{_mandir}/man1/ControlPanel.1*
192
193 %files progs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/Adie.stx
196 %attr(755,root,root) %{_bindir}/PathFinder
197 %attr(755,root,root) %{_bindir}/adie
198 %attr(755,root,root) %{_bindir}/calculator
199 %attr(755,root,root) %{_bindir}/shutterbug
200 %{_mandir}/man1/PathFinder.1*
201 %{_mandir}/man1/adie.1*
202 %{_mandir}/man1/calculator.1*
203 %{_mandir}/man1/shutterbug.1*
204
205 %files devel
206 %defattr(644,root,root,755)
207 %doc ADDITIONS TRACING
208 %attr(755,root,root) %{_bindir}/fox-config
209 %attr(755,root,root) %{_bindir}/reswrap
210 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
211 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
212 %attr(755,root,root) %{_libdir}/libFOX.so
213 %{_libdir}/libCHART-1.7.la
214 %{_libdir}/libFOX-1.7.la
215 %{_includedir}/fox-1.7
216 %{_pkgconfigdir}/fox17.pc
217 %{_mandir}/man1/reswrap.1*
218
219 %if %{with static_libs}
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/libCHART-1.7.a
223 %{_libdir}/libFOX-1.7.a
224 %endif
225
226 %files doc
227 %defattr(644,root,root,755)
228 %doc doc/*
229
230 %files examples
231 %defattr(644,root,root,755)
232 %{_examplesdir}/%{name}-%{version}
This page took 0.124134 seconds and 4 git commands to generate.