]> git.pld-linux.org Git - packages/fetch-crl.git/commitdiff
- avoid modifying element in hash
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 11 Jun 2011 08:36:23 +0000 (08:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fetch-crl.spec -> 1.2
    no-modify-template.patch -> 1.1

fetch-crl.spec
no-modify-template.patch [new file with mode: 0644]

index ac40d1e893847282be91b7d89ef11077239f0f1b..9fa940de2a1cf8388b373bf545d0317ec50c0db8 100644 (file)
@@ -10,6 +10,7 @@ Group:                Applications/System
 URL:           http://www.nikhef.nl/grid/gridwiki/index.php/FetchCRL3
 Source0:       https://dist.eugridpma.info/distribution/util/fetch-crl3/%{name}-%{version}.tar.gz
 # Source0-md5: b58f10fb76bab3a34fd4d80541956ef3
 URL:           http://www.nikhef.nl/grid/gridwiki/index.php/FetchCRL3
 Source0:       https://dist.eugridpma.info/distribution/util/fetch-crl3/%{name}-%{version}.tar.gz
 # Source0-md5: b58f10fb76bab3a34fd4d80541956ef3
+Patch0:                no-modify-template.patch
 BuildRequires: rpm-perlprov >= 4.1-13
 Requires:      openssl
 Obsoletes:     fetch-crl3
 BuildRequires: rpm-perlprov >= 4.1-13
 Requires:      openssl
 Obsoletes:     fetch-crl3
@@ -40,6 +41,8 @@ files follow the hash.crl_url convention.
 
 %prep
 %setup -q
 
 %prep
 %setup -q
+%patch0 -p1
+
 # use this to figure out deps
 #sed -i -e 's,\ 1,BLAAA,' %{name}
 
 # use this to figure out deps
 #sed -i -e 's,\ 1,BLAAA,' %{name}
 
diff --git a/no-modify-template.patch b/no-modify-template.patch
new file mode 100644 (file)
index 0000000..7033efe
--- /dev/null
@@ -0,0 +1,33 @@
+with Perl 5.12.3 we changed $self->{"nametemplate_pem"} via $file modification
+
+with such config:
+nametemplate_pem = @ALIAS@.r@R@.pem
+infodir = /etc/pki/esteid
+cadir = /etc/pki/esteid
+output = /etc/pki/esteid/crl
+formats = openssl, pem
+
+it tried to:
+VERBOSE(3) Writing PEM file /etc/pki/esteid/crl//etc/pki/esteid/crl/ESTEID-SK_2007.r0.pem
+should had been:
+VERBOSE(3) Writing PEM file /etc/pki/esteid/crl/ESTEID-SK_2007.r0.pem
+
+--- fetch-crl-3.0.6/fetch-crl  2011-03-20 05:01:20.000000000 +0200
++++ fetch-crl-3.0.6/fetch-crl  2011-06-11 11:30:58.731040625 +0300
+@@ -1873,13 +1879,14 @@
+            $::cnf->{_}->{"output_der"}, $::cnf->{_}->{"output_pem"},
+            $::cnf->{_}->{"output_nss"}, $::cnf->{_}->{"output_openssl"}) ) {
+         defined $output and $output or next;
+-        foreach my $file (
++        foreach my $ref (
+               $self->{"nametemplate_der"},
+               $self->{"nametemplate_pem"},
+               $self->{"alias"}.".r\@R\@",
+               $self->{"anchorname"}.".r\@R\@",
+             ) {
+-          next unless $file;
++          next unless $ref;
++          my $file = $ref; # copy, not to change original
+           $file =~ s/\@R\@/$i/g;
+           $file = join "/", $output, $file;
+           next if ! -e $file;
This page took 0.084169 seconds and 4 git commands to generate.