]> git.pld-linux.org Git - packages/fetch-crl.git/blame - fetch-crl.spec
- avoid modifying element in hash
[packages/fetch-crl.git] / fetch-crl.spec
CommitLineData
5b41b6a6
ER
1# TODO
2# - pldize initscript
3%include /usr/lib/rpm/macros.perl
4Summary: Downloads Certificate Revocation Lists
5Name: fetch-crl
6Version: 3.0.6
7Release: 1
8License: ASL 2.0
9Group: Applications/System
10URL: http://www.nikhef.nl/grid/gridwiki/index.php/FetchCRL3
11Source0: https://dist.eugridpma.info/distribution/util/fetch-crl3/%{name}-%{version}.tar.gz
12# Source0-md5: b58f10fb76bab3a34fd4d80541956ef3
6051a581 13Patch0: no-modify-template.patch
5b41b6a6
ER
14BuildRequires: rpm-perlprov >= 4.1-13
15Requires: openssl
16Obsoletes: fetch-crl3
17# These requires are only added since file is currently broken so they don't get autogenerated.
18# https://bugzilla.redhat.com/show_bug.cgi?id=699548
19# (file(1) considers file 'data' as it sees ^A inside script)
20Requires: /usr/bin/perl
21Requires: perl(File::Basename)
22Requires: perl(File::Temp)
23Requires: perl(Getopt::Long)
24Requires: perl(IO::Select)
25Requires: perl(IPC::Open3)
26Requires: perl(LWP)
27Requires: perl(POSIX)
28Requires: perl(Sys::Syslog)
29Requires: perl(Time::Local)
30Requires: perl(integer)
31Requires: perl(strict)
32Requires: perl(vars)
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37This tool and associated cron entry ensure that Certificate Revocation
38Lists (CRLs) are periodically retrieved from the web sites of the
39respective Certification Authorities. It assumes that the installed CA
40files follow the hash.crl_url convention.
41
42%prep
43%setup -q
6051a581
ER
44%patch0 -p1
45
5b41b6a6
ER
46# use this to figure out deps
47#sed -i -e 's,\ 1,BLAAA,' %{name}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}.d,/etc/{cron.d,rc.d/init.d}}
52%{__make} install \
53 PREFIX=$RPM_BUILD_ROOT%{_usr} \
54 ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
55 CACHE=$RPM_BUILD_ROOT%{_var}/cache
56
57install -p fetch-crl-cron.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-cron
58install -p fetch-crl-boot.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-boot
59cp -p fetch-crl-cron.cron $RPM_BUILD_ROOT/etc/cron.d/%{name}
60
61# Remove some files that have been duplicated as docs.
62rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68/sbin/chkconfig --add %{name}-cron
69/sbin/chkconfig --add %{name}-boot
70
71%preun
72if [ $1 = 0 ]; then
73 %service %{name}-cron stop
74 %service %{name}-boot stop
75 /sbin/chkconfig --del %{name}-cron
76 /sbin/chkconfig --del %{name}-boot
77fi
78
79%files
80%defattr(644,root,root,755)
81%doc CHANGES NOTICE README fetch-crl.cnf.example
82%dir %{_sysconfdir}/%{name}.d
83%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
84%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
85%attr(755,root,root) %{_sbindir}/%{name}
86%attr(754,root,root) /etc/rc.d/init.d/fetch-crl-boot
87%attr(754,root,root) /etc/rc.d/init.d/fetch-crl-cron
88%{_mandir}/man8/%{name}.8*
89%dir %{_var}/cache/%{name}
This page took 0.078673 seconds and 4 git commands to generate.