]> git.pld-linux.org Git - packages/fetch-crl.git/blob - fetch-crl.spec
- avoid modifying element in hash
[packages/fetch-crl.git] / fetch-crl.spec
1 # TODO
2 # - pldize initscript
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Downloads Certificate Revocation Lists
5 Name:           fetch-crl
6 Version:        3.0.6
7 Release:        1
8 License:        ASL 2.0
9 Group:          Applications/System
10 URL:            http://www.nikhef.nl/grid/gridwiki/index.php/FetchCRL3
11 Source0:        https://dist.eugridpma.info/distribution/util/fetch-crl3/%{name}-%{version}.tar.gz
12 # Source0-md5:  b58f10fb76bab3a34fd4d80541956ef3
13 Patch0:         no-modify-template.patch
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 Requires:       openssl
16 Obsoletes:      fetch-crl3
17 # These requires are only added since file is currently broken so they don't get autogenerated.
18 # https://bugzilla.redhat.com/show_bug.cgi?id=699548
19 # (file(1) considers file 'data' as it sees ^A inside script)
20 Requires:       /usr/bin/perl
21 Requires:       perl(File::Basename)
22 Requires:       perl(File::Temp)
23 Requires:       perl(Getopt::Long)
24 Requires:       perl(IO::Select)
25 Requires:       perl(IPC::Open3)
26 Requires:       perl(LWP)
27 Requires:       perl(POSIX)
28 Requires:       perl(Sys::Syslog)
29 Requires:       perl(Time::Local)
30 Requires:       perl(integer)
31 Requires:       perl(strict)
32 Requires:       perl(vars)
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This tool and associated cron entry ensure that Certificate Revocation
38 Lists (CRLs) are periodically retrieved from the web sites of the
39 respective Certification Authorities. It assumes that the installed CA
40 files follow the hash.crl_url convention.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 # use this to figure out deps
47 #sed -i -e 's,\ 1,BLAAA,' %{name}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}.d,/etc/{cron.d,rc.d/init.d}}
52 %{__make} install \
53         PREFIX=$RPM_BUILD_ROOT%{_usr} \
54         ETC=$RPM_BUILD_ROOT%{_sysconfdir} \
55         CACHE=$RPM_BUILD_ROOT%{_var}/cache
56
57 install -p fetch-crl-cron.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-cron
58 install -p fetch-crl-boot.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-boot
59 cp -p fetch-crl-cron.cron $RPM_BUILD_ROOT/etc/cron.d/%{name}
60
61 # Remove some files that have been duplicated as docs.
62 rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 /sbin/chkconfig --add %{name}-cron
69 /sbin/chkconfig --add %{name}-boot
70
71 %preun
72 if [ $1 = 0 ]; then
73         %service %{name}-cron stop
74         %service %{name}-boot stop
75         /sbin/chkconfig --del %{name}-cron
76         /sbin/chkconfig --del %{name}-boot
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CHANGES NOTICE README fetch-crl.cnf.example
82 %dir %{_sysconfdir}/%{name}.d
83 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
84 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
85 %attr(755,root,root) %{_sbindir}/%{name}
86 %attr(754,root,root) /etc/rc.d/init.d/fetch-crl-boot
87 %attr(754,root,root) /etc/rc.d/init.d/fetch-crl-cron
88 %{_mandir}/man8/%{name}.8*
89 %dir %{_var}/cache/%{name}
This page took 0.059503 seconds and 3 git commands to generate.