]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
boost rebuild
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.19.1
11 Release:        9
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  5af573e26b1fc7cb57ef5efc5dd88801
17 Patch0:         lib.patch
18 Patch1:         qt-5.15.patch
19 Patch2:         %{name}-includes.patch
20 Patch3:         %{name}-univalue.patch
21 Patch4:         missing-includes.patch
22 URL:            https://www.feathercoin.com/
23 %if %{with gui}
24 BuildRequires:  Qt5Core-devel >= 5
25 BuildRequires:  Qt5DBus-devel >= 5
26 BuildRequires:  Qt5Gui-devel >= 5
27 BuildRequires:  Qt5Network-devel >= 5
28 BuildRequires:  Qt5PrintSupport-devel >= 5
29 BuildRequires:  Qt5Test-devel >= 5
30 BuildRequires:  Qt5Widgets-devel >= 5
31 %endif
32 BuildRequires:  autoconf >= 2.69
33 BuildRequires:  automake
34 BuildRequires:  boost-devel >= 1.47.0
35 %{?with_ccache:BuildRequires:   ccache}
36 BuildRequires:  db-cxx-devel >= 4.8
37 BuildRequires:  gettext-tools
38 BuildRequires:  libevent-devel
39 %{?with_gui:BuildRequires:      libpng-devel}
40 BuildRequires:  libsecp256k1-devel >= 0.1.0.15
41 BuildRequires:  libstdc++-devel >= 6:4.7
42 BuildRequires:  libtool >= 2:2
43 BuildRequires:  libunivalue-devel >= 1.0.4
44 BuildRequires:  miniupnpc-devel >= 1.5
45 BuildRequires:  openssl-devel
46 BuildRequires:  pkgconfig
47 BuildRequires:  protobuf-devel
48 BuildRequires:  python3 >= 1:3.5
49 BuildRequires:  qrencode-devel
50 %{?with_gui:BuildRequires:      qt5-build >= 5}
51 BuildRequires:  zeromq-devel >= 4
52 %{?with_gui:BuildRequires:      zlib-devel}
53 BuildRequires:  zxing-cpp-devel
54 Requires:       libsecp256k1 >= 0.1.0.15
55 Requires:       libunivalue >= 1.0.4
56 Requires:       perl-base
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 # uses nNeoScryptOptions symbol from binaries
60 %define         skip_post_check_so      libbitcoinconsensus.so.*
61
62 %description
63 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
64 central authority issues new money or tracks transactions. These tasks
65 are managed collectively by the network.
66
67 %description -l pl.UTF-8
68 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
69 centralnego urzędu, który emituje nowe pieniądze czy śledzi
70 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
71
72 %package devel
73 Summary:        Header file for bitcoinconsensus library
74 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       openssl-devel
78 Conflicts:      bitcoin-devel
79
80 %description devel
81 Header file for bitcoinconsensus library.
82
83 %description devel -l pl.UTF-8
84 Plik nagłówkowy biblioteki bitcoinconsensus.
85
86 %package static
87 Summary:        Static bitcoinconsensus library
88 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Conflicts:      bitcoin-static
92
93 %description static
94 Static bitcoinconsensus library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka bitcoinconsensus.
98
99 %package qt
100 Summary:        Qt-based Feathercoin Wallet
101 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
102 Group:          X11/Applications
103
104 %description qt
105 Qt-based Feathercoin Wallet.
106
107 %description qt -l pl.UTF-8
108 Oparty na Qt portfel Feathercoin.
109
110 %prep
111 %setup -q -n Feathercoin-%{version}
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115 %patch3 -p1
116 %patch4 -p1
117
118 %build
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
125 %configure \
126         --disable-bench \
127         --enable-bip70 \
128         --enable-ccache%{!?with_ccache:=no} \
129         --disable-gui-tests \
130         --disable-silent-rules \
131         --disable-tests \
132         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
133         --with-incompatible-bdb \
134         --with-system-univalue
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # obsoleted by pkg-config
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
146
147 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
148 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
149 [Desktop Entry]
150 Encoding=UTF-8
151 Name=Feathercoin
152 Comment=Feathercoin P2P Cryptocurrency
153 Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
154 Comment[pl]=Feathercoin - kryptowaluta P2P
155 Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
156 Exec=feathercoin-qt %u
157 Terminal=false
158 Type=Application
159 Icon=bitcoin128
160 MimeType=x-scheme-handler/feathercoin;
161 Categories=Office;Finance;
162 EOF
163
164 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
165 [Protocol]
166 exec=feathercoin-qt '%u'
167 protocol=feathercoin
168 input=none
169 output=none
170 helper=true
171 listing=
172 reading=false
173 writing=false
174 makedir=false
175 deleting=false
176 EOF
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %doc COPYING README.md doc/*.txt
187 %attr(755,root,root) %{_bindir}/feathercoin-cli
188 %attr(755,root,root) %{_bindir}/feathercoin-tx
189 %attr(755,root,root) %{_bindir}/feathercoin-wallet
190 %attr(755,root,root) %{_bindir}/feathercoind
191 %{_mandir}/man1/feathercoin-cli.1*
192 %{_mandir}/man1/feathercoin-tx.1*
193 %{_mandir}/man1/feathercoin-wallet.1*
194 %{_mandir}/man1/feathercoind.1*
195 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
201 %{_includedir}/bitcoinconsensus.h
202 %{_pkgconfigdir}/libbitcoinconsensus.pc
203
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libbitcoinconsensus.a
207
208 %files qt
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/feathercoin-qt
211 %{_datadir}/kde4/services/feathercoin-qt.protocol
212 %{_desktopdir}/feathercoin-qt.desktop
213 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.07509 seconds and 4 git commands to generate.