]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
boost rebuild
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
27aee4eb 10Version: 0.19.1
ff12e1c3 11Release: 9
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
27aee4eb 16# Source0-md5: 5af573e26b1fc7cb57ef5efc5dd88801
d27150c9 17Patch0: lib.patch
4e6b795e 18Patch1: qt-5.15.patch
36f7f9aa 19Patch2: %{name}-includes.patch
27aee4eb 20Patch3: %{name}-univalue.patch
ff10876d 21Patch4: missing-includes.patch
24d61d02 22URL: https://www.feathercoin.com/
d71863a9
JB
23%if %{with gui}
24BuildRequires: Qt5Core-devel >= 5
25BuildRequires: Qt5DBus-devel >= 5
26BuildRequires: Qt5Gui-devel >= 5
27BuildRequires: Qt5Network-devel >= 5
28BuildRequires: Qt5PrintSupport-devel >= 5
29BuildRequires: Qt5Test-devel >= 5
30BuildRequires: Qt5Widgets-devel >= 5
31%endif
32BuildRequires: autoconf >= 2.69
33BuildRequires: automake
d5d03ba6 34BuildRequires: boost-devel >= 1.47.0
d71863a9
JB
35%{?with_ccache:BuildRequires: ccache}
36BuildRequires: db-cxx-devel >= 4.8
37BuildRequires: gettext-tools
27aee4eb 38BuildRequires: libevent-devel
d71863a9 39%{?with_gui:BuildRequires: libpng-devel}
27aee4eb
JB
40BuildRequires: libsecp256k1-devel >= 0.1.0.15
41BuildRequires: libstdc++-devel >= 6:4.7
d5d03ba6
JB
42BuildRequires: libtool >= 2:2
43BuildRequires: libunivalue-devel >= 1.0.4
0f77417f
AM
44BuildRequires: miniupnpc-devel >= 1.5
45BuildRequires: openssl-devel
d71863a9
JB
46BuildRequires: pkgconfig
47BuildRequires: protobuf-devel
27aee4eb 48BuildRequires: python3 >= 1:3.5
0f77417f 49BuildRequires: qrencode-devel
d71863a9 50%{?with_gui:BuildRequires: qt5-build >= 5}
d5d03ba6 51BuildRequires: zeromq-devel >= 4
d71863a9 52%{?with_gui:BuildRequires: zlib-devel}
d27150c9 53BuildRequires: zxing-cpp-devel
27aee4eb 54Requires: libsecp256k1 >= 0.1.0.15
d5d03ba6 55Requires: libunivalue >= 1.0.4
0f77417f
AM
56Requires: perl-base
57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
d5d03ba6
JB
59# uses nNeoScryptOptions symbol from binaries
60%define skip_post_check_so libbitcoinconsensus.so.*
61
0f77417f 62%description
24d61d02
JB
63Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
64central authority issues new money or tracks transactions. These tasks
65are managed collectively by the network.
66
67%description -l pl.UTF-8
68Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
69centralnego urzędu, który emituje nowe pieniądze czy śledzi
70transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f 71
f6a6bc9a
JB
72%package devel
73Summary: Header file for bitcoinconsensus library
74Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77Requires: openssl-devel
78Conflicts: bitcoin-devel
79
80%description devel
81Header file for bitcoinconsensus library.
82
83%description devel -l pl.UTF-8
84Plik nagłówkowy biblioteki bitcoinconsensus.
85
86%package static
87Summary: Static bitcoinconsensus library
88Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
89Group: Development/Libraries
90Requires: %{name}-devel = %{version}-%{release}
91Conflicts: bitcoin-static
92
93%description static
94Static bitcoinconsensus library.
95
96%description static -l pl.UTF-8
97Statyczna biblioteka bitcoinconsensus.
98
0f77417f
AM
99%package qt
100Summary: Qt-based Feathercoin Wallet
24d61d02 101Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
102Group: X11/Applications
103
104%description qt
105Qt-based Feathercoin Wallet.
106
24d61d02
JB
107%description qt -l pl.UTF-8
108Oparty na Qt portfel Feathercoin.
109
0f77417f 110%prep
d71863a9
JB
111%setup -q -n Feathercoin-%{version}
112%patch0 -p1
4e6b795e 113%patch1 -p1
36f7f9aa 114%patch2 -p1
27aee4eb 115%patch3 -p1
ff10876d 116%patch4 -p1
0f77417f
AM
117
118%build
d27150c9
AM
119%{__libtoolize}
120%{__aclocal}
d71863a9
JB
121%{__autoconf}
122%{__autoheader}
123%{__automake}
124# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
125%configure \
27aee4eb
JB
126 --disable-bench \
127 --enable-bip70 \
d71863a9 128 --enable-ccache%{!?with_ccache:=no} \
27aee4eb 129 --disable-gui-tests \
d71863a9 130 --disable-silent-rules \
27aee4eb 131 --disable-tests \
d27150c9 132 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
f6a6bc9a 133 --with-incompatible-bdb \
d27150c9 134 --with-system-univalue
0f77417f
AM
135
136%{__make}
137
0f77417f
AM
138%install
139rm -rf $RPM_BUILD_ROOT
0f77417f 140
d71863a9
JB
141%{__make} install \
142 DESTDIR=$RPM_BUILD_ROOT
0f77417f 143
f6a6bc9a
JB
144# obsoleted by pkg-config
145%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
146
147install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
d5d03ba6
JB
148cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
149[Desktop Entry]
150Encoding=UTF-8
151Name=Feathercoin
152Comment=Feathercoin P2P Cryptocurrency
153Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
154Comment[pl]=Feathercoin - kryptowaluta P2P
155Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
156Exec=feathercoin-qt %u
157Terminal=false
158Type=Application
159Icon=bitcoin128
160MimeType=x-scheme-handler/feathercoin;
161Categories=Office;Finance;
162EOF
163
164cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
165[Protocol]
166exec=feathercoin-qt '%u'
167protocol=feathercoin
168input=none
169output=none
170helper=true
171listing=
172reading=false
173writing=false
174makedir=false
175deleting=false
176EOF
0f77417f
AM
177
178%clean
179rm -rf $RPM_BUILD_ROOT
180
f6a6bc9a
JB
181%post -p /sbin/ldconfig
182%postun -p /sbin/ldconfig
d27150c9 183
0f77417f
AM
184%files
185%defattr(644,root,root,755)
d5d03ba6 186%doc COPYING README.md doc/*.txt
d71863a9 187%attr(755,root,root) %{_bindir}/feathercoin-cli
d27150c9 188%attr(755,root,root) %{_bindir}/feathercoin-tx
4e6b795e 189%attr(755,root,root) %{_bindir}/feathercoin-wallet
0f77417f 190%attr(755,root,root) %{_bindir}/feathercoind
d71863a9 191%{_mandir}/man1/feathercoin-cli.1*
d27150c9 192%{_mandir}/man1/feathercoin-tx.1*
4e6b795e 193%{_mandir}/man1/feathercoin-wallet.1*
d71863a9 194%{_mandir}/man1/feathercoind.1*
f6a6bc9a 195%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
d27150c9 196%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
f6a6bc9a
JB
197
198%files devel
199%defattr(644,root,root,755)
200%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
201%{_includedir}/bitcoinconsensus.h
202%{_pkgconfigdir}/libbitcoinconsensus.pc
203
204%files static
205%defattr(644,root,root,755)
206%{_libdir}/libbitcoinconsensus.a
0f77417f
AM
207
208%files qt
209%defattr(644,root,root,755)
210%attr(755,root,root) %{_bindir}/feathercoin-qt
211%{_datadir}/kde4/services/feathercoin-qt.protocol
212%{_desktopdir}/feathercoin-qt.desktop
d71863a9 213%{_mandir}/man1/feathercoin-qt.1*
This page took 0.318825 seconds and 4 git commands to generate.