]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
- up to 0.18.3
[packages/feathercoin.git] / feathercoin.spec
1 # NOTE: "portable wallet" wants BDB 4.8
2 #
3 # Conditional build:
4 %bcond_with     ccache  # use ccache for building
5 %bcond_without  gui     # Qt5 GUI
6
7 Summary:        Feathercoin - a peer-to-peer currency
8 Summary(pl.UTF-8):      Feathercoin - waluta peer-to-peer
9 Name:           feathercoin
10 Version:        0.18.3
11 Release:        1
12 License:        MIT
13 Group:          Applications/Networking
14 #Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15 Source0:        https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  e5e3fc683a09ec7c2efc21dda691c402
17 Patch0:         lib.patch
18 Patch1:         qt-5.15.patch
19 URL:            https://www.feathercoin.com/
20 %if %{with gui}
21 BuildRequires:  Qt5Core-devel >= 5
22 BuildRequires:  Qt5DBus-devel >= 5
23 BuildRequires:  Qt5Gui-devel >= 5
24 BuildRequires:  Qt5Network-devel >= 5
25 BuildRequires:  Qt5PrintSupport-devel >= 5
26 BuildRequires:  Qt5Test-devel >= 5
27 BuildRequires:  Qt5Widgets-devel >= 5
28 %endif
29 BuildRequires:  autoconf >= 2.69
30 BuildRequires:  automake
31 BuildRequires:  boost-devel >= 1.47.0
32 %{?with_ccache:BuildRequires:   ccache}
33 BuildRequires:  db-cxx-devel >= 4.8
34 BuildRequires:  gettext-tools
35 %{?with_gui:BuildRequires:      libpng-devel}
36 BuildRequires:  libsecp256k1-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:2
39 BuildRequires:  libunivalue-devel >= 1.0.4
40 BuildRequires:  miniupnpc-devel >= 1.5
41 BuildRequires:  openssl-devel
42 BuildRequires:  pkgconfig
43 BuildRequires:  protobuf-devel
44 BuildRequires:  qrencode-devel
45 %{?with_gui:BuildRequires:      qt5-build >= 5}
46 BuildRequires:  zeromq-devel >= 4
47 %{?with_gui:BuildRequires:      zlib-devel}
48 BuildRequires:  zxing-cpp-devel
49 Requires:       libunivalue >= 1.0.4
50 Requires:       perl-base
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # uses nNeoScryptOptions symbol from binaries
54 %define         skip_post_check_so      libbitcoinconsensus.so.*
55
56 %description
57 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
58 central authority issues new money or tracks transactions. These tasks
59 are managed collectively by the network.
60
61 %description -l pl.UTF-8
62 Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
63 centralnego urzędu, który emituje nowe pieniądze czy śledzi
64 transakcje. Zadania te są obsługiwane zespołowo przez sieć.
65
66 %package devel
67 Summary:        Header file for bitcoinconsensus library
68 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bitcoinconsensus
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       openssl-devel
72 Conflicts:      bitcoin-devel
73
74 %description devel
75 Header file for bitcoinconsensus library.
76
77 %description devel -l pl.UTF-8
78 Plik nagłówkowy biblioteki bitcoinconsensus.
79
80 %package static
81 Summary:        Static bitcoinconsensus library
82 Summary(pl.UTF-8):      Statyczna biblioteka bitcoinconsensus
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Conflicts:      bitcoin-static
86
87 %description static
88 Static bitcoinconsensus library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka bitcoinconsensus.
92
93 %package qt
94 Summary:        Qt-based Feathercoin Wallet
95 Summary(pl.UTF-8):      Oparty na Qt portfel Feathercoin
96 Group:          X11/Applications
97
98 %description qt
99 Qt-based Feathercoin Wallet.
100
101 %description qt -l pl.UTF-8
102 Oparty na Qt portfel Feathercoin.
103
104 %prep
105 %setup -q -n Feathercoin-%{version}
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__autoheader}
114 %{__automake}
115 # --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
116 %configure \
117         --enable-ccache%{!?with_ccache:=no} \
118         --disable-silent-rules \
119         --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
120         --with-incompatible-bdb \
121         --with-system-univalue
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 # obsoleted by pkg-config
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
133
134 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
135 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
136 [Desktop Entry]
137 Encoding=UTF-8
138 Name=Feathercoin
139 Comment=Feathercoin P2P Cryptocurrency
140 Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
141 Comment[pl]=Feathercoin - kryptowaluta P2P
142 Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
143 Exec=feathercoin-qt %u
144 Terminal=false
145 Type=Application
146 Icon=bitcoin128
147 MimeType=x-scheme-handler/feathercoin;
148 Categories=Office;Finance;
149 EOF
150
151 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
152 [Protocol]
153 exec=feathercoin-qt '%u'
154 protocol=feathercoin
155 input=none
156 output=none
157 helper=true
158 listing=
159 reading=false
160 writing=false
161 makedir=false
162 deleting=false
163 EOF
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc COPYING README.md doc/*.txt
174 %attr(755,root,root) %{_bindir}/feathercoin-cli
175 %attr(755,root,root) %{_bindir}/feathercoin-tx
176 %attr(755,root,root) %{_bindir}/feathercoin-wallet
177 %attr(755,root,root) %{_bindir}/feathercoind
178 %{_mandir}/man1/feathercoin-cli.1*
179 %{_mandir}/man1/feathercoin-tx.1*
180 %{_mandir}/man1/feathercoin-wallet.1*
181 %{_mandir}/man1/feathercoind.1*
182 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
188 %{_includedir}/bitcoinconsensus.h
189 %{_pkgconfigdir}/libbitcoinconsensus.pc
190
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/libbitcoinconsensus.a
194
195 %files qt
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/feathercoin-qt
198 %{_datadir}/kde4/services/feathercoin-qt.protocol
199 %{_desktopdir}/feathercoin-qt.desktop
200 %{_mandir}/man1/feathercoin-qt.1*
This page took 0.715931 seconds and 3 git commands to generate.