]> git.pld-linux.org Git - packages/feathercoin.git/blob - feathercoin.spec
- - rebuild with boost 1.55.0
[packages/feathercoin.git] / feathercoin.spec
1 Summary:        Feathercoin is a peer-to-peer currency
2 Name:           feathercoin
3 Version:        0.0.1
4 Release:        4
5 License:        MIT/X11
6 Group:          X11/Applications
7 Source0:        https://github.com/FeatherCoin/FeatherCoin/archive/master.zip?/%{name}-%{version}.zip
8 # Source0-md5:  9662befa9e33b7ab7ded60d41cd12eea
9 URL:            http://www.feathercoin.org
10 BuildRequires:  QtCore-devel
11 BuildRequires:  QtDBus-devel
12 BuildRequires:  QtGui-devel
13 BuildRequires:  boost-devel
14 BuildRequires:  db-cxx-devel
15 BuildRequires:  miniupnpc-devel >= 1.5
16 BuildRequires:  openssl-devel
17 BuildRequires:  qrencode-devel
18 BuildRequires:  qt4-qmake
19 Requires:       perl-base
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Feathercoin is a peer-to-peer currency. Peer-to-peer means that no central
24 authority issues new money or tracks transactions. These tasks are
25 managed collectively by the network.
26
27 %package qt
28 Summary:        Qt-based Feathercoin Wallet
29 Group:          X11/Applications
30
31 %description qt
32 Qt-based Feathercoin Wallet.
33
34 %prep
35 %setup -q -c
36
37 %build
38 cd FeatherCoin-master
39 qmake-qt4 \
40         USE_UPNP=1 \
41         USE_DBUS=1 \
42         USE_QRCODE=1
43
44 %{__make}
45
46 %{__make} -C src -f makefile.unix \
47         CXX="%{__cxx}" \
48         CXXFLAGS="%{rpmcflags} %{rpmcxxflags} %{rpmcppflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 cd FeatherCoin-master
53
54 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_mandir}/man{1,5},%{_localedir},%{_desktopdir},%{_pixmapsdir},%{_datadir}/kde4/services}
55
56 install src/feathercoind $RPM_BUILD_ROOT%{_libdir}/%{name}/feathercoind
57 sed -e 's#/usr/lib/#%{_libdir}/#g' -e 's#bitcoin#feathercoin#g' contrib/debian/bin/bitcoind > $RPM_BUILD_ROOT%{_bindir}/feathercoind
58 chmod 755 $RPM_BUILD_ROOT%{_bindir}/feathercoind
59
60 install feathercoin-qt $RPM_BUILD_ROOT%{_bindir}
61 sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.desktop > $RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
62 sed -e 's#bitcoin#feathercoin#g' contrib/debian/bitcoin-qt.protocol > $RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc FeatherCoin-master/doc/*.txt FeatherCoin-master/contrib/debian/examples/bitcoin.conf
70 %attr(755,root,root) %{_bindir}/feathercoind
71 %dir %{_libdir}/%{name}
72 %attr(755,root,root) %{_libdir}/%{name}/feathercoind
73
74 %files qt
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_bindir}/feathercoin-qt
77 %{_datadir}/kde4/services/feathercoin-qt.protocol
78 %{_desktopdir}/feathercoin-qt.desktop
This page took 0.058142 seconds and 3 git commands to generate.