]> git.pld-linux.org Git - packages/fbida.git/blob - fbida.spec
- fixed giflib patch; release 12
[packages/fbida.git] / fbida.spec
1 # TODO:
2 # - package thumbnail.cgi (in %{_libdir}/cgi-bin?)
3 #
4 # Conditional build:
5 %bcond_without  curl    # without URL support
6 %bcond_without  exif    # without EXIF tags support
7 %bcond_without  gif     # without GIF images support
8 %bcond_without  lirc    # without LIRC control support
9 %bcond_without  motif   # don't build (Motif-based) ida
10 %bcond_without  pcd     # without PCD images support
11 %bcond_without  png     # without PNG images support
12 %bcond_without  sane    # without SANE scanning support (in ida)
13 %bcond_without  tiff    # without TIFF images support
14 %bcond_without  webp    # without WebP images support
15 #
16 %if %{without motif}
17 # SANE used only in ida
18 %undefine       with_sane
19 %endif
20 Summary:        fbida - a few applications for viewing and editing images
21 Summary(pl.UTF-8):      fbida - kilka aplikacji do oglądania i edycji obrazków
22 Name:           fbida
23 Version:        2.09
24 Release:        12
25 License:        GPL
26 Group:          Applications/Graphics
27 Source0:        http://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
28 # Source0-md5:  62415c7cb28d995f9d317868de0f2830
29 Patch0:         %{name}-config-noforce.patch
30 Patch1:         %{name}-desktop.patch
31 Patch2:         format-security.patch
32 Patch3:         %{name}-giflib.patch
33 URL:            http://www.kraxel.org/blog/linux/fbida/
34 BuildRequires:  ImageMagick-devel
35 %{?with_curl:BuildRequires:     curl-devel}
36 BuildRequires:  fontconfig-devel
37 BuildRequires:  freetype-devel >= 2.0.0
38 # -Wno-pointer-sign
39 BuildRequires:  gcc >= 5:4.0
40 %{?with_gif:BuildRequires:      giflib-devel}
41 BuildRequires:  libexif-devel >= 1:0.6.9
42 BuildRequires:  libjpeg-devel
43 %{?with_pcd:BuildRequires:      libpcd-devel >= 1:1.0.1}
44 %{?with_png:BuildRequires:      libpng-devel}
45 %{?with_tiff:BuildRequires:     libtiff-devel}
46 %{?with_webp:BuildRequires:     libwebp-devel}
47 %{?with_lirc:BuildRequires:     lirc-devel}
48 # acc. to README lesstif is not sufficient
49 %{?with_motif:BuildRequires:    motif-devel >= 2.0}
50 BuildRequires:  perl-base
51 BuildRequires:  pkgconfig
52 %{?with_sane:BuildRequires:     sane-backends-devel}
53 BuildRequires:  util-linux
54 BuildRequires:  which
55 BuildRequires:  xorg-lib-libXpm-devel
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _appdefsdir     /usr/share/X11/app-defaults
59
60 %description
61 The fbida project contains a few applications for viewing and editing
62 images, with the main focus being photos. The applications are:
63 - fbi - image viewer for the Linux framebuffer console
64 - fbgs - wrapper script for viewing PS/PDF files using fbi
65 - ida - Motif-based application for viewing images
66 - exiftran - command-line tool to do lossless transformations of JPEG
67   images
68 - thumbnail.cgi - small and fast CGI program to extract EXIF
69   thumbnails from JPEG images and send them to the web browser
70
71 %description -l pl.UTF-8
72 Projekt fbida zawiera kilka aplikacji do oglądania i edycji obrazków,
73 głównie przeznaczonych dla zdjęć. Te aplikacje to:
74 - fbi - przeglądarka dla linuksowej konsoli z framebufferem
75 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
76 - ida - oparta na Motifie aplikacja do oglądania obrazków
77 - exiftran - działające z linii poleceń narzędzie do wykonywania
78   bezstratnych przekształceń obrazków JPEG
79 - thumbnail.cgi - mały i szybki program CGI do wyciągania miniaturek
80   EXIF z obrazków JPEG i wysyłania ich do przeglądarki WWW
81
82 %package -n fbi
83 Summary:        Linux FrameBuffer Imageviewer
84 Summary(pl.UTF-8):      Przeglądarka obrazków dla linuksowego framebuffera
85 Group:          Applications/Graphics
86 Requires:       mktemp >= 1.3
87
88 %description -n fbi
89 This is a image viewer for linux framebuffer devices. It supports
90 PhotoCD, JPEG and PPM directly. GIF, TIFF and PNG are handled with the
91 netpbm tools, for anything else convert from the ImageMagick package
92 is used as external converter.
93
94 This package contains also additional utilities:
95 - fbgs - wrapper script for viewing PS/PDF files using fbi
96 - exiftran - command-line tool to do lossless transformations of JPEG
97   images
98
99 %description -n fbi -l pl.UTF-8
100 To jest przeglądarka obrazków korzystająca z framebuffera. Obsługuje
101 bezpośrednio PhotoCD, JPEG i PPM; GIF, TIFF i PNG poprzez narzędzia z
102 pakietu netpbm-progs; inne obrazki poprzez program convert z pakietu
103 ImageMagick.
104
105 Ten pakiet zawiera także dodatkowe narzędzia:
106 - fbgs - skrypt do oglądania plików PS/PDF przy użyciu fbi
107 - exiftran - działające z linii poleceń narzędzie do wykonywania
108   bezstratnych przekształceń obrazków JPEG
109
110 %package -n ida
111 Summary:        Small and fast image viewer, Motif-based
112 Summary(pl.UTF-8):      Mała, szybka przeglądarka obrazków oparta na Motifie
113 Group:          X11/Applications/Graphics
114
115 %description -n ida
116 Ida is a small and fast image viewer, Motif-based. For people who
117 don't want the KDE/GNOME overhead. Some basic editing functions are
118 available too.
119
120 %description -n ida -l pl.UTF-8
121 Ida to mała i szybka przeglądarka obrazków oparta na Motifie.
122 Przeznaczona jest dla ludzi, którzy nie chcą narzutu KDE/GNOME.
123 Dostępne jest też trochę podstawowych funkcji edycyjnych.
124
125 %prep
126 %setup -q
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130 %patch3 -p1
131
132 %build
133 CFLAGS="%{rpmcflags}" \
134 %{__make} \
135         CC="%{__cc}" \
136         verbose=yes \
137         %{!?with_pcd:HAVE_LIBPCD=no} \
138         %{!?with_gif:HAVE_LIBUNGIF=no} \
139         %{!?with_png:HAVE_LIBPNG=no} \
140         %{!?with_tiff:HAVE_LIBTIFF=no} \
141         %{!?with_webp:HAVE_LIBWEBP=no} \
142         %{!?with_sane:HAVE_LIBSANE=no} \
143         %{!?with_curl:HAVE_LIBCURL=no} \
144         %{!?with_lirc:HAVE_LIBLIRC=no} \
145         %{!?with_motif:HAVE_MOTIF=no}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT \
152         prefix=%{_prefix} \
153         INSTALL_BINARY=install \
154         %{!?with_pcd:HAVE_LIBPCD=no} \
155         %{!?with_gif:HAVE_LIBUNGIF=no} \
156         %{!?with_png:HAVE_LIBPNG=no} \
157         %{!?with_tiff:HAVE_LIBTIFF=no} \
158         %{!?with_webp:HAVE_LIBWEBP=no} \
159         %{!?with_sane:HAVE_LIBSANE=no} \
160         %{!?with_curl:HAVE_LIBCURL=no} \
161         %{!?with_lirc:HAVE_LIBLIRC=no} \
162         %{!?with_motif:HAVE_MOTIF=no}
163
164 %if %{with motif}
165 install -D desktop/ida.desktop $RPM_BUILD_ROOT%{_desktopdir}/ida.desktop
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %files -n fbi
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/exiftran
174 %attr(755,root,root) %{_bindir}/fbgs
175 %attr(755,root,root) %{_bindir}/fbi
176 %{_mandir}/man1/exiftran.1*
177 %{_mandir}/man1/fbgs.1*
178 %{_mandir}/man1/fbi.1*
179
180 %if %{with motif}
181 %files -n ida
182 %defattr(644,root,root,755)
183 %doc README TODO
184 %attr(755,root,root) %{_bindir}/ida
185 %{_mandir}/man1/ida.1*
186 %{_appdefsdir}/Ida
187 %{_desktopdir}/ida.desktop
188 %endif
This page took 0.722029 seconds and 3 git commands to generate.