]> git.pld-linux.org Git - packages/fbida.git/commitdiff
- fixed giflib patch; release 12 auto/th/fbida-2.09-12
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Feb 2014 15:39:44 +0000 (16:39 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Feb 2014 15:39:44 +0000 (16:39 +0100)
fbida-giflib.patch
fbida.spec

index 60a45ea7d966896d9f3080b4308efefa61381bb7..65089153296bb7cd1f3e165ba0c88bb919448fb0 100644 (file)
@@ -1,16 +1,15 @@
 diff -Naur fbida-2.09-orig/rd/read-gif.c fbida-2.09/rd/read-gif.c
 --- fbida-2.09-orig/rd/read-gif.c      2013-07-29 16:43:26.949362012 -0400
 +++ fbida-2.09/rd/read-gif.c   2013-07-29 16:43:43.669166969 -0400
-@@ -13,6 +13,14 @@
+@@ -13,6 +13,13 @@
      int w,h;
  };
  
 +static void
-+localPrintGifError(void)
++localPrintGifError(int ErrorCode)
 +{
-+    int ErrorCode=0;
-+    GifErrorString(ErrorCode);
-+    fprintf(stderr, "\nGIF-LIB error: %i.\n", ErrorCode);
++    const char *err = GifErrorString(ErrorCode);
++    fprintf(stderr, "\nGIF-LIB error %d: %s.\n", ErrorCode, err);
 +}
 +
  static GifRecordType
@@ -21,7 +20,7 @@ diff -Naur fbida-2.09-orig/rd/read-gif.c fbida-2.09/rd/read-gif.c
            if (debug)
                fprintf(stderr,"gif: DGifGetRecordType failed\n");
 -          PrintGifError();
-+          localPrintGifError();
++          localPrintGifError(h->gif->Error);
            return -1;
        }
        switch (RecordType) {
@@ -30,7 +29,7 @@ diff -Naur fbida-2.09-orig/rd/read-gif.c fbida-2.09/rd/read-gif.c
                    if (debug)
                        fprintf(stderr,"gif: DGifGetExtension failed\n");
 -                  PrintGifError();
-+                  localPrintGifError();
++                  localPrintGifError(h->gif->Error);
                    return -1;
                }
                if (debug) {
@@ -55,7 +54,7 @@ diff -Naur fbida-2.09-orig/rd/read-gif.c fbida-2.09/rd/read-gif.c
                if (debug)
                    fprintf(stderr,"gif: DGifGetImageDesc failed\n");
 -              PrintGifError();
-+              localPrintGifError();
++              localPrintGifError(h->gif->Error);
            }
            if (NULL == h->gif->SColorMap &&
                NULL == h->gif->Image.ColorMap) {
index 93ba1f406e9d84497de586c36bf0cc281ab64633..47e1af637346cbb0990199ce88a404800dec7e42 100644 (file)
@@ -21,7 +21,7 @@ Summary:      fbida - a few applications for viewing and editing images
 Summary(pl.UTF-8):     fbida - kilka aplikacji do oglądania i edycji obrazków
 Name:          fbida
 Version:       2.09
-Release:       11
+Release:       12
 License:       GPL
 Group:         Applications/Graphics
 Source0:       http://www.kraxel.org/releases/fbida/%{name}-%{version}.tar.gz
This page took 0.068544 seconds and 4 git commands to generate.