]> git.pld-linux.org Git - packages/eventum.git/blame - eventum.spec
- another try for eventum-setup propaganda
[packages/eventum.git] / eventum.spec
CommitLineData
bb01d732 1# TODO
9748a8c3 2# - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
bb01d732
ER
3# - discard bundled packages (from INSTALL):
4# - JpGraph 1.5.3 (last GPL version)
5# - Smarty 2.3.0 (http://smarty.php.net)
6# - PEAR packages
7# - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
8# - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
9# - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
10# - A few other small javascript libraries
11# - Mail Queue Process, cron or separate package (misc/process_mail_queue.php)
12# - Email Download (misc/download_emails.php)
13# - Reminder System (misc/check_reminders.php)
14# - Heartbeat Monitor (misc/monitor.php)
15# - Email Routing Script (misc/route_emails.php)
16# - Note Routing Script (misc/route_notes.php)
17# - IRC Notification Bot (misc/irc/bot.php)
18# - Command-line Interface (misc/cli/eventum)
87d15bba
ER
19
20# snapshot: DATE
21#define _snap 20050114
22
23%if 0%{?_snap}
24%define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
25%else
26%define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
27%endif
28
ec185415 29%define _rel 1.32
87d15bba 30
bb01d732
ER
31Summary: Eventum Issue / Bug Tracking System
32Name: eventum
33Version: 1.4
87d15bba 34Release: %{?_snap:0.%{_snap}.}%{_rel}
6850abd9
ER
35License: GPL
36Group: Applications/WWW
87d15bba 37Source0: %{_source}
bb01d732 38# Source0-md5: 361c1355e46a6bbfa54e420964ec92cf
82121306 39Source1: %{name}-apache.conf
17a8bd0d
ER
40Patch0: %{name}-rpm.patch
41Patch1: %{name}-clock-status.patch
bb01d732
ER
42URL: http://dev.mysql.com/downloads/other/eventum/index.html
43BuildRequires: sed >= 4.0
ec185415 44BuildRequires: rpmbuild(macros) >= 1.177
9cdc5027 45Requires: php >= 4.1.0
bb01d732
ER
46Requires: php-pcre
47Requires: php-mysql
48Requires: php-gd
49Requires: php-imap
7a7a10b5 50#Requires: apache-mod_dir
82121306
ER
51# conflict with non-confdir apache
52Conflicts: apache1 < 1.3.33-1.1
bb01d732
ER
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
82121306 55%define _sysconfdir /etc/%{name}
9748a8c3 56%define _appdir %{_datadir}/%{name}
bb01d732 57
82121306
ER
58%define _apache1dir /etc/apache
59%define _apache2dir /etc/httpd
60
bb01d732
ER
61%description
62Eventum is a user-friendly and flexible issue tracking system that can
63be used by a support department to track incoming technical support
64requests, or by a software development team to quickly organize tasks
65and bugs. Eventum is used by the MySQL AB Technical Support team, and
66has allowed us to dramatically improve our response times.
67
ab983aaa
ER
68%package setup
69Summary: Eventum setup package.
70Group: Applications/WWW
94bd779f
ER
71PreReq: %{name}
72Requires: %{name} = %{epoch}:%{version}-%{release}
ab983aaa
ER
73
74%description setup
75Install this package to configure initial Eventum installation. You
76should uninstall this package when you're done, as it considered
77insecure to keep the setup files in place.
78
bb01d732 79%prep
87d15bba 80%setup -q %{?_snap:-n %{name}-%{_snap}}
d36b46b9 81%patch0 -p1
17a8bd0d 82%patch1 -p1
bb01d732
ER
83
84%build
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
82121306 89install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{locks,templates_c}}
bb01d732 90
9748a8c3 91cp -a . $RPM_BUILD_ROOT%{_appdir}
bb01d732 92
9748a8c3 93> $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
9cdc5027 94
82121306
ER
95sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
96
97install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
98
bb01d732 99# in doc
9748a8c3 100rm -f $RPM_BUILD_ROOT%{_appdir}/{COPYING,ChangeLog,FAQ,INSTALL,README,UPGRADE}
21efb649 101rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
bb01d732
ER
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
82121306
ER
106%post
107# apache1
108if [ -f %{_apache1dir}/apache.conf ]; then
109 ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
110 if [ -f /var/lock/subsys/apache ]; then
111 /etc/rc.d/init.d/apache restart 1>&2
112 fi
113fi
114# apache2
115if [ -d %{_apache2dir}/httpd.conf ]; then
116 ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
117 if [ -f /var/lock/subsys/httpd ]; then
118 /etc/rc.d/init.d/httpd restart 1>&2
119 fi
120fi
121
ec185415
ER
122# check if the package is configured.
123if grep -q 'header("Location: setup/")' %{_appdir}/config.inc.php; then
124%banner %{name} -e <<EOF
125
126You haven't yet configured Eventum!
127
128Install %{name}-setup and open up http://yourserver/eventum/
129-- that will help you setup initial config.
130
131when have configured Eventum, please uninstall the setup package,
132so that %{name}-setup is able to secure your Eventum installation.
133
134EOF
135#' vim stupidity.
136fi
94bd779f 137
82121306
ER
138%preun
139if [ "$1" = "0" ]; then
140 # apache1
141 if [ -f %{_apache1dir}/apache.conf ]; then
142 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
143 if [ -f /var/lock/subsys/apache ]; then
144 /etc/rc.d/init.d/apache restart 1>&2
145 fi
146 fi
147 # apache2
148 if [ -d %{_apache2dir}/httpd.conf ]; then
149 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
150 if [ -f /var/lock/subsys/httpd ]; then
151 /etc/rc.d/init.d/httpd restart 1>&2
152 fi
153 fi
154fi
155
94bd779f
ER
156%post setup
157# RACE possible? chmod just in case
158chmod 640 %{_appdir}/{config.inc,setup.conf}.php
159chown http:root %{_appdir}/{config.inc,setup.conf}.php
160
161%postun setup
162if [ "$1" = "0" ]; then
163 # RACE condition possible?
164 chmod 640 %{_appdir}/{config.inc,setup.conf}.php
165 chown root:http %{_appdir}/{config.inc,setup.conf}.php
166fi
167
bb01d732
ER
168%files
169%defattr(644,root,root,755)
21efb649 170%doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade
82121306 171%dir %{_sysconfdir}
94bd779f 172%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
82121306 173
9748a8c3 174%dir %{_appdir}
94bd779f
ER
175%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/config.inc.php
176%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/setup.conf.php
9748a8c3
ER
177%{_appdir}/*[!cf].php
178
179%{_appdir}/css
180%{_appdir}/customer
181%{_appdir}/docs
182%{_appdir}/images
183%{_appdir}/js
184%{_appdir}/manage
185%{_appdir}/misc
186%{_appdir}/reports
187%{_appdir}/rpc
9748a8c3
ER
188%{_appdir}/templates
189
94bd779f 190%dir %attr(750,http,root) %{_appdir}/locks
9748a8c3
ER
191
192%dir %{_appdir}/include
193%{_appdir}/include/customer
194%{_appdir}/include/jpgraph
195%{_appdir}/include/pear
196%{_appdir}/include/Smarty
197%{_appdir}/include/workflow
198%{_appdir}/include/class.*
199%{_appdir}/include/db_access.php
200%{_appdir}/include/jsrsServer.inc.php
201%attr(640,http,root) %{_appdir}/include/private_key.php
202
94bd779f
ER
203%dir %attr(731,root,http) %{_appdir}/logs
204%attr(640,http,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/logs/*
9748a8c3
ER
205
206%dir %attr(750,http,root) %{_appdir}/templates_c
ab983aaa
ER
207
208%files setup
209%defattr(644,root,root,755)
210%{_appdir}/setup
This page took 0.056473 seconds and 4 git commands to generate.