]> git.pld-linux.org Git - packages/double-conversion.git/blob - double-conversion.spec
up to 1.1.4; library name with minus not underscore
[packages/double-conversion.git] / double-conversion.spec
1 #
2 # TODO
3 # - versioning in shared lib
4
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7
8 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
9 Name:           double-conversion
10 Version:        1.1.4
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
15 # Source0-md5:  53669dba2d23e308dc512d6330852aa5
16 URL:            http://code.google.com/p/double-conversion
17 Source1:        SConstruct
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  scons >= 2.3.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This project (double-conversion) provides binary-decimal and
24 decimal-binary routines for IEEE doubles.
25
26 The library consists of efficient conversion routines that have been
27 extracted from the V8 JavaScript engine. The code has been refactored
28 and improved so that it can be used more easily in other projects.
29
30 %package devel
31 Summary:        Library providing binary-decimal and decimal-binary routines for IEEE doubles
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Contains header files for developing applications that use the %{name}
37 library.
38
39 There is extensive documentation in src/double-conversion.h. Other
40 examples can be found in test/cctest/test-conversions.cc.
41
42 %package static
43 Summary:        Static %{name} library
44 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static %{name} library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka %{name}.
53
54 %prep
55 %setup -qc
56 cp -p %{SOURCE1} SConstruct
57
58 %build
59 %scons \
60         CXX="%{__cxx}"
61         CXXFLAGS="%{__cxx}"
62
63 # avoid file exists errors, when entering install
64 rm -f libdouble-conversion.so libdouble-conversion.so.0
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
69 %scons install \
70         DESTDIR=$RPM_BUILD_ROOT \
71
72 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
73
74 %clean
75 %{__rm} -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc LICENSE README AUTHORS Changelog
83 %attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
84 %ghost %{_libdir}/libdouble-conversion.so.0
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_libdir}/libdouble-conversion.so
89 %{_includedir}/%{name}
90
91 %if %{with static_libs}
92 %files static
93 %defattr(644,root,root,755)
94 %{_libdir}/libdouble-conversion.a
95 %{_libdir}/libdouble-conversion_pic.a
96 %endif
This page took 0.380626 seconds and 3 git commands to generate.