]> git.pld-linux.org Git - packages/double-conversion.git/blame - double-conversion.spec
up to 1.1.4; library name with minus not underscore
[packages/double-conversion.git] / double-conversion.spec
CommitLineData
a6527f0c
ER
1#
2# TODO
3# - versioning in shared lib
4
5# Conditional build:
6%bcond_without static_libs # don't build static libraries
7
002c3a9e
ER
8Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
9Name: double-conversion
48fe636d 10Version: 1.1.4
002c3a9e
ER
11Release: 1
12License: BSD
13Group: Libraries
14Source0: http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
48fe636d 15# Source0-md5: 53669dba2d23e308dc512d6330852aa5
002c3a9e
ER
16URL: http://code.google.com/p/double-conversion
17Source1: SConstruct
18BuildRequires: libstdc++-devel
09cc3773 19BuildRequires: scons >= 2.3.0
002c3a9e
ER
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
95c391f9
ER
23This project (double-conversion) provides binary-decimal and
24decimal-binary routines for IEEE doubles.
25
26The library consists of efficient conversion routines that have been
27extracted from the V8 JavaScript engine. The code has been refactored
28and improved so that it can be used more easily in other projects.
002c3a9e
ER
29
30%package devel
31Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
95c391f9
ER
36Contains header files for developing applications that use the %{name}
37library.
38
39There is extensive documentation in src/double-conversion.h. Other
40examples can be found in test/cctest/test-conversions.cc.
002c3a9e 41
af4206ea
ER
42%package static
43Summary: Static %{name} library
44Summary(pl.UTF-8): Statyczna biblioteka %{name}
45Group: Development/Libraries
46Requires: %{name}-devel = %{version}-%{release}
47
48%description static
49Static %{name} library.
50
51%description static -l pl.UTF-8
52Statyczna biblioteka %{name}.
53
002c3a9e 54%prep
48fe636d 55%setup -qc
3a886c7c 56cp -p %{SOURCE1} SConstruct
002c3a9e
ER
57
58%build
3a886c7c 59%scons \
3a886c7c
ER
60 CXX="%{__cxx}"
61 CXXFLAGS="%{__cxx}"
002c3a9e 62
09cc3773 63# avoid file exists errors, when entering install
48fe636d 64rm -f libdouble-conversion.so libdouble-conversion.so.0
09cc3773 65
002c3a9e
ER
66%install
67rm -rf $RPM_BUILD_ROOT
68install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
a6527f0c
ER
69%scons install \
70 DESTDIR=$RPM_BUILD_ROOT \
002c3a9e 71
a54fc8c4 72cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
002c3a9e
ER
73
74%clean
75%{__rm} -rf $RPM_BUILD_ROOT
76
a6527f0c
ER
77%post -p /sbin/ldconfig
78%postun -p /sbin/ldconfig
79
002c3a9e
ER
80%files
81%defattr(644,root,root,755)
7a858767 82%doc LICENSE README AUTHORS Changelog
48fe636d
ER
83%attr(755,root,root) %{_libdir}/libdouble-conversion.so.*.*.*
84%ghost %{_libdir}/libdouble-conversion.so.0
002c3a9e
ER
85
86%files devel
87%defattr(644,root,root,755)
48fe636d 88%{_libdir}/libdouble-conversion.so
a6527f0c
ER
89%{_includedir}/%{name}
90
91%if %{with static_libs}
92%files static
93%defattr(644,root,root,755)
48fe636d
ER
94%{_libdir}/libdouble-conversion.a
95%{_libdir}/libdouble-conversion_pic.a
a6527f0c 96%endif
This page took 1.799311 seconds and 4 git commands to generate.