]> git.pld-linux.org Git - packages/double-conversion.git/blame - double-conversion.spec
simplify headers install
[packages/double-conversion.git] / double-conversion.spec
CommitLineData
a6527f0c
ER
1#
2# TODO
3# - versioning in shared lib
4
5# Conditional build:
6%bcond_without static_libs # don't build static libraries
7
002c3a9e
ER
8Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
9Name: double-conversion
10Version: 1.1.1
11Release: 1
12License: BSD
13Group: Libraries
14Source0: http://double-conversion.googlecode.com/files/%{name}-%{version}.tar.gz
15# Source0-md5: 29b533ed4311161267bff1a9a97e2953
16URL: http://code.google.com/p/double-conversion
17Source1: SConstruct
18BuildRequires: libstdc++-devel
19BuildRequires: scons
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
95c391f9
ER
23This project (double-conversion) provides binary-decimal and
24decimal-binary routines for IEEE doubles.
25
26The library consists of efficient conversion routines that have been
27extracted from the V8 JavaScript engine. The code has been refactored
28and improved so that it can be used more easily in other projects.
002c3a9e
ER
29
30%package devel
31Summary: Library providing binary-decimal and decimal-binary routines for IEEE doubles
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34
35%description devel
95c391f9
ER
36Contains header files for developing applications that use the %{name}
37library.
38
39There is extensive documentation in src/double-conversion.h. Other
40examples can be found in test/cctest/test-conversions.cc.
002c3a9e 41
af4206ea
ER
42%package static
43Summary: Static %{name} library
44Summary(pl.UTF-8): Statyczna biblioteka %{name}
45Group: Development/Libraries
46Requires: %{name}-devel = %{version}-%{release}
47
48%description static
49Static %{name} library.
50
51%description static -l pl.UTF-8
52Statyczna biblioteka %{name}.
53
002c3a9e
ER
54%prep
55%setup -q -n %{name}
3a886c7c 56cp -p %{SOURCE1} SConstruct
002c3a9e
ER
57
58%build
3a886c7c 59%scons \
3a886c7c
ER
60 CXX="%{__cxx}"
61 CXXFLAGS="%{__cxx}"
002c3a9e
ER
62
63%install
64rm -rf $RPM_BUILD_ROOT
65install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/%{name}}
a6527f0c
ER
66%scons install \
67 DESTDIR=$RPM_BUILD_ROOT \
002c3a9e 68
a54fc8c4 69cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
002c3a9e
ER
70
71%clean
72%{__rm} -rf $RPM_BUILD_ROOT
73
a6527f0c
ER
74%post -p /sbin/ldconfig
75%postun -p /sbin/ldconfig
76
002c3a9e
ER
77%files
78%defattr(644,root,root,755)
79%doc LICENSE README AUTHORS
a6527f0c 80%{_libdir}/libdouble_conversion.so
002c3a9e
ER
81
82%files devel
83%defattr(644,root,root,755)
a6527f0c
ER
84%{_includedir}/%{name}
85
86%if %{with static_libs}
87%files static
88%defattr(644,root,root,755)
002c3a9e
ER
89%{_libdir}/libdouble_conversion.a
90%{_libdir}/libdouble_conversion_pic.a
a6527f0c 91%endif
This page took 0.088021 seconds and 4 git commands to generate.