]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
cleanup devel files packaging
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - sync pl
3 # - clean up spec. cleanup what?
4 %define         subver  stable
5 Summary:        jDoom, jHeretic and jHexen for Linux
6 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
7 Name:           doomsday
8 Version:        1.15.4
9 Release:        0.1
10 License:        GPL v2 / CC 3.0 (icons)
11 Group:          Applications/Games
12 Source0:        http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
13 # Source0-md5:  8329eacdea73edca7aea4034ca8d78aa
14 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
15 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
16 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
17 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
18 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
19 # Source3-md5:  c89e36c49eabe2846137f313a5250308
20 #Patch0:                %{name}-libpng15.patch
21 #Patch1:                %{name}-format.patch
22 URL:            http://www.dengine.net/
23 BuildRequires:  OpenAL-devel
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL2-devel
27 BuildRequires:  SDL2_mixer-devel
28 BuildRequires:  assimp-devel
29 BuildRequires:  curl-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  ncurses-devel
32 BuildRequires:  python
33 BuildRequires:  python-modules
34 BuildRequires:  qt4-qmake
35 BuildRequires:  rpmbuild(macros) >= 1.595
36 Requires(post): /sbin/ldconfig
37 Requires:       TiMidity++
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The Doomsday Engine allows you to play the classic first-person
42 shooters DOOM, Heretic, and Hexen using modern technology, with
43 hardware accelerated 3D graphics, surround sound and much more.
44
45 %description -l pl.UTF-8
46 jDoom, jHeretic i jHexen dla Linuksa.
47
48 %prep
49 %setup -q -n %{name}-%{subver}-%{version}
50 #%patch0 -p1
51 #%patch1 -p1
52
53 %build
54 install -d build
55 cd build
56 LDFLAGS="-lm"
57 qmake-qt4 CONFIG+=deng_notools \
58         -r ../doomsday/doomsday.pro
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_desktopdir}
64 %{__make} -C build install \
65         INSTALL_ROOT=$RPM_BUILD_ROOT
66
67 # no -devel package. cleanup
68 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so
69 # junk links
70 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so.1.15
71 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_core.so.2.0
72
73 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
74 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
75 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
76 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
77
78 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
79 [Desktop Entry]
80 Name=Doom
81 Comment=Doom for linux
82 Exec=doomsday -game jdoom
83 Icon=doom.png
84 Terminal=false
85 Type=Application
86 Categories=Game;FirstPersonGame;
87 Encoding=UTF-8
88 EOF
89
90 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
91 [Desktop Entry]
92 Name=Hexen
93 Comment=Hexen for linux
94 Exec=doomsday -game jhexen
95 Icon=hexen.png
96 Terminal=false
97 Type=Application
98 Categories=Game;FirstPersonGame;
99 Encoding=UTF-8
100 EOF
101
102 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
103 [Desktop Entry]
104 Name=Heretic
105 Comment=Heretic for linux
106 Exec=doomsday -game jheretic
107 Icon=heretic.png
108 Terminal=false
109 Type=Application
110 Categories=Game;FirstPersonGame;
111 Encoding=UTF-8
112 EOF
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 /sbin/ldconfig
119 %banner -o -e %{name} <<-EOF
120 To run doomsday you need some WAD file: either freedoom package
121 or some shareware or commercial WAD from Doom or Heretic:
122 Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
123 Heretic.wad or Heretic1.wad.
124 When you have them, run doomsday with:
125 doomsday -game [ jdoom | jheretic | jhexen ]
126 EOF
127
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 #%doc doomsday/build/README
133 %attr(755,root,root) %{_bindir}/doomsday
134 %attr(755,root,root) %{_bindir}/doomsday-server
135 %attr(755,root,root) %{_bindir}/launch-doomsday
136
137 %attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
139 %attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
141 %attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
143 %attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
145 %attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
147 %attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
149
150
151 %{_libdir}/doomsday
152 %{_datadir}/doomsday
153 %{_desktopdir}/*.desktop
154 %{_pixmapsdir}/*.png
155 %{_mandir}/man6/*
This page took 0.070552 seconds and 3 git commands to generate.