]> git.pld-linux.org Git - packages/doomsday.git/blame - doomsday.spec
cleanup devel files packaging
[packages/doomsday.git] / doomsday.spec
CommitLineData
1748e707 1# TODO
96e1b283 2# - sync pl
9d6c2050 3# - clean up spec. cleanup what?
65f3387c 4%define subver stable
613b8bc6 5Summary: jDoom, jHeretic and jHexen for Linux
5398b956 6Summary(pl.UTF-8): jDoom, jHeretic i jHexen dla Linuksa
613b8bc6 7Name: doomsday
65f3387c
LM
8Version: 1.15.4
9Release: 0.1
a4a33ef2 10License: GPL v2 / CC 3.0 (icons)
613b8bc6 11Group: Applications/Games
65f3387c
LM
12Source0: http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
13# Source0-md5: 8329eacdea73edca7aea4034ca8d78aa
a4a33ef2 14Source1: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
76bc3a41 15# Source1-md5: b7b7a9389eba56679e5db65d95c06803
a4a33ef2 16Source2: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
76bc3a41 17# Source2-md5: 573845e6e747f68617ac67f3a87dc78e
a4a33ef2 18Source3: http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
76bc3a41 19# Source3-md5: c89e36c49eabe2846137f313a5250308
9d6c2050 20#Patch0: %{name}-libpng15.patch
27c6a781 21#Patch1: %{name}-format.patch
96e1b283 22URL: http://www.dengine.net/
613b8bc6 23BuildRequires: OpenAL-devel
2a1961bd 24BuildRequires: OpenGL-GLU-devel
613b8bc6 25BuildRequires: OpenGL-devel
65f3387c
LM
26BuildRequires: SDL2-devel
27BuildRequires: SDL2_mixer-devel
65f3387c 28BuildRequires: assimp-devel
2a1961bd 29BuildRequires: curl-devel
8755e793 30BuildRequires: libpng-devel
31BuildRequires: ncurses-devel
32BuildRequires: python
33BuildRequires: python-modules
1305a4f7 34BuildRequires: qt4-qmake
96e1b283 35BuildRequires: rpmbuild(macros) >= 1.595
85be4bea 36Requires(post): /sbin/ldconfig
663fb57e 37Requires: TiMidity++
613b8bc6 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
613b8bc6 40%description
96e1b283
ER
41The Doomsday Engine allows you to play the classic first-person
42shooters DOOM, Heretic, and Hexen using modern technology, with
43hardware accelerated 3D graphics, surround sound and much more.
613b8bc6 44
39e9285b 45%description -l pl.UTF-8
6f1050b2 46jDoom, jHeretic i jHexen dla Linuksa.
613b8bc6 47
48%prep
1305a4f7 49%setup -q -n %{name}-%{subver}-%{version}
65f3387c
LM
50#%patch0 -p1
51#%patch1 -p1
613b8bc6 52
53%build
663fb57e
ER
54install -d build
55cd build
96e1b283 56LDFLAGS="-lm"
65f3387c
LM
57qmake-qt4 CONFIG+=deng_notools \
58 -r ../doomsday/doomsday.pro
613b8bc6 59%{__make}
60
61%install
62rm -rf $RPM_BUILD_ROOT
1748e707 63install -d $RPM_BUILD_ROOT%{_desktopdir}
9d6c2050
ER
64%{__make} -C build install \
65 INSTALL_ROOT=$RPM_BUILD_ROOT
613b8bc6 66
1305a4f7
ER
67# no -devel package. cleanup
68%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so
69# junk links
70%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so.1.15
71%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_core.so.2.0
72
a4a33ef2 73install -d $RPM_BUILD_ROOT%{_pixmapsdir}
9d6c2050
ER
74cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
75cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
76cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
a4a33ef2 77
1748e707
ER
78cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
79[Desktop Entry]
80Name=Doom
81Comment=Doom for linux
82Exec=doomsday -game jdoom
a4a33ef2 83Icon=doom.png
1748e707
ER
84Terminal=false
85Type=Application
f6ee92a4 86Categories=Game;FirstPersonGame;
1748e707 87Encoding=UTF-8
1748e707
ER
88EOF
89
90cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
91[Desktop Entry]
92Name=Hexen
93Comment=Hexen for linux
94Exec=doomsday -game jhexen
a4a33ef2 95Icon=hexen.png
1748e707
ER
96Terminal=false
97Type=Application
f6ee92a4 98Categories=Game;FirstPersonGame;
1748e707 99Encoding=UTF-8
1748e707
ER
100EOF
101
102cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
103[Desktop Entry]
104Name=Heretic
105Comment=Heretic for linux
106Exec=doomsday -game jheretic
a4a33ef2 107Icon=heretic.png
1748e707
ER
108Terminal=false
109Type=Application
f6ee92a4 110Categories=Game;FirstPersonGame;
1748e707 111Encoding=UTF-8
1748e707
ER
112EOF
113
613b8bc6 114%clean
6f1050b2 115rm -rf $RPM_BUILD_ROOT
613b8bc6 116
85be4bea
ER
117%post
118/sbin/ldconfig
96e1b283
ER
119%banner -o -e %{name} <<-EOF
120To run doomsday you need some WAD file: either freedoom package
121or some shareware or commercial WAD from Doom or Heretic:
122Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
123Heretic.wad or Heretic1.wad.
124When you have them, run doomsday with:
125doomsday -game [ jdoom | jheretic | jhexen ]
1748e707 126EOF
613b8bc6 127
65f3387c
LM
128%postun -p /sbin/ldconfig
129
613b8bc6 130%files
131%defattr(644,root,root,755)
65f3387c 132#%doc doomsday/build/README
613b8bc6 133%attr(755,root,root) %{_bindir}/doomsday
65f3387c
LM
134%attr(755,root,root) %{_bindir}/doomsday-server
135%attr(755,root,root) %{_bindir}/launch-doomsday
136
b72a2307 137%attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
65f3387c 138%attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
b72a2307 139%attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
65f3387c 140%attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
b72a2307 141%attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
65f3387c 142%attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
b72a2307 143%attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
65f3387c 144%attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
b72a2307 145%attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
65f3387c 146%attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
b72a2307 147%attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
65f3387c
LM
148%attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
149
1305a4f7 150
65f3387c
LM
151%{_libdir}/doomsday
152%{_datadir}/doomsday
1748e707 153%{_desktopdir}/*.desktop
a4a33ef2 154%{_pixmapsdir}/*.png
65f3387c 155%{_mandir}/man6/*
This page took 0.080453 seconds and 4 git commands to generate.