]> git.pld-linux.org Git - packages/dokuwiki-plugin-move.git/blob - dokuwiki-plugin-move.spec
Up to 2022-01-23
[packages/dokuwiki-plugin-move.git] / dokuwiki-plugin-move.spec
1 %define         subver  2017-01-07
2 %define         ver             %(echo %{subver} | tr -d -)
3 %define         plugin          move
4 Summary:        Move pages, media files and namespaces while maintaining the link structure
5 Name:           dokuwiki-plugin-%{plugin}
6 Version:        %{ver}
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/WWW
10 Source0:        https://github.com/michitux/dokuwiki-plugin-move/archive/06b7ca403829/%{plugin}-%{version}.tar.gz
11 # Source0-md5:  b75a0887edf7d627386d27050aa8f867
12 URL:            https://www.dokuwiki.org/plugin:move
13 BuildRequires:  sed >= 4.0
14 BuildRequires:  unzip
15 Requires:       dokuwiki >= 20131208
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         dokuconf        /etc/webapps/dokuwiki
20 %define         dokudir         /usr/share/dokuwiki
21 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
22
23 %description
24 This plugin allows to move pages and namespaces including media files
25 and automatically adjusts all links and media references that point to
26 these pages. Unlike the old pagemove plugin this plugin uses the
27 DokuWiki parser which allows it to correctly identify all links and
28 nothing else.
29
30 Parts of this plugin like some of the translated strings, some parts
31 of the structure of the code and parts of the user interface have been
32 taken from the old pagemove plugin by Gary Owen, Arno Puschmann and
33 Christoph Jähnigen.
34
35 Warning: This plugin does not update ACL rules. For example if you had
36 an ACL rule that read-protected a certain wiki page this rule won't
37 have any effect anymore after moving that page.
38
39 %prep
40 %setup -qc
41 mv dokuwiki-plugin-move-*/* .
42
43 # cleanup backups after patching
44 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
45
46 %build
47 version=$(awk '/^date/{print $2}' plugin.info.txt)
48 if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
49         : %%{version} mismatch
50         exit 1
51 fi
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{plugindir}
56 cp -a . $RPM_BUILD_ROOT%{plugindir}
57
58 %{__rm} $RPM_BUILD_ROOT%{plugindir}/README
59 %{__rm} -r $RPM_BUILD_ROOT%{plugindir}/_test
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %dir %{plugindir}
68 %{plugindir}/*.js
69 %{plugindir}/*.less
70 %{plugindir}/*.txt
71 %{plugindir}/action
72 %{plugindir}/admin
73 %{plugindir}/conf
74 %{plugindir}/helper
75 %{plugindir}/images
76 %{plugindir}/script
77
78 %dir %{plugindir}/lang
79 %{plugindir}/lang/en
80 %lang(cs) %{plugindir}/lang/cs
81 %lang(de) %{plugindir}/lang/de
82 %lang(es) %{plugindir}/lang/es
83 %lang(fr) %{plugindir}/lang/fr
84 %lang(it) %{plugindir}/lang/it
85 %lang(ja) %{plugindir}/lang/ja
86 %lang(ko) %{plugindir}/lang/ko
87 %lang(lv) %{plugindir}/lang/lv
88 %lang(nl) %{plugindir}/lang/nl
89 %lang(no) %{plugindir}/lang/no
90 %lang(pl) %{plugindir}/lang/pl
91 %lang(ru) %{plugindir}/lang/ru
92 %lang(sl) %{plugindir}/lang/sl
93 %lang(sv) %{plugindir}/lang/sv
94 %lang(zh_CN) %{plugindir}/lang/zh
This page took 0.096191 seconds and 3 git commands to generate.