]> git.pld-linux.org Git - packages/dokuwiki-plugin-move.git/blame - dokuwiki-plugin-move.spec
Up to 2022-01-23
[packages/dokuwiki-plugin-move.git] / dokuwiki-plugin-move.spec
CommitLineData
2d4880c3 1%define subver 2022-01-23
e160702a 2%define ver %(echo %{subver} | tr -d -)
4492f0b8 3%define plugin move
2d4880c3 4%define php_min_version 5.3.0
4492f0b8
ER
5Summary: Move pages, media files and namespaces while maintaining the link structure
6Name: dokuwiki-plugin-%{plugin}
e160702a 7Version: %{ver}
4492f0b8
ER
8Release: 1
9License: GPL v2
10Group: Applications/WWW
2d4880c3
ER
11Source0: https://github.com/michitux/dokuwiki-plugin-move/archive/%{subver}/%{plugin}-%{subver}.tar.gz
12# Source0-md5: b6ac00200df22eb9b76376ef240fb7b7
4492f0b8 13URL: https://www.dokuwiki.org/plugin:move
2d4880c3
ER
14BuildRequires: rpm-php-pearprov >= 4.4.2-11
15BuildRequires: rpmbuild(find_lang) >= 1.41
16BuildRequires: rpmbuild(macros) >= 1.745
4492f0b8 17BuildRequires: sed >= 4.0
4492f0b8 18Requires: dokuwiki >= 20131208
2d4880c3 19Requires: php(core) >= %{php_min_version}
4492f0b8
ER
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define dokuconf /etc/webapps/dokuwiki
24%define dokudir /usr/share/dokuwiki
25%define plugindir %{dokudir}/lib/plugins/%{plugin}
26
27%description
28This plugin allows to move pages and namespaces including media files
29and automatically adjusts all links and media references that point to
30these pages. Unlike the old pagemove plugin this plugin uses the
31DokuWiki parser which allows it to correctly identify all links and
32nothing else.
33
34Parts of this plugin like some of the translated strings, some parts
35of the structure of the code and parts of the user interface have been
36taken from the old pagemove plugin by Gary Owen, Arno Puschmann and
37Christoph Jähnigen.
38
39Warning: This plugin does not update ACL rules. For example if you had
40an ACL rule that read-protected a certain wiki page this rule won't
41have any effect anymore after moving that page.
42
43%prep
44%setup -qc
2d4880c3 45mv *-%{plugin}-*/{.??*,*} .
4492f0b8 46
2d4880c3
ER
47rm .github/workflows/phpTestLinux.yml
48rm deleted.files
4492f0b8
ER
49
50%build
51version=$(awk '/^date/{print $2}' plugin.info.txt)
52if [ "$(echo "$version" | tr -d -)" != %{version} ]; then
53 : %%{version} mismatch
54 exit 1
55fi
56
57%install
58rm -rf $RPM_BUILD_ROOT
59install -d $RPM_BUILD_ROOT%{plugindir}
60cp -a . $RPM_BUILD_ROOT%{plugindir}
61
62%{__rm} $RPM_BUILD_ROOT%{plugindir}/README
63%{__rm} -r $RPM_BUILD_ROOT%{plugindir}/_test
64
2d4880c3
ER
65%find_lang %{name}.lang --with-dokuwiki
66
4492f0b8
ER
67%clean
68rm -rf $RPM_BUILD_ROOT
69
2d4880c3 70%files -f %{name}.lang
4492f0b8
ER
71%defattr(644,root,root,755)
72%doc README
73%dir %{plugindir}
74%{plugindir}/*.js
75%{plugindir}/*.less
2d4880c3
ER
76%{plugindir}/*.php
77%{plugindir}/*.svg
4492f0b8
ER
78%{plugindir}/*.txt
79%{plugindir}/action
80%{plugindir}/admin
81%{plugindir}/conf
82%{plugindir}/helper
83%{plugindir}/images
84%{plugindir}/script
This page took 0.155635 seconds and 4 git commands to generate.