]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
include 'fetch' into path
[packages/depot_tools.git] / depot_tools.spec
1 %define         snap    20130619
2 %define         rel             0.9
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{snap}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        https://src.chromium.org/svn/trunk/tools/depot_tools.zip?/%{name}-svn%{snap}.zip
10 # Source0-md5:  6cf6483d6da8d15848cbaa8857aae3ae
11 URL:            http://dev.chromium.org/developers/how-tos/depottools
12 BuildRequires:  unzip
13 Requires:       python
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Chromium uses a package of scripts, the depot_tools, to manage
19 interaction with the Chromium source code repository and the Chromium
20 development process. It contains the following utilities:
21
22 - gclient: Meta-checkout tool managing both subversion and git
23   checkouts. It is similar to repo tool except that it works on Linux,
24   OS X, and Windows and supports both svn and git. On the other hand,
25   gclient doesn't integrate any code review functionality.
26 - gcl: Rietveld code review tool for subversion. The gcl tool runs
27   presubmit scripts.
28 - git-cl: Rietveld code review tool for git. The git-cl tool runs
29   presubmit scripts.
30 - hammer: (Obsolete) Wrapper script for building Chromium with the
31   SCons software construction tool.
32 - drover: Quickly revert svn commits.
33 - cpplint.py: Checks for C++ style compliance.
34 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
35 - repo: The repo tool.
36 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
37 - git-try: Try change tool for git users
38 - wtf: Displays the active git branches in a chromium os checkout.
39 - weekly: Displays the log of checkins for a particular developer
40   since a particular date for git checkouts.
41 - git-gs: Wrapper for git grep with relevant source types.
42 - zsh-goodies: Completion for zsh users.
43
44 %prep
45 %setup -qc
46 mv depot_tools/* .
47 rm -r depot_tools
48
49 cat > py-wrap.sh <<'EOF'
50 #!/bin/sh
51 exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
52 EOF
53 chmod +x *.sh
54 ln -s git_cl.py git-cl.py
55
56 # python 2.4 components
57 rm -r third_party/pymox
58
59 # screw binaries and shipped dependencies and things useless to this platform
60 rm ninja*
61 find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
62 rm create-ntfs-junction.c
63
64 # tests
65 rm -r testing_support
66 rm -r tests
67
68 # other junk
69 rm -r bootstrap
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
74 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
75 # already in %doc
76 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
77
78 for a in gclient gcl git-cl fetch; do
79         ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
80 done
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc LICENSE README README.gclient
88 %attr(755,root,root) %{_bindir}/gcl
89 %attr(755,root,root) %{_bindir}/gclient
90 %attr(755,root,root) %{_bindir}/git-cl
91 %attr(755,root,root) %{_bindir}/fetch
92 %dir %{_datadir}/%{name}
93 %attr(755,root,root) %{_datadir}/%{name}/apply_issue
94 %attr(755,root,root) %{_datadir}/%{name}/cbuildbot
95 %attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
96 %attr(755,root,root) %{_datadir}/%{name}/codereview.settings
97 %attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
98 %attr(755,root,root) %{_datadir}/%{name}/cros
99 %attr(755,root,root) %{_datadir}/%{name}/cros_sdk
100 %attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
101 %attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
102 %attr(755,root,root) %{_datadir}/%{name}/drover
103 %attr(755,root,root) %{_datadir}/%{name}/fetch
104 %attr(755,root,root) %{_datadir}/%{name}/gcl
105 %attr(755,root,root) %{_datadir}/%{name}/gclient
106 %attr(755,root,root) %{_datadir}/%{name}/git-cl
107 %attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
108 %attr(755,root,root) %{_datadir}/%{name}/git-crsync
109 %attr(755,root,root) %{_datadir}/%{name}/git-crup
110 %attr(755,root,root) %{_datadir}/%{name}/git-gs
111 %attr(755,root,root) %{_datadir}/%{name}/git-lkgr
112 %attr(755,root,root) %{_datadir}/%{name}/git-runhooks
113 %attr(755,root,root) %{_datadir}/%{name}/git-try
114 %attr(755,root,root) %{_datadir}/%{name}/hammer
115 %attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
116 %attr(755,root,root) %{_datadir}/%{name}/pylint
117 %attr(755,root,root) %{_datadir}/%{name}/pylintrc
118 %attr(755,root,root) %{_datadir}/%{name}/repo
119 %attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
120 %attr(755,root,root) %{_datadir}/%{name}/weekly
121 %attr(755,root,root) %{_datadir}/%{name}/wtf
122
123 %{_datadir}/%{name}/*.py
124 %{_datadir}/%{name}/profile.xml
125 %{_datadir}/%{name}/git-templates/
126 %{_datadir}/%{name}/git_utils/
127 %{_datadir}/%{name}/recipes/
128 %{_datadir}/%{name}/support/
129 %{_datadir}/%{name}/third_party/
130 %{_datadir}/%{name}/zsh-goodies/
This page took 0.105336 seconds and 4 git commands to generate.