]> git.pld-linux.org Git - packages/depot_tools.git/blame - depot_tools.spec
obsolete gclient
[packages/depot_tools.git] / depot_tools.spec
CommitLineData
e9bf62fa 1%define subver 20131210
676bbd7d 2%define rel 0.12
e2970781
ER
3Summary: A package of scripts called used to manage checkouts and code reviews
4Name: depot_tools
5Version: 0.1
e9bf62fa 6Release: 0.%{subver}.%{rel}
e2970781
ER
7License: BSD
8Group: Development/Tools
e9bf62fa
ER
9Source0: %{name}-%{subver}-aeab41a.tar.xz
10# Source0-md5: 5dd469c8ec03d03d48b7db886475bbfa
11Patch0: adjust-path.patch
e2970781 12URL: http://dev.chromium.org/developers/how-tos/depottools
e9bf62fa
ER
13BuildRequires: tar >= 1:1.22
14BuildRequires: xz
e2970781 15Requires: python
016f910f 16Obsoletes: gclient
f59bfbe1 17BuildArch: noarch
e2970781
ER
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Chromium uses a package of scripts, the depot_tools, to manage
22interaction with the Chromium source code repository and the Chromium
7bd89abe 23development process. It contains the following utilities:
e2970781 24
7bd89abe
ER
25- gclient: Meta-checkout tool managing both subversion and git
26 checkouts. It is similar to repo tool except that it works on Linux,
27 OS X, and Windows and supports both svn and git. On the other hand,
28 gclient doesn't integrate any code review functionality.
e2970781
ER
29- gcl: Rietveld code review tool for subversion. The gcl tool runs
30 presubmit scripts.
31- git-cl: Rietveld code review tool for git. The git-cl tool runs
32 presubmit scripts.
33- hammer: (Obsolete) Wrapper script for building Chromium with the
34 SCons software construction tool.
35- drover: Quickly revert svn commits.
7bd89abe 36- cpplint.py: Checks for C++ style compliance.
e2970781
ER
37- presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
38- repo: The repo tool.
39- trychange.py: Try server tool. It is wrapped by gcl try and git-try.
40- git-try: Try change tool for git users
41- wtf: Displays the active git branches in a chromium os checkout.
42- weekly: Displays the log of checkins for a particular developer
43 since a particular date for git checkouts.
44- git-gs: Wrapper for git grep with relevant source types.
45- zsh-goodies: Completion for zsh users.
46
47%prep
e9bf62fa 48%setup -qn %{name}-%{subver}
407fa934 49%patch0 -p1
e2970781 50
2c66fa69
ER
51cat > py-wrap.sh <<'EOF'
52#!/bin/sh
53exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
54EOF
55chmod +x *.sh
0afdc21d 56ln -s git_cl.py git-cl.py
2c66fa69 57
e2970781 58# python 2.4 components
92eda2a9 59rm -r third_party/pymox
e2970781 60
b03a4c59
ER
61# screw binaries and shipped dependencies and things useless to this platform
62rm ninja*
63find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
f59bfbe1
ER
64rm create-ntfs-junction.c
65
66# tests
67rm -r testing_support
68rm -r tests
69
e9bf62fa 70# other irrelevant junk
f59bfbe1 71rm -r bootstrap
e9bf62fa
ER
72rm .gitignore
73rm OWNERS WATCHLISTS
b03a4c59 74
e2970781
ER
75%install
76rm -rf $RPM_BUILD_ROOT
2c66fa69 77install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
e2970781 78cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
f59bfbe1
ER
79# already in %doc
80rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
81
e1627786 82for a in gclient gcl git-cl fetch; do
2c66fa69
ER
83 ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
84done
e2970781
ER
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc LICENSE README README.gclient
2c66fa69 92%attr(755,root,root) %{_bindir}/gcl
e2970781 93%attr(755,root,root) %{_bindir}/gclient
2c66fa69 94%attr(755,root,root) %{_bindir}/git-cl
e1627786 95%attr(755,root,root) %{_bindir}/fetch
92eda2a9 96%dir %{_datadir}/%{name}
f59bfbe1
ER
97%attr(755,root,root) %{_datadir}/%{name}/apply_issue
98%attr(755,root,root) %{_datadir}/%{name}/cbuildbot
99%attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
100%attr(755,root,root) %{_datadir}/%{name}/codereview.settings
101%attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
102%attr(755,root,root) %{_datadir}/%{name}/cros
103%attr(755,root,root) %{_datadir}/%{name}/cros_sdk
104%attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
105%attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
106%attr(755,root,root) %{_datadir}/%{name}/drover
107%attr(755,root,root) %{_datadir}/%{name}/fetch
108%attr(755,root,root) %{_datadir}/%{name}/gcl
109%attr(755,root,root) %{_datadir}/%{name}/gclient
110%attr(755,root,root) %{_datadir}/%{name}/git-cl
111%attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
112%attr(755,root,root) %{_datadir}/%{name}/git-crsync
113%attr(755,root,root) %{_datadir}/%{name}/git-crup
114%attr(755,root,root) %{_datadir}/%{name}/git-gs
115%attr(755,root,root) %{_datadir}/%{name}/git-lkgr
e9bf62fa 116%attr(755,root,root) %{_datadir}/%{name}/git-number
f59bfbe1
ER
117%attr(755,root,root) %{_datadir}/%{name}/git-runhooks
118%attr(755,root,root) %{_datadir}/%{name}/git-try
e9bf62fa 119%attr(755,root,root) %{_datadir}/%{name}/gn
f59bfbe1 120%attr(755,root,root) %{_datadir}/%{name}/hammer
2c66fa69 121%attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
f59bfbe1
ER
122%attr(755,root,root) %{_datadir}/%{name}/pylint
123%attr(755,root,root) %{_datadir}/%{name}/pylintrc
124%attr(755,root,root) %{_datadir}/%{name}/repo
125%attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
126%attr(755,root,root) %{_datadir}/%{name}/weekly
127%attr(755,root,root) %{_datadir}/%{name}/wtf
128
129%{_datadir}/%{name}/*.py
130%{_datadir}/%{name}/profile.xml
131%{_datadir}/%{name}/git-templates/
132%{_datadir}/%{name}/git_utils/
133%{_datadir}/%{name}/recipes/
134%{_datadir}/%{name}/support/
135%{_datadir}/%{name}/third_party/
136%{_datadir}/%{name}/zsh-goodies/
This page took 0.068052 seconds and 4 git commands to generate.