]> git.pld-linux.org Git - packages/depot_tools.git/blame - depot_tools.spec
fix gcl (imports cpplint and cpplint_chromium)
[packages/depot_tools.git] / depot_tools.spec
CommitLineData
92eda2a9 1%define snap 20130619
0afdc21d 2%define rel 0.8
e2970781
ER
3Summary: A package of scripts called used to manage checkouts and code reviews
4Name: depot_tools
5Version: 0.1
6Release: 0.%{snap}.%{rel}
7License: BSD
8Group: Development/Tools
92eda2a9
ER
9Source0: https://src.chromium.org/svn/trunk/tools/depot_tools.zip?/%{name}-svn%{snap}.zip
10# Source0-md5: 6cf6483d6da8d15848cbaa8857aae3ae
e2970781 11URL: http://dev.chromium.org/developers/how-tos/depottools
92eda2a9 12BuildRequires: unzip
e2970781 13Requires: python
f59bfbe1 14BuildArch: noarch
e2970781
ER
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Chromium uses a package of scripts, the depot_tools, to manage
19interaction with the Chromium source code repository and the Chromium
7bd89abe 20development process. It contains the following utilities:
e2970781 21
7bd89abe
ER
22- gclient: Meta-checkout tool managing both subversion and git
23 checkouts. It is similar to repo tool except that it works on Linux,
24 OS X, and Windows and supports both svn and git. On the other hand,
25 gclient doesn't integrate any code review functionality.
e2970781
ER
26- gcl: Rietveld code review tool for subversion. The gcl tool runs
27 presubmit scripts.
28- git-cl: Rietveld code review tool for git. The git-cl tool runs
29 presubmit scripts.
30- hammer: (Obsolete) Wrapper script for building Chromium with the
31 SCons software construction tool.
32- drover: Quickly revert svn commits.
7bd89abe 33- cpplint.py: Checks for C++ style compliance.
e2970781
ER
34- presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
35- repo: The repo tool.
36- trychange.py: Try server tool. It is wrapped by gcl try and git-try.
37- git-try: Try change tool for git users
38- wtf: Displays the active git branches in a chromium os checkout.
39- weekly: Displays the log of checkins for a particular developer
40 since a particular date for git checkouts.
41- git-gs: Wrapper for git grep with relevant source types.
42- zsh-goodies: Completion for zsh users.
43
44%prep
92eda2a9
ER
45%setup -qc
46mv depot_tools/* .
47rm -r depot_tools
e2970781 48
2c66fa69
ER
49cat > py-wrap.sh <<'EOF'
50#!/bin/sh
51exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
52EOF
53chmod +x *.sh
0afdc21d 54ln -s git_cl.py git-cl.py
2c66fa69 55
e2970781 56# python 2.4 components
92eda2a9 57rm -r third_party/pymox
e2970781 58
b03a4c59
ER
59# screw binaries and shipped dependencies and things useless to this platform
60rm ninja*
61find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
f59bfbe1
ER
62rm create-ntfs-junction.c
63
64# tests
65rm -r testing_support
66rm -r tests
67
68# other junk
69rm -r bootstrap
b03a4c59 70
e2970781
ER
71%install
72rm -rf $RPM_BUILD_ROOT
2c66fa69 73install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
e2970781 74cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
f59bfbe1
ER
75# already in %doc
76rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
77
2c66fa69
ER
78for a in gclient gcl git-cl; do
79 ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
80done
e2970781
ER
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(644,root,root,755)
87%doc LICENSE README README.gclient
2c66fa69 88%attr(755,root,root) %{_bindir}/gcl
e2970781 89%attr(755,root,root) %{_bindir}/gclient
2c66fa69 90%attr(755,root,root) %{_bindir}/git-cl
92eda2a9 91%dir %{_datadir}/%{name}
f59bfbe1
ER
92%attr(755,root,root) %{_datadir}/%{name}/apply_issue
93%attr(755,root,root) %{_datadir}/%{name}/cbuildbot
94%attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
95%attr(755,root,root) %{_datadir}/%{name}/codereview.settings
96%attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
97%attr(755,root,root) %{_datadir}/%{name}/cros
98%attr(755,root,root) %{_datadir}/%{name}/cros_sdk
99%attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
100%attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
101%attr(755,root,root) %{_datadir}/%{name}/drover
102%attr(755,root,root) %{_datadir}/%{name}/fetch
103%attr(755,root,root) %{_datadir}/%{name}/gcl
104%attr(755,root,root) %{_datadir}/%{name}/gclient
105%attr(755,root,root) %{_datadir}/%{name}/git-cl
106%attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
107%attr(755,root,root) %{_datadir}/%{name}/git-crsync
108%attr(755,root,root) %{_datadir}/%{name}/git-crup
109%attr(755,root,root) %{_datadir}/%{name}/git-gs
110%attr(755,root,root) %{_datadir}/%{name}/git-lkgr
111%attr(755,root,root) %{_datadir}/%{name}/git-runhooks
112%attr(755,root,root) %{_datadir}/%{name}/git-try
113%attr(755,root,root) %{_datadir}/%{name}/hammer
2c66fa69 114%attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
f59bfbe1
ER
115%attr(755,root,root) %{_datadir}/%{name}/pylint
116%attr(755,root,root) %{_datadir}/%{name}/pylintrc
117%attr(755,root,root) %{_datadir}/%{name}/repo
118%attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
119%attr(755,root,root) %{_datadir}/%{name}/weekly
120%attr(755,root,root) %{_datadir}/%{name}/wtf
121
122%{_datadir}/%{name}/*.py
123%{_datadir}/%{name}/profile.xml
124%{_datadir}/%{name}/git-templates/
125%{_datadir}/%{name}/git_utils/
126%{_datadir}/%{name}/recipes/
127%{_datadir}/%{name}/support/
128%{_datadir}/%{name}/third_party/
129%{_datadir}/%{name}/zsh-goodies/
This page took 0.097538 seconds and 4 git commands to generate.