]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
obsolete gclient
[packages/depot_tools.git] / depot_tools.spec
1 %define         subver  20131210
2 %define         rel             0.12
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{subver}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        %{name}-%{subver}-aeab41a.tar.xz
10 # Source0-md5:  5dd469c8ec03d03d48b7db886475bbfa
11 Patch0:         adjust-path.patch
12 URL:            http://dev.chromium.org/developers/how-tos/depottools
13 BuildRequires:  tar >= 1:1.22
14 BuildRequires:  xz
15 Requires:       python
16 Obsoletes:      gclient
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Chromium uses a package of scripts, the depot_tools, to manage
22 interaction with the Chromium source code repository and the Chromium
23 development process. It contains the following utilities:
24
25 - gclient: Meta-checkout tool managing both subversion and git
26   checkouts. It is similar to repo tool except that it works on Linux,
27   OS X, and Windows and supports both svn and git. On the other hand,
28   gclient doesn't integrate any code review functionality.
29 - gcl: Rietveld code review tool for subversion. The gcl tool runs
30   presubmit scripts.
31 - git-cl: Rietveld code review tool for git. The git-cl tool runs
32   presubmit scripts.
33 - hammer: (Obsolete) Wrapper script for building Chromium with the
34   SCons software construction tool.
35 - drover: Quickly revert svn commits.
36 - cpplint.py: Checks for C++ style compliance.
37 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
38 - repo: The repo tool.
39 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
40 - git-try: Try change tool for git users
41 - wtf: Displays the active git branches in a chromium os checkout.
42 - weekly: Displays the log of checkins for a particular developer
43   since a particular date for git checkouts.
44 - git-gs: Wrapper for git grep with relevant source types.
45 - zsh-goodies: Completion for zsh users.
46
47 %prep
48 %setup -qn %{name}-%{subver}
49 %patch0 -p1
50
51 cat > py-wrap.sh <<'EOF'
52 #!/bin/sh
53 exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
54 EOF
55 chmod +x *.sh
56 ln -s git_cl.py git-cl.py
57
58 # python 2.4 components
59 rm -r third_party/pymox
60
61 # screw binaries and shipped dependencies and things useless to this platform
62 rm ninja*
63 find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
64 rm create-ntfs-junction.c
65
66 # tests
67 rm -r testing_support
68 rm -r tests
69
70 # other irrelevant junk
71 rm -r bootstrap
72 rm .gitignore
73 rm OWNERS WATCHLISTS
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
78 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
79 # already in %doc
80 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
81
82 for a in gclient gcl git-cl fetch; do
83         ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
84 done
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc LICENSE README README.gclient
92 %attr(755,root,root) %{_bindir}/gcl
93 %attr(755,root,root) %{_bindir}/gclient
94 %attr(755,root,root) %{_bindir}/git-cl
95 %attr(755,root,root) %{_bindir}/fetch
96 %dir %{_datadir}/%{name}
97 %attr(755,root,root) %{_datadir}/%{name}/apply_issue
98 %attr(755,root,root) %{_datadir}/%{name}/cbuildbot
99 %attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
100 %attr(755,root,root) %{_datadir}/%{name}/codereview.settings
101 %attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
102 %attr(755,root,root) %{_datadir}/%{name}/cros
103 %attr(755,root,root) %{_datadir}/%{name}/cros_sdk
104 %attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
105 %attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
106 %attr(755,root,root) %{_datadir}/%{name}/drover
107 %attr(755,root,root) %{_datadir}/%{name}/fetch
108 %attr(755,root,root) %{_datadir}/%{name}/gcl
109 %attr(755,root,root) %{_datadir}/%{name}/gclient
110 %attr(755,root,root) %{_datadir}/%{name}/git-cl
111 %attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
112 %attr(755,root,root) %{_datadir}/%{name}/git-crsync
113 %attr(755,root,root) %{_datadir}/%{name}/git-crup
114 %attr(755,root,root) %{_datadir}/%{name}/git-gs
115 %attr(755,root,root) %{_datadir}/%{name}/git-lkgr
116 %attr(755,root,root) %{_datadir}/%{name}/git-number
117 %attr(755,root,root) %{_datadir}/%{name}/git-runhooks
118 %attr(755,root,root) %{_datadir}/%{name}/git-try
119 %attr(755,root,root) %{_datadir}/%{name}/gn
120 %attr(755,root,root) %{_datadir}/%{name}/hammer
121 %attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
122 %attr(755,root,root) %{_datadir}/%{name}/pylint
123 %attr(755,root,root) %{_datadir}/%{name}/pylintrc
124 %attr(755,root,root) %{_datadir}/%{name}/repo
125 %attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
126 %attr(755,root,root) %{_datadir}/%{name}/weekly
127 %attr(755,root,root) %{_datadir}/%{name}/wtf
128
129 %{_datadir}/%{name}/*.py
130 %{_datadir}/%{name}/profile.xml
131 %{_datadir}/%{name}/git-templates/
132 %{_datadir}/%{name}/git_utils/
133 %{_datadir}/%{name}/recipes/
134 %{_datadir}/%{name}/support/
135 %{_datadir}/%{name}/third_party/
136 %{_datadir}/%{name}/zsh-goodies/
This page took 0.146717 seconds and 3 git commands to generate.