]> git.pld-linux.org Git - packages/deltarpm.git/blob - deltarpm.spec
- up to 3.6 (git snapshot)
[packages/deltarpm.git] / deltarpm.spec
1 %define         subver  20110223
2 %define         rel             1
3 Summary:        Create deltas between rpms
4 Summary(pl.UTF-8):      Generowanie różnic między pakietami rpm
5 Name:           deltarpm
6 Version:        3.6
7 Release:        0.%{subver}git.%{rel}
8 License:        BSD
9 Group:          Base
10 Source0:        http://pkgs.fedoraproject.org/repo/pkgs/deltarpm/%{name}-git-%{subver}.tar.bz2/70f8884be63614ca7c3fc888cf20ebc8/deltarpm-git-%{subver}.tar.bz2
11 # Source0-md5:  70f8884be63614ca7c3fc888cf20ebc8
12 Patch0:         %{name}-3.4-no-skip-doc.patch
13 Patch1:         %{name}-3.4-pld.patch
14 Patch2:         %{name}-rpmdumpheader.patch
15 URL:            http://www.novell.com/products/linuxpackages/opensuse/deltarpm.html
16 BuildRequires:  bzip2-devel
17 BuildRequires:  popt-devel
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-devel
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 BuildRequires:  xz-devel
23 BuildRequires:  zlib-static
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A deltarpm contains the difference between an old and a new version of
28 a rpm, which makes it possible to recreate the new rpm from the
29 deltarpm and the old one. You don't have to have a copy of the old
30 rpm, deltarpms can also work with installed rpms.
31
32 %description -l pl.UTF-8
33 Deltarpm zawiera różnice pomiędzy starą i nową wersją pakietu rpm,
34 pozwalając na stworzenie nowej wersji na podstawie delty i starej
35 wersji. Nie jest konieczne posiadanie kopii starego pakietu rpm,
36 deltarpm obsługuje także już zainstalowane pakiety.
37
38 %package -n drpmsync
39 Summary:        Sync a file tree with deltarpms
40 Group:          Base
41 Requires:       %{name} = %{version}-%{release}
42
43 %description -n drpmsync
44 This package contains a tool to sync a file tree with deltarpms.
45
46 %package -n deltaiso
47 Summary:        Create deltas between isos containing rpms
48 Group:          Base
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n deltaiso
52 This package contains tools for creating and using deltasisos, a
53 difference between an old and a new iso containing rpms.
54
55 %package -n python-deltarpm
56 Summary:        Python bindings for deltarpm
57 Group:          Base
58 Requires:       %{name} = %{version}-%{release}
59
60 %description -n python-deltarpm
61 This package contains python bindings for deltarpm.
62
63 %prep
64 %setup -q -n %{name}-git-%{subver}
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68
69 %{__sed} -i -e 's/python3//' Makefile
70
71 %build
72 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags} -I/usr/include/rpm" \
73         bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
74         zlibbundled='' zlibldflags='-lz' zlibcppflags=''
75
76 %{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}" \
77         bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
78         zlibbundled='' zlibldflags='-lz' zlibcppflags='' \
79         python
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
87 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
88 %py_postclean
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc LICENSE.BSD README
96 %attr(755,root,root) %{_bindir}/applydeltarpm
97 %attr(755,root,root) %{_bindir}/combinedeltarpm
98 %attr(755,root,root) %{_bindir}/makedeltarpm
99 %attr(755,root,root) %{_bindir}/rpmdumpheader
100 %{_mandir}/man8/applydeltarpm.8*
101 %{_mandir}/man8/combinedeltarpm.8*
102 %{_mandir}/man8/makedeltarpm.8*
103
104 %files -n deltaiso
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/applydeltaiso
107 %attr(755,root,root) %{_bindir}/fragiso
108 %attr(755,root,root) %{_bindir}/makedeltaiso
109 %{_mandir}/man8/applydeltaiso*
110 %{_mandir}/man8/makedeltaiso*
111
112 %files -n drpmsync
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/drpmsync
115 %{_mandir}/man8/drpmsync*
116
117 %files -n python-deltarpm
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
120 %{py_sitedir}/deltarpm.py[co]
This page took 0.047238 seconds and 3 git commands to generate.