]> git.pld-linux.org Git - packages/deltarpm.git/commitdiff
- up to 3.6 (git snapshot) auto/th/deltarpm-3_6-0_20110223git_1
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 7 Nov 2011 20:43:47 +0000 (20:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added drpmsync, drpmsync, python-deltarpm packages

Changed files:
    deltarpm-3.4-pld.patch -> 1.5
    deltarpm.spec -> 1.12

deltarpm-3.4-pld.patch
deltarpm.spec

index fba615d248a0220dc5c10aa3253448c09aa5f6b4..9e181e64f9979a7e26e19e838a28881527eaa54b 100644 (file)
@@ -1,4 +1,3 @@
-diff -u deltarpm-3.5/cfile.c deltarpm-pld/cfile.c
 --- deltarpm-3.5/cfile.c       2009-07-29 14:50:48.000000000 +0200
 +++ deltarpm-pld/cfile.c       2010-06-17 01:27:15.000000000 +0200
 @@ -658,7 +658,8 @@
@@ -30,49 +29,31 @@ diff -u deltarpm-3.5/cfile.c deltarpm-pld/cfile.c
        deflevel = 9;
        break;
      default:
-diff -u deltarpm-3.5-old/makedeltarpm.c deltarpm/makedeltarpm.c
---- deltarpm-3.5-old/makedeltarpm.c    2009-08-18 15:18:13.000000000 +0200
-+++ deltarpm/makedeltarpm.c    2010-06-17 01:01:12.000000000 +0200
-@@ -833,13 +833,16 @@
-     bfd = cfile_open(CFILE_OPEN_RD, CFILE_IO_BUFFER, newcpio, CFILE_COMP_UN, newcpiolen, 0, 0);
-   else
-     bfd = cfile_open(CFILE_OPEN_RD, fd, 0, CFILE_COMP_XX, CFILE_LEN_UNLIMITED, 0, 0);
-+  
-   if (!bfd)
-     {
+--- deltarpm-git-20110223/makedeltarpm.c~      2011-11-07 22:27:12.000000000 +0200
++++ deltarpm-git-20110223/makedeltarpm.c       2011-11-07 22:27:52.884618404 +0200
+@@ -1080,11 +1080,13 @@
        fprintf(stderr, "payload open failed\n");
        exit(1);
      }
-+    
-   if (verbose && !alone)
-     fprintf(vfp, "reading old rpm...\n");
-+  
-   if (rpmonly)
++/*
+   if (cfile_detect_rsync(newbz))
      {
-       while ((l = bfd->read(bfd, buf, sizeof(buf))) > 0)
-@@ -1188,11 +1198,11 @@
-         fprintf(stderr, "payload open failed\n");
-         exit(1);
-       }
--      if (cfile_detect_rsync(newbz))
-+/*      if (cfile_detect_rsync(newbz))
-       {
-         fprintf(stderr, "detect_rsync failed\n");
-         exit(1);
--      }
-+      }*/
-       targetcomp = newbz->comp;
-       if ((payloadflags = headstring(d.h, TAG_PAYLOADFLAGS)) != 0)
-       if (*payloadflags >= '1' && *payloadflags <= '9')
-diff -u deltarpm-3.5/Makefile deltarpm-pld/Makefile
---- deltarpm-3.5/Makefile      2009-07-21 16:27:17.000000000 +0200
-+++ deltarpm-pld/Makefile      2010-06-16 22:42:11.000000000 +0200
-@@ -1,6 +1,6 @@
+       fprintf(stderr, "detect_rsync failed\n");
+       exit(1);
+     }
++*/
+   targetcomp = newbz->comp;
+   if ((payloadflags = headstring(d.h, TAG_PAYLOADFLAGS)) != 0)
+     if (*payloadflags >= '1' && *payloadflags <= '9')
+--- deltarpm-git-20110223/Makefile~    2011-02-19 18:53:23.000000000 +0200
++++ deltarpm-git-20110223/Makefile     2011-11-07 22:29:01.877800526 +0200
+@@ -1,7 +1,7 @@
 -prefix=/usr/local
 +prefix=/usr
  bindir=$(prefix)/bin
+ libdir=$(prefix)/lib
 -mandir=$(prefix)/man
 +mandir=$(prefix)/share/man
  rpmdumpheader=$(bindir)/rpmdumpheader
  zlibdir=zlib-1.2.2.f-rsyncable
- CFLAGS = -O2 -Wall -g
+ zlibbundled=$(zlibdir)/libz.a
index 7011a2e9fccfc7008353da8054bc144d0c6046ba..2691430e43062fe7a8f0b6832df32616b9767a9f 100644 (file)
@@ -1,18 +1,25 @@
+%define                subver  20110223
+%define                rel             1
 Summary:       Create deltas between rpms
 Summary(pl.UTF-8):     Generowanie różnic między pakietami rpm
 Name:          deltarpm
-Version:       3.5
-Release:       6
+Version:       3.6
+Release:       0.%{subver}git.%{rel}
 License:       BSD
 Group:         Base
-Source0:       ftp://ftp.suse.com/pub/projects/deltarpm/%{name}-%{version}.tar.bz2
-# Source0-md5: df656d5cbba98e4cc1fc8e18a31f1f3b
+Source0:       http://pkgs.fedoraproject.org/repo/pkgs/deltarpm/%{name}-git-%{subver}.tar.bz2/70f8884be63614ca7c3fc888cf20ebc8/deltarpm-git-%{subver}.tar.bz2
+# Source0-md5: 70f8884be63614ca7c3fc888cf20ebc8
 Patch0:                %{name}-3.4-no-skip-doc.patch
 Patch1:                %{name}-3.4-pld.patch
 Patch2:                %{name}-rpmdumpheader.patch
-URL:           http://www.novell.com/products/linuxpackages/professional/deltarpm.html
+URL:           http://www.novell.com/products/linuxpackages/opensuse/deltarpm.html
 BuildRequires: bzip2-devel
+BuildRequires: popt-devel
+BuildRequires: python-devel
 BuildRequires: rpm-devel
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: xz-devel
 BuildRequires: zlib-static
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,28 +35,86 @@ pozwalając na stworzenie nowej wersji na podstawie delty i starej
 wersji. Nie jest konieczne posiadanie kopii starego pakietu rpm,
 deltarpm obsługuje także już zainstalowane pakiety.
 
+%package -n drpmsync
+Summary:       Sync a file tree with deltarpms
+Group:         Base
+Requires:      %{name} = %{version}-%{release}
+
+%description -n drpmsync
+This package contains a tool to sync a file tree with deltarpms.
+
+%package -n deltaiso
+Summary:       Create deltas between isos containing rpms
+Group:         Base
+Requires:      %{name} = %{version}-%{release}
+
+%description -n deltaiso
+This package contains tools for creating and using deltasisos, a
+difference between an old and a new iso containing rpms.
+
+%package -n python-deltarpm
+Summary:       Python bindings for deltarpm
+Group:         Base
+Requires:      %{name} = %{version}-%{release}
+
+%description -n python-deltarpm
+This package contains python bindings for deltarpm.
+
 %prep
-%setup -q
+%setup -q -n %{name}-git-%{subver}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 
+%{__sed} -i -e 's/python3//' Makefile
+
 %build
-%{__make} \
-       CFLAGS="%{rpmcflags} -I/usr/include/rpm" zlibdir=%{_libdir}\
-       CC="%{__cc}"
+%{__make} CC="%{__cc}" CFLAGS="%{rpmcflags} -I/usr/include/rpm" \
+       bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
+       zlibbundled='' zlibldflags='-lz' zlibcppflags=''
+
+%{__make} CC="%{__cc}" CFLAGS="%{rpmcflags}" \
+       bindir=%{_bindir} libdir=%{_libdir} mandir=%{_mandir} prefix=%{_prefix} \
+       zlibbundled='' zlibldflags='-lz' zlibcppflags='' \
+       python
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_postclean
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc LICENSE.BSD README
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man8/*
+%attr(755,root,root) %{_bindir}/applydeltarpm
+%attr(755,root,root) %{_bindir}/combinedeltarpm
+%attr(755,root,root) %{_bindir}/makedeltarpm
+%attr(755,root,root) %{_bindir}/rpmdumpheader
+%{_mandir}/man8/applydeltarpm.8*
+%{_mandir}/man8/combinedeltarpm.8*
+%{_mandir}/man8/makedeltarpm.8*
+
+%files -n deltaiso
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/applydeltaiso
+%attr(755,root,root) %{_bindir}/fragiso
+%attr(755,root,root) %{_bindir}/makedeltaiso
+%{_mandir}/man8/applydeltaiso*
+%{_mandir}/man8/makedeltaiso*
+
+%files -n drpmsync
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/drpmsync
+%{_mandir}/man8/drpmsync*
+
+%files -n python-deltarpm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
+%{py_sitedir}/deltarpm.py[co]
This page took 0.126525 seconds and 4 git commands to generate.