]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- updated for 0.80
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 %define         dbus_version    1.1
7 %define         expat_version   1:1.95.5
8 %define         glib_version    1:2.10.1
9 #
10 Summary:        GLib-based library for using D-BUS
11 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
12 Name:           dbus-glib
13 Version:        0.80
14 Release:        1
15 License:        AFL v2.1 or GPL v2
16 Group:          Libraries
17 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
18 # Source0-md5:  86ea60ba2118a1b9deafe8257f6a6a1a
19 Source1:        dbus-bus-introspect.xml
20 Patch0:         %{name}-configure.patch
21 Patch1:         %{name}-as-needed.patch
22 URL:            http://www.freedesktop.org/Software/DBusBindings
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake >= 1:1.9
25 BuildRequires:  dbus-devel >= %{dbus_version}
26 BuildRequires:  expat-devel >= %{expat_version}
27 BuildRequires:  gettext-devel
28 BuildRequires:  glib2-devel >= %{glib_version}
29 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.98
33 Requires:       dbus-libs >= %{dbus_version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 D-BUS add-on library to integrate the standard D-BUS library with the
38 GLib thread abstraction and main loop.
39
40 %description -l pl.UTF-8
41 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
42 z abstrakcją wątków i główną pętlą GLib.
43
44 %package devel
45 Summary:        Header files for GLib-based library for using D-BUS
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-devel >= %{dbus_version}
50 Requires:       glib2-devel >= %{glib2_version}
51
52 %description devel
53 Header files for GLib-based library for using D-BUS.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
57
58 %package static
59 Summary:        Static GLib-based library for using D-BUS
60 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GLib-based library for using D-BUS.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka do używania D-BUS oparta o GLib.
69
70 %package apidocs
71 Summary:        D-BUS-GLib API documentation
72 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
73 Group:          Documentation
74 Requires:       gtk-doc-common
75
76 %description apidocs
77 D-BUS-GLib API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API D-BUS-GLib.
81
82 %package -n bash-completion-dbus
83 Summary:        bash-completion for dbus-send
84 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla dbus-send
85 Group:          Applications/Shells
86 Requires:       bash-completion
87
88 %description -n bash-completion-dbus
89 This package provides bash-completion for dbus-send.
90
91 %description -n bash-completion-dbus -l pl.UTF-8
92 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98
99 %if %{without apidocs}
100 echo 'EXTRA_DIST=' > gtk-doc.make
101 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
102 %endif
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         %{!?with_apidocs:--disable-gtk-doc} \
112         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
113         %{!?with_static_libs:--disable-static} \
114         --with-xml=expat
115
116 cp %{SOURCE1} tools
117
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         profiledir=/etc/bash_completion.d
126
127 mv -f $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 # AFL not in common-licenses, so COPYING included
138 %doc AUTHORS COPYING ChangeLog NEWS README
139 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/dbus-binding-tool
145 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
146 %{_libdir}/libdbus-glib-1.la
147 %{_includedir}/dbus*/dbus/dbus-glib*.h
148 %{_includedir}/dbus*/dbus/dbus-gtype-specialized.h
149 %{_pkgconfigdir}/dbus-glib-1.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libdbus-glib-1.a
155 %endif
156
157 %if %{with apidocs}
158 %files apidocs
159 %defattr(644,root,root,755)
160 %{_gtkdocdir}/dbus-glib
161 %endif
162
163 %files -n bash-completion-dbus
164 %defattr(644,root,root,755)
165 /etc/bash_completion.d/dbus
166 %attr(755,root,root) %{_libdir}/dbus-bash-completion-helper
This page took 0.10528 seconds and 3 git commands to generate.