]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- ugh, bash-completion-dbus contains binary helper, so not noarch; release 2
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 %define         dbus_version    1.8
7 %define         expat_version   1:1.95.5
8 %define         glib2_version   1:2.40
9 Summary:        GLib-based library for using D-BUS
10 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
11 Name:           dbus-glib
12 Version:        0.112
13 Release:        2
14 License:        AFL v2.1 or GPL v2
15 Group:          Libraries
16 Source0:        https://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
17 # Source0-md5:  021e6c8a288df02c227e4aafbf7e7527
18 Patch0:         %{name}-configure.patch
19 URL:            https://www.freedesktop.org/wiki/Software/DBusBindings
20 BuildRequires:  autoconf >= 2.52
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  dbus-devel >= %{dbus_version}
23 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
24 BuildRequires:  expat-devel >= %{expat_version}
25 BuildRequires:  gettext-tools
26 BuildRequires:  glib2-devel >= %{glib2_version}
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
28 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.14}
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  pkgconfig >= 1:0.28
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.527
33 Requires:       dbus-libs >= %{dbus_version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 D-BUS add-on library to integrate the standard D-BUS library with the
38 GLib thread abstraction and main loop.
39
40 %description -l pl.UTF-8
41 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
42 z abstrakcją wątków i główną pętlą GLib.
43
44 %package devel
45 Summary:        Header files for GLib-based library for using D-BUS
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-devel >= %{dbus_version}
50 Requires:       glib2-devel >= %{glib2_version}
51
52 %description devel
53 Header files for GLib-based library for using D-BUS.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
57
58 %package static
59 Summary:        Static GLib-based library for using D-BUS
60 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GLib-based library for using D-BUS.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka do używania D-BUS oparta o GLib.
69
70 %package apidocs
71 Summary:        D-BUS-GLib API documentation
72 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
73 Group:          Documentation
74 Requires:       gtk-doc-common
75 BuildArch:      noarch
76
77 %description apidocs
78 D-BUS-GLib API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API D-BUS-GLib.
82
83 %package -n bash-completion-dbus
84 Summary:        bash-completion for dbus-send
85 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla dbus-send
86 Group:          Applications/Shells
87 Requires:       bash-completion
88
89 %description -n bash-completion-dbus
90 This package provides bash-completion for dbus-send.
91
92 %description -n bash-completion-dbus -l pl.UTF-8
93 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 #{__gtkdocize}
101 #{__libtoolize}
102 #{__aclocal}
103 #{__autoconf}
104 #{__autoheader}
105 #{__automake}
106 %configure \
107         %{__disable apidocs gtk-doc} \
108         %{__disable static_libs static} \
109         --disable-silent-rules \
110         --with-html-dir=%{_gtkdocdir}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         profiledir=/etc/bash_completion.d
120
121 %{__mv} $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
122 # obsoleted by pkg-config
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdbus-glib-1.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 # AFL not in common-licenses, so COPYING included
134 %doc AUTHORS COPYING NEWS README
135 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/dbus-binding-tool
141 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
142 %{_mandir}/man1/dbus-binding-tool.1*
143 %{_includedir}/dbus-1.0/dbus/dbus-glib*.h
144 %{_includedir}/dbus-1.0/dbus/dbus-gtype-specialized.h
145 %{_includedir}/dbus-1.0/dbus/dbus-gvalue-parse-variant.h
146 %{_pkgconfigdir}/dbus-glib-1.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libdbus-glib-1.a
152 %endif
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %{_gtkdocdir}/dbus-glib
158 %endif
159
160 %files -n bash-completion-dbus
161 %defattr(644,root,root,755)
162 /etc/bash_completion.d/dbus
163 %attr(755,root,root) %{_libexecdir}/dbus-bash-completion-helper
This page took 0.037975 seconds and 4 git commands to generate.