]> git.pld-linux.org Git - packages/dbus-glib.git/blob - dbus-glib.spec
- don't explicitly enable docs rebuilding, it's broken; but package apidocs by default
[packages/dbus-glib.git] / dbus-glib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5
6 %define         dbus_version    1.2.16
7 %define         expat_version   1:1.95.5
8 %define         glib2_version   1:2.26
9 Summary:        GLib-based library for using D-BUS
10 Summary(pl.UTF-8):      Biblioteka do używania D-BUS oparta o GLib
11 Name:           dbus-glib
12 Version:        0.100.1
13 Release:        1
14 License:        AFL v2.1 or GPL v2
15 Group:          Libraries
16 Source0:        http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
17 # Source0-md5:  d758967b70ea3d5318b62839d5bd440f
18 Patch0:         %{name}-configure.patch
19 Patch1:         %{name}-am.patch
20 URL:            http://www.freedesktop.org/Software/DBusBindings
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  dbus-devel >= %{dbus_version}
24 %{?with_apidocs:BuildRequires:  docbook-dtd412-xml}
25 BuildRequires:  expat-devel >= %{expat_version}
26 BuildRequires:  gettext-devel
27 BuildRequires:  glib2-devel >= %{glib2_version}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
29 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.8}
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.527
33 Requires:       dbus-libs >= %{dbus_version}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 D-BUS add-on library to integrate the standard D-BUS library with the
38 GLib thread abstraction and main loop.
39
40 %description -l pl.UTF-8
41 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
42 z abstrakcją wątków i główną pętlą GLib.
43
44 %package devel
45 Summary:        Header files for GLib-based library for using D-BUS
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       dbus-devel >= %{dbus_version}
50 Requires:       glib2-devel >= %{glib2_version}
51
52 %description devel
53 Header files for GLib-based library for using D-BUS.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki do używania D-BUS opartej o GLib.
57
58 %package static
59 Summary:        Static GLib-based library for using D-BUS
60 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o GLib
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static GLib-based library for using D-BUS.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka do używania D-BUS oparta o GLib.
69
70 %package apidocs
71 Summary:        D-BUS-GLib API documentation
72 Summary(pl.UTF-8):      Dokumentacja API D-BUS-GLib
73 Group:          Documentation
74 Requires:       gtk-doc-common
75
76 %description apidocs
77 D-BUS-GLib API documentation.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API D-BUS-GLib.
81
82 %package -n bash-completion-dbus
83 Summary:        bash-completion for dbus-send
84 Summary(pl.UTF-8):      Bashowe uzupełnianie poleceń dla dbus-send
85 Group:          Applications/Shells
86 Requires:       bash-completion
87
88 %description -n bash-completion-dbus
89 This package provides bash-completion for dbus-send.
90
91 %description -n bash-completion-dbus -l pl.UTF-8
92 Ten pakiet dostarcza bashowe uzupełnianie poleceń dla dbus-send.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__gtkdocize}
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         %{__disable apidocs gtk-doc} \
108         %{__disable static_libs static} \
109         --disable-silent-rules \
110         --with-html-dir=%{_gtkdocdir}
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         profiledir=/etc/bash_completion.d
120
121 mv -f $RPM_BUILD_ROOT/etc/bash_completion.d/{dbus-bash-completion.sh,dbus}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 # AFL not in common-licenses, so COPYING included
132 %doc AUTHORS COPYING ChangeLog NEWS README
133 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libdbus-glib-1.so.2
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/dbus-binding-tool
139 %attr(755,root,root) %{_libdir}/libdbus-glib-1.so
140 %{_libdir}/libdbus-glib-1.la
141 %{_mandir}/man1/dbus-binding-tool.1*
142 %{_includedir}/dbus-1.0/dbus/dbus-glib*.h
143 %{_includedir}/dbus-1.0/dbus/dbus-gtype-specialized.h
144 %{_includedir}/dbus-1.0/dbus/dbus-gvalue-parse-variant.h
145 %{_pkgconfigdir}/dbus-glib-1.pc
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libdbus-glib-1.a
151 %endif
152
153 %if %{with apidocs}
154 %files apidocs
155 %defattr(644,root,root,755)
156 %{_gtkdocdir}/dbus-glib
157 %endif
158
159 %files -n bash-completion-dbus
160 %defattr(644,root,root,755)
161 /etc/bash_completion.d/dbus
162 %attr(755,root,root) %{_libdir}/dbus-bash-completion-helper
This page took 0.090316 seconds and 3 git commands to generate.